Bug 33631 - Can't remove line/paragraph after table
Summary: Can't remove line/paragraph after table
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: low enhancement
Assignee: Not Assigned
URL: https://bugs.launchpad.net/ubuntu/+so...
Whiteboard:
Keywords:
: 95907 101752 (view as bug list)
Depends on:
Blocks: Writer-Tables-Enhancements
  Show dependency treegraph
 
Reported: 2011-01-27 17:21 UTC by Christopher M. Penalver
Modified: 2019-01-21 10:27 UTC (History)
10 users (show)

See Also:
Crash report or crash signature:


Attachments
Example.odt (11.93 KB, application/vnd.oasis.opendocument.text)
2011-01-27 17:21 UTC, Christopher M. Penalver
Details
document of one page with a table and no line after the table (9.09 KB, application/vnd.oasis.opendocument.text)
2014-05-02 22:56 UTC, Jean-Baptiste Faure
Details
File exemplifying this bug. (29.95 KB, application/vnd.oasis.opendocument.text)
2015-03-24 19:34 UTC, Marnen Laibow-Koser
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Christopher M. Penalver 2011-01-27 17:21:50 UTC
Created attachment 42623 [details]
Example.odt

Downstream bug may be found at:
https://bugs.launchpad.net/ubuntu/+source/openoffice.org/+bug/254655

When a new table is created it creates an unnecessary space at the bottom of it (please see attached Example.odt).

A workaround for this is Secondary click the table -> primary click Table... -> click the Borders tab -> in the Spacing to contents area, the four fields are 0.04" by default with the Synchronize checkbox checked. Change all 4 fields to 0 -> click the OK button. However, it is more convenient if the default install had this workaround already committed.
Comment 1 Cédric Bosdonnat 2011-01-28 01:27:42 UTC
Well, this is by design... how could you add text after the table otherwise?

See the downstream conclusion... which is completely accurate:


--- Snip ---
RESOLUTION:

Not a Bug.

Go to end of paragraph in right bottom cell.
Ctrl+Shift+Delete.

Find other useful shortcut keys in the help in part "Shortcut Keys for Tables
in OpenOffice.org Writer" in chapter "Shortcut Keys for OpenOffice.org Writer.
--- Snip ---
Comment 2 Christopher M. Penalver 2011-01-28 21:09:00 UTC
Cédric Bosdonnat:

Thank you for responding quickly to this bug. 

I also noted the same thing as downstream and agree looking at it from the experienced user/developer perspective, not a bug.

Looking at it from the new(er) user, it is a big issue. I personally went through months of creating one page documents with tables at the end and making sure one line was left at the end because how to remove it was not known. I got fed up and finally made a bug ( https://bugs.launchpad.net/ubuntu/+source/openoffice.org/+bug/691296 ). Other people have also experienced this same issue and addressing this is one less thing a new user has to deal with to ease the transition from a competing suite to LibreOffice.

I (naively) searched the source code for Contents to spacing area via Places -> Search for Files to edit it and recompile, did not find it. Any suggestions?

Your understanding is appreciated.
Comment 3 Cédric Bosdonnat 2011-01-31 01:36:49 UTC
(In reply to comment #2)
> Looking at it from the new(er) user, it is a big issue. I personally went
> through months of creating one page documents with tables at the end and making
> sure one line was left at the end because how to remove it was not known. I got
> fed up and finally made a bug (
> https://bugs.launchpad.net/ubuntu/+source/openoffice.org/+bug/691296 ). Other
> people have also experienced this same issue and addressing this is one less
> thing a new user has to deal with to ease the transition from a competing suite
> to LibreOffice.

Then this is an enhancement, not a bug.

> I (naively) searched the source code for Contents to spacing area via Places ->
> Search for Files to edit it and recompile, did not find it. Any suggestions?
> 
> Your understanding is appreciated.

Sorry, but this goes far beyond the simple spacings... I fear this is no easy hack.
Comment 4 kleist 2013-04-10 05:14:57 UTC
Using LibreOffice 4.0.2.2 (Windows 7) I can't delete the empty line following the table by using "Shift+Ctrl+Del" as suggested in comment 1 (and as specified by https://help.libreoffice.org/Writer/Shortcut_Keys_for_Writer#Shortcut_Keys_for_Tables_in_LibreOffice_Writer).

So I'd call this a BUG, not an enhancement.
Comment 5 Hyogapag 2013-07-24 16:30:11 UTC
I confirm that the shortcut ctrl+shift+del doesn't do anything in LO 4.0.3.3 (Ubuntu 13.04).
Comment 6 Jean-Baptiste Faure 2014-05-02 22:56:05 UTC
Created attachment 98352 [details]
document of one page with a table and no line after the table

(In reply to comment #5)
> I confirm that the shortcut ctrl+shift+del doesn't do anything in LO 4.0.3.3
> (Ubuntu 13.04).

Help says: "If no whole cell is selected and the cursor is at the end of the table, the paragraph following the table will be deleted, unless it is the last paragraph in the document."

In current stable version, this shortcut works as designed.
You can't remove the last paragraph of the document, but you can have a table covering the entire page without a line after the table. For example by inserting the table in a frame. See attachment.

Best regards. JBF
Comment 7 Joel Madero 2014-11-03 04:45:23 UTC
NEW is appropriate status, not REOPENED.
Comment 8 Marnen Laibow-Koser 2015-03-24 19:34:17 UTC
Created attachment 114309 [details]
File exemplifying this bug.

This problem is still present in 4.4.1 release. I've attached a sample file; the table at the end goes to the end of the page, but has a useless newline after it, which makes the "page 1 of 3" in the footer incorrect.
Comment 9 Marnen Laibow-Koser 2015-03-24 19:36:48 UTC
Doesn't just affect Linux. I'm using Mac OS X 10.10.
Comment 10 Christopher M. Penalver 2015-03-24 22:33:24 UTC
Marnen Laibow-Koser, please do not add attachments to this report, as this report is scoped to the attachment noted in https://bugs.documentfoundation.org/show_bug.cgi?id=33631#c0 .

Please either attempt a reproduction on that attachment, or if your issue is completely different file a new report.

Thank you for your understanding.
Comment 11 Marnen Laibow-Koser 2015-03-25 04:09:15 UTC
(In reply to Christopher M. Penalver from comment #10)
> Marnen Laibow-Koser, please do not add attachments to this report, as this
> report is scoped to the attachment noted in
> https://bugs.documentfoundation.org/show_bug.cgi?id=33631#c0 .

The original report demonstrated a bug on version 3.3.2.  I attached a new file showing that the bug still exists on version 4.4.1.

The attachment on #c0 was the original demonstration of the bug, sure, but it seemed like it would be helpful to provide additional supporting evidence.

> 
> Please either attempt a reproduction on that attachment, or if your issue is
> completely different file a new report.

My issue is identical to the one described in #c0, as I clearly explained.  I thought it was best to provide the file that was actually giving me trouble.

I just attempted a reproduction with attachment 42623 [details], but that file does not appear to contain any tables, and therefore isn't a proper demonstration of the bug as originally described.

> 
> Thank you for your understanding.

I don't understand at all why you wouldn't want an example that reliably reproduces the bug for me on current versions.  Scoping a bug report to one particular file seems counterproductive.
Comment 12 Regina Henschel 2016-02-16 22:27:33 UTC
*** Bug 95907 has been marked as a duplicate of this bug. ***
Comment 13 Dennis Schridde 2016-05-28 09:37:29 UTC
(In reply to Jean-Baptiste Faure from comment #6)
> Help says: "If no whole cell is selected and the cursor is at the end of the
> table, the paragraph following the table will be deleted, unless it is the
> last paragraph in the document."

That's exactly my problem. My document consists of one long table. LibreOffice insists to add a blank page at the end. Having to have a paragraph at the end of the document is a serious limitation.

Maybe related: bug #60967
Comment 14 Cor Nouws 2016-08-27 10:34:26 UTC
*** Bug 101752 has been marked as a duplicate of this bug. ***
Comment 15 chuck.pobanz 2018-12-21 23:00:05 UTC
I would like to have a table as the very last item on the last page. However, this creates an extra page as noted by Dennis Schridde in Comment 13. The only work around I have found is, as stated by Jean-Baptiste Faure in comment 6, to put the table in a frame.

Libreoffice 6.1.3.2
on Linux Mint 18.3