Bug 36262 - Undo BrOffice, return to LibreOffice
Summary: Undo BrOffice, return to LibreOffice
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.4.0 Beta3
Hardware: Other All
: medium normal
Assignee: Thorsten Behrens (CIB)
URL:
Whiteboard:
Keywords:
: 35744 (view as bug list)
Depends on:
Blocks: mab3.4
  Show dependency treegraph
 
Reported: 2011-04-15 08:23 UTC by Olivier Hallot
Modified: 2011-05-05 03:55 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Olivier Hallot 2011-04-15 08:23:05 UTC
Since BrOffice.org - Projeto Brasil, the NGO that helped to build the Brazilian community and gave name to the software in Brazil, has been extincted, there is no more reason to keep the brand BrOffice inside LibreOffice, when it comes to the Brazilian locale.

The Brazilian locale now should have LibreOffice as its brand.

The following bugs were open to address the BrOffice modifications:

Bug 31770
Bug 32635
Bug 33744
Bug 32435
Bug 31098
Comment 1 Don't use this account, use tml@iki.fi 2011-04-15 09:03:17 UTC
Duplicate of bug #35744 , but as this has more information, should we mark that as a duplicate of this instead?
Comment 2 Thorsten Behrens (CIB) 2011-04-17 16:17:42 UTC
I think so.
Comment 3 Thorsten Behrens (CIB) 2011-04-17 16:18:46 UTC
*** Bug 35744 has been marked as a duplicate of this bug. ***
Comment 4 Petr Mladek 2011-04-22 02:36:04 UTC
It should be enough to do the builds without --enable-broffice configure option. 

http://cgit.freedesktop.org/libreoffice/bootstrap/commit/?h=libreoffice-3-4&id=7ad0e877067d9e72dcc7fb27160e6ad69af9a8e2 should do the job for beta3 build.

Please, reopen this bug if you still see some BrOffice traces in LO-3.4.0-beta3 builds.
Comment 5 Petr Mladek 2011-04-22 06:29:57 UTC
Heh, it was needed to also disable BrOffice in configure.in by default, see
http://cgit.freedesktop.org/libreoffice/bootstrap/commit/?h=libreoffice-3-4&id=94ccfeaccb3ffc09b244ea990eda43531764352d
Comment 6 Don't use this account, use tml@iki.fi 2011-04-26 04:44:11 UTC
I cherry-picked the two commits above to master and then removed all (I hope) BrOffice related things, changed PRODUCTNAME_BR to just PRODUCTNAME, etc.
Comment 7 Olivier Hallot 2011-04-29 14:34:01 UTC
It looks that this bug is fixed, but with one exception!

Windows installation, desktop integration, Windows control panel, Start menu.

These still contain BrOffice brand and icons names.

Information on bug 32635 may be usefull.
Comment 8 Rainer Bielefeld Retired 2011-04-29 23:20:04 UTC
Modified Version due to report date

@Olivier:
Observed with3.4Beta3?
Comment 9 Olivier Hallot 2011-04-30 05:01:03 UTC
@Rainer: Yes... 3.4 Beta 3.
Comment 10 Don't use this account, use tml@iki.fi 2011-05-02 06:19:55 UTC
I installed a pt-BR Windows in a virtual machine and can confirm, yep, both the 3.4 beta3 NSIS installer wrapper, the actual MSI installer, the Start Menu, and the list of installed programs still talk about BrOffice when run in a pt-BR installation, and use BrOffice artwork. Will attempt to fix.
Comment 11 Don't use this account, use tml@iki.fi 2011-05-02 14:08:21 UTC
The issue should now be fixed in the libreoffice-3-4 branch, too. I fixed it in a less intrusive way there for safety: I just changed the value of PRODUCTNAME_BR to LibreOffice (instead of BrOffice) in openoffice.lst. I verified that the MSI installer didn't mention BrOffice when installing on a pt-BR system, and also in the "Desinstalar ou alterar um programa" dialog I see LibreOffice and not BrOffice. (I don't have NSIS on my development machine so I can't be sure if the outer level NSIS installer uses the LibreOffice name, too.)
Comment 12 Don't use this account, use tml@iki.fi 2011-05-02 14:10:19 UTC
Ah, but when I start it, what do I see if not the large test "BrOffice 3" in the "start centre" ;)
Comment 13 Don't use this account, use tml@iki.fi 2011-05-02 14:18:32 UTC
Ah, but I had built with --enable-broffice, so hopefully that is caused by that;)
Comment 14 Don't use this account, use tml@iki.fi 2011-05-02 16:29:26 UTC
OK, now I hope the BrOffice branding is gone at least for Windows. I suspect it is still present for Mac OS X and Linux, though.
Comment 15 Don't use this account, use tml@iki.fi 2011-05-02 16:46:53 UTC
Note that there are still a couple of instances of "BrOffice" in the pt-BR translations in the libreoffice-3-4 branch. Hopefully the pt-BR l10n people will handle those.
Comment 16 Olivier Hallot 2011-05-02 17:46:38 UTC
Found one occurence in scp2/source/ooo.po and one in the help. Thanks.
Comment 17 Michael Meeks 2011-05-05 03:05:03 UTC
assuming these pointers are fixed; I just removed the unotools config hack, that covers a lot of BrOffice instances (and was the last "BrOffice" style string I could see in the code itself).

So - re-closing; should be in RC1 etc.
Comment 18 Andras Timar 2011-05-05 03:10:24 UTC
I replaced two BrOffice strings in translations, Olivier, please make sure you change them in Pootle and/or in your local file set.

helpcontent2\source\text\shared\guide.po 
scp2\source\ooo.po
Comment 19 Olivier Hallot 2011-05-05 03:55:25 UTC
@Andras: done