Bug Hunting Session
Bug 36271 - FILEOPEN impossible, General error, memory could not be read
Summary: FILEOPEN impossible, General error, memory could not be read
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
3.4.0 Beta1
Hardware: All All
: highest blocker
Assignee: Don't use this account, use tml@iki.fi
URL:
Whiteboard:
Keywords: regression
: 36320 36355 36373 (view as bug list)
Depends on:
Blocks: mab3.4
  Show dependency treegraph
 
Reported: 2011-04-15 12:16 UTC by Zack
Modified: 2011-04-19 02:23 UTC (History)
9 users (show)

See Also:
Crash report or crash signature:


Attachments
LO Writer Error Message (156.75 KB, image/png)
2011-04-15 12:16 UTC, Zack
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Zack 2011-04-15 12:16:32 UTC
Created attachment 45681 [details]
LO Writer Error Message

I decided to check out the new 3.4 Beta and after installation I tried to open writer and I got this error message:
General Error.
General input/output error.

I tried uninstalling LO 3.4 and reinstalling.  The same error message appears.  I will be switching back to LO 3.3.2 because I need something that works, but if anything is needed of me I'd be happy to help so this problem gets fixed.

I have attached a screenshot.  Everything but writer works (albeit with missing icons as has been mentioned in another bug).  The program is completely unusable.

System:
Windows 7 Home Premium x86
Intel Core 2 Duo E7700
4GB RAM.
Comment 1 Helmut Leininger 2011-04-15 14:01:28 UTC
Same problem with Windows XP, also with Calc.

Regards
Comment 2 Kohei Yoshida 2011-04-15 14:07:18 UTC
Tor, help.
Comment 3 Zack 2011-04-16 09:42:49 UTC
Same results with my desktop which is running a 64 bit version of Windows 7.
Comment 4 Allen 2011-04-16 10:52:07 UTC
FYI, a "ProcMon" dump can be very useful for tracking down this kind of problem.  ProcMon is part of Sysinternals distributed by Microsoft at http://technet.microsoft.com/en-us/sysinternals/

To generate a ProcMon dump:

1. Download ProcMon from http://live.sysinternals.com/Procmon.exe
2. Run ProcMon.
3. Select the menu Filter -> Filter..., select "Image Path" and "contains", type "LibreOffice", select "include", then click "Add" then "OK".
4. Under the File menu, make sure Capture Events is checked.
5. Select the menu Edit -> Clear display.
6. Force the bug to occur (i.e., run LibreOffice, do whatever causes the bug, etc.)
7. Go back to ProcMon.
8. Select the File menu and uncheck Capture Events.
9. Select File -> Save, select "Events displayed using current filter", uncheck "Also include profiling events", select "Native Process Monitor Format (PML)", enter a file name, click OK.
10. Post the .pml file.
Comment 6 Don't use this account, use tml@iki.fi 2011-04-17 01:17:44 UTC
Allen, can you then show us how to use such a "Procmon dump", thanks! I assume you have built LibreOffice for Windows yourself and have tried to use such a dump file? Thanks in advance!
Comment 7 Jonathan S 2011-04-17 08:26:32 UTC
System XP Pro, SP3

I start Writer. No icons in toolbars. Attempt to open a text document, get:

General Error.
General input/output error.

same as other people.
Close Writer (and thus whole of LibreOffice) and get:

DDE Server Window: soffice.bin - Application Error [title-bar of dialogue]
The instruction at "0x04306546" referenced memory at "0x00000004". The memory could not be "read".
Click on OK to terminate the program

I attach the PML file as requested by Allen, using exactly his instructions.
Comment 8 Jonathan S 2011-04-17 08:51:13 UTC
PML file is too big for attachment. Can be found here:
http://www.elgedi.demon.co.uk/Logfile.PML
Comment 9 Rainer Bielefeld Retired 2011-04-17 20:50:33 UTC
*** Bug 36320 has been marked as a duplicate of this bug. ***
Comment 10 Rainer Bielefeld Retired 2011-04-17 20:54:18 UTC
Modified component due to Comment 1 and results from 
Bug 36320 - General error on opening files

Modified Status due to facts.
Comment 11 Zack 2011-04-17 21:20:39 UTC
(In reply to comment #10)
> Modified component due to Comment 1 and results from 
> Bug 36320 - General error on opening files
> 
> Modified Status due to facts.

Rainer, I wouldn't mark this as a duplicate of Bug 36320.  They may be related based on the error message, but they are distinctly different.  What I was referring to with this bug is that I cannot open LO Writer.  Even a new blank document fails to open.  In the start center if I click "Text Document" I receive the error message I posted.  Bug 36320 deals with opening files.  This deals with running the writer program itself.
Comment 12 Kohei Yoshida 2011-04-18 16:33:15 UTC
*** Bug 36355 has been marked as a duplicate of this bug. ***
Comment 13 Allen 2011-04-18 17:43:23 UTC
> Allen, can you then show us how to use such a "Procmon dump"

You load the PML file into ProcMon (File -> Open) and then look for signs of a problem.  ProcMon's filtering (Filter -> Filter...) and highlighting (Filter -> Highlight) can be helpful.  For example, if you Filter to exclude the results SUCCESS, END OF FILE and NO MORE FILES, then you would just see the errors.  It can also be helpful to export (File -> Save) the PML file to a CSV file and load it into an editor that can sort and search by column.

I see a few things that look strange to me in the .PML file Jonathan linked to, on the other hand, I have never used ProcMon to debug LibreOffice (only OpenOffice.org), and what I'm seeing might be normal for LibreOffice, and especially for the v3.4.  For one thought however, see my next comment.
Comment 14 Allen 2011-04-18 18:20:17 UTC
Could the users who are seeing this problem (or a related problem) try the following:

1. Run LibreOffice to confirm the problem.
2. Close LibreOffice.
3. If the LibreOffice Quickstarter is running, right-click on the LibreOffice Quickstarter icon in the system tray and select "Exit Quickstarter".
4. Run taskmgr (Start -> Run -> type "taskmgr" and hit Enter).
5. Verify that there are no processes running with names that start with "soffice" (such as "soffice.exe" or "soffice.bin").
6. Navigate to your user setting directory (open the Windows File Explorer, type %APPDATA$ in the location bar and hit Enter).
7. You should see a subfolder called "LibreOffice".  Rename this subfolder to something else, like "LibreOffice-save".
8. Run LibreOffice and check to see if the problem is still occurs.

If the problem is still there, do the following if you are running Vista or Windows 7; otherwise, skip to Step 14 below:

9. Repeat Steps 2-6 above, and then:
10. In your user settings directory, delete the subfolder named LibreOffice.
11. Navigate to your VirtualStore folder, which is at C:\Users\<your username>\AppData\Local\VirtualStore.
12. Look in all subfolders for any subfolders named "LibreOffice" or "LibreOffice 3", and if you find one, delete it.
13. Run LibreOffice and check to see if the problem is still occurs.

If the problem is still there:

14. Repeat Steps 2-6 above, and then:
15. In your user settings directory, delete the subfolder named LibreOffice.
16. Uninstall LibreOffice.
17. Delete the folder named "LibreOffice 3" in the Windows programs directory (either "C:\Program Files\LibreOffice 3" or "C:\Program Files (x86)\LibreOffice 3", depending on whether you are running a 32 bit or 64 bit version of Windows).
18. Reboot your computer.
19. Reinstall LibreOffice.
20. Run LibreOffice and check to see if the problem is still occurs.

If any of the above helps, please post which step solved the problem.
Comment 15 Zack 2011-04-18 21:44:22 UTC
Step 7 solved my problem with swriter.exe failing to run properly (which is what this bug was initially about).  I opened a new bug, Bug 36375 to deal with the swriter.exe problem.  However, steps 1-13 were unable to solve the file opening problem.  I haven't had time to try steps 14-20 yet.
Comment 16 Rainer Bielefeld Retired 2011-04-18 22:30:09 UTC
*** Bug 36373 has been marked as a duplicate of this bug. ***
Comment 17 Rainer Bielefeld Retired 2011-04-18 22:33:10 UTC
Bug 36373 - Can’t open files confirmed several details in the comments here ("The memory could not be "read"").
Comment 18 Allen 2011-04-19 01:36:40 UTC
To recount the history of this bug report:

1. Zack opened this bug report (#3671), stating that he was getting the error message "General input/output error" whenever he attempted to run Writer, either with a new blank document or an existing document.

2. Someone else came along and said they were getting the error message "General error, memory could not be read" whenever they attempted to open a document in Writer.  Based on their bug, that person changed the title of this bug report to "FILEOPEN impossible, General error, memory could not be read" 

3. In response to Action #2 above, Zack opened a new bug report (#36375) that restated his initial bug report, with his original title.

Action #2 above was wrong and should not have been done.  It confused two different error messages (one an error in input/output and the other an error reading memory) that occur at two different times (one when trying to run Writer, and one when trying to open an existing document in Writer).

At this point, I agree with Zack that this issue thread is hopelessly confused.  I suggest closing this issue as a duplicate and then following up on Zack's issue at his new bug report #36375, and the other bug at whatever bug number is created for it.
Comment 19 Don't use this account, use tml@iki.fi 2011-04-19 02:23:02 UTC
I agree with Allen in comment #18 that this bug report is now quite confusing and should be closed. 

Anyway, the problem where attempting to open ODF documents failed with a useless "General input/output error" message had the same root cause as bug #36263, so that problem is fixed now, even more reason to resolve this bug report.

Could bugzilla_acct_1959 please tell more what kind of document he/she/it was trying to open?

The crash when quitting LibreOffice is another thing, not related to the file opening problem. I wish people would spend as much time on producing useful bug reports that don't mix in different problems as they do on coming up with clever email addresses for bugzilla.