Download it now!
Bug 36397 - PRINTING FILESAVE Impress removes two images exporting to PDF or printing
Summary: PRINTING FILESAVE Impress removes two images exporting to PDF or printing
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.3.2 release
Hardware: x86 (IA32) All
: high major
Assignee: Radek Doulik
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-04-19 08:33 UTC by gleppert
Modified: 2014-01-13 10:46 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Lost-images.odp (123.50 KB, application/vnd.oasis.opendocument.presentation)
2011-04-19 08:34 UTC, gleppert
Details
Lost-images.pdf (13.98 KB, application/pdf)
2011-04-19 08:36 UTC, gleppert
Details
tar.gz file with odt and pdf (generated by export directly to pdf...) note the missing photograph (284.50 KB, application/x-gzip)
2011-11-15 07:46 UTC, dpermar
Details

Note You need to log in before you can comment on or make changes to this bug.
Description gleppert 2011-04-19 08:33:16 UTC
Problems with Printing / PDF exporting in Impress:

With attached odp-file, there are problems with the two images/graphics.
They are simply gone, when I print the file or export the file to PDF. Please also have a look at the attached PDF file. Where the images are supposed to be, there is nothing.

I am reusing this slide for almost one year and I printed it a couple of times without noticing the problem. Hence, I assume that this is a new problem in a recent version of LO.

Side note: The slide was long time ago a PPT 2003 slide and, as far as I can remember, the sources of the images were SVGs imported to Powerpoint via Visio. Maybe, this helps to track the reason for the problem.


System: Ubuntu 10.10/Gnome and LibreOffice 3.2 PPA.
Comment 1 gleppert 2011-04-19 08:34:07 UTC
Created attachment 45821 [details]
Lost-images.odp
Comment 2 gleppert 2011-04-19 08:36:46 UTC
Created attachment 45822 [details]
Lost-images.pdf
Comment 3 gleppert 2011-04-19 12:13:47 UTC
Additional remark: A friend of mine tested this issue with OpenOffice.org 3.3 and there was no problem with the images. It seems to be a LibreOffice related bug.
Comment 4 gleppert 2011-06-05 06:13:24 UTC
Could someone please have a look at this bug? Thank you very much!
As said, it is a LibreOffice only bug. There is no problem in OpenOffice.org. 

I changed this bug to the importance high/major as it cannot be accepted that the user must check every single page of his/her PDF exports of documents or presentations before publishing them somewhere. I already received PDF documents from students where graphics were simply missing. Shouldn't be like that.
Comment 5 Christopher M. Penalver 2011-06-20 08:50:47 UTC
Confirmed in Ubuntu 11.04, LO Impress via the Terminal:

wget -c https://bugs.freedesktop.org/attachment.cgi?id=45821 -O Lost-images.odp && unoconv --listener && unoconv -f pdf Lost-images.odp && acroread Lost-images.pdf

the pdf is missing some of the pictures in Adobe Reader.

lsb_release -rd
Description:	Ubuntu 11.04
Release:	11.04

apt-cache policy libreoffice-impress
libreoffice-impress:
  Installed: 1:3.3.2-1ubuntu5
  Candidate: 1:3.3.2-1ubuntu5
  Version table:
 *** 1:3.3.2-1ubuntu5 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty-updates/main i386 Packages
        100 /var/lib/dpkg/status
     1:3.3.2-1ubuntu4 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty/main i386 Packages

apt-cache policy acroread
acroread:
  Installed: 9.4.2-0natty1
  Candidate: 9.4.2-0natty1
  Version table:
 *** 9.4.2-0natty1 0
        500 http://archive.canonical.com/ubuntu/ natty/partner i386 Packages
        100 /var/lib/dpkg/status

apt-cache policy unoconv
unoconv:
  Installed: 0.3-6
  Candidate: 0.3-6
  Version table:
 *** 0.3-6 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty/universe i386 Packages
        100 /var/lib/dpkg/status
Comment 6 Rainer Bielefeld Retired 2011-11-11 04:32:58 UTC
NOT reproducible with "LibreOffice 3.4.4RC2  - WIN7 Home Premium (64bit) German UI [OOO340m1 (Build:402)]". Might be LINUX only? Please compare results in "Bug 41058 - PRINTING: impossible for particular Object", what might be a DUP
Comment 7 Christopher M. Penalver 2011-11-11 22:29:45 UTC
Problem reproducible. Both Bug 41058 and Bug 41059 look like dups of this bug as it is the same Linux only problem.

 apt-cache policy libreoffice-impress
libreoffice-impress:
  Installed: 1:3.4.4-0ubuntu1~ppa1
  Candidate: 1:3.4.4-0ubuntu1~ppa1
  Version table:
 *** 1:3.4.4-0ubuntu1~ppa1 0
        500 http://ppa.launchpad.net/libreoffice/ppa/ubuntu/ oneiric/main i386 Packages
        100 /var/lib/dpkg/status
     1:3.4.3-3ubuntu2 0
        500 http://us.archive.ubuntu.com/ubuntu/ oneiric/main i386 Packages

apt-cache policy acroreadacroread:
  Installed: 9.4.6~enu-0oneiric1
  Candidate: 9.4.6~enu-0oneiric1
  Version table:
 *** 9.4.6~enu-0oneiric1 0
        500 http://archive.canonical.com/ubuntu/ oneiric/partner i386 Packages
        100 /var/lib/dpkg/status
Comment 8 Rainer Bielefeld Retired 2011-11-11 23:55:50 UTC
CONFIRMED due to Comment 5, Comment 7

@Radek:
Please feel free to reassign (or reset Assignee to default) if it’s not your area or if provided information is not sufficient. Please set Status to ASSIGNED if you accept this Bug.
Comment 9 dpermar 2011-11-15 07:46:45 UTC
Created attachment 53575 [details]
tar.gz file with odt and pdf (generated by export directly to pdf...) note the missing photograph

The same read in presentation ODP bug #45821 happens to me in Writer with odp. exporting to PDF wipes out my photograph, but no the horizontal (small) lines that are images aswell. The same behaviour is observed when I print a paper copy.
Comment 10 A (Andy) 2013-04-23 19:43:12 UTC
buggy behavior reproducible with LO 4.0.2.2 (Win7 Home, 64bit)

Result: I only see a very much enlarged part of the picture in the PDF-Document.
Comment 11 ign_christian 2013-06-18 10:05:45 UTC
I can confirm there is a bug doing Export as PDF (differ than file attached on comment 2), but no problem with printing.

Looks like very similar with Bug 55345 -> scaling problem

Tested on LO 4.0.4.2 (Win7 32bit)
Comment 12 Zeki Bildirici 2014-01-12 22:03:30 UTC
Hi,

Seems fixed in Version: 4.2.0.1
Build ID: 420m0(Build:1) on Ubuntu. Exporting to PDF shows all images. Could you please check with recent version.

Best regards,
Zeki
Comment 13 Gerry 2014-01-13 10:45:33 UTC
Hi, I can confirm that the bug is fixed in 

LibreOffice Version: 4.2.0.2
Build-ID: 601a398b803303d1a40a3299729531824fe0db56

on Ubuntu 13.04
Comment 14 Gerry 2014-01-13 10:46:39 UTC
Mark it as RESOLVED-WORKSFORME. In case, you still encounter the problem, please feel free to reopen the bug.