Download it now!
Bug 55345 - Export to pdf does not incorporate the scale settings of pictures imbedded in odt/odg-files
Summary: Export to pdf does not incorporate the scale settings of pictures imbedded in...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
3.6.0.0.alpha1
Hardware: All All
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectRequest, regression
: 65879 (view as bug list)
Depends on:
Blocks: mab3.6
  Show dependency treegraph
 
Reported: 2012-09-26 06:23 UTC by dreamquartz
Modified: 2015-12-17 06:52 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments
embedded pictures in odt document (22.32 KB, application/vnd.oasis.opendocument.text)
2012-09-26 06:23 UTC, dreamquartz
Details
PDF exports 4.0.4 & 4.1.0 (12.69 KB, application/zip)
2013-07-31 05:26 UTC, tommy27
Details

Note You need to log in before you can comment on or make changes to this bug.
Description dreamquartz 2012-09-26 06:23:59 UTC
Created attachment 67704 [details]
embedded pictures in odt document

Windows 7 PRO & Ubuntu 12.04.1

Trying to export an odt & odg-file to pdf causes the embedded pictures not convert with scale settings included.
Comment 1 sasha.libreoffice 2012-11-14 12:31:07 UTC
Thanks for bugreport
used attachment and File->Export to PDF
Reproduced:
3.5.7 and 3.6.3 on RFR 17 64 bit
3.5.0 and 3.6.3 on Windows XP 32 bit

Not reproduced:
3.4.2, 3.5.0, 3.5.4 on Windows XP 32 bit

Looks like regression appears after 3.5.4 version (I do not know when exactly)
Comment 2 Adam 2012-11-22 10:47:41 UTC
I can reproduce this bug on 3.6.x but on 3.5.7.2 it works just fine. I had to regress to 3.5 due to this bug. It affects all objects pasted to any Libre Office application as windows GDI metafile.
Comment 3 Adam 2012-11-22 10:58:33 UTC
(In reply to comment #2)
> I can reproduce this bug on 3.6.x but on 3.5.7.2 it works just fine. I had
> to regress to 3.5 due to this bug. It affects all objects pasted to any
> Libre Office application as windows GDI metafile.

Forgot to add I tried this Windows 7 (both 32bit and 64bit).
Comment 4 Adam 2013-01-30 19:59:43 UTC
(In reply to comment #1)
> Thanks for bugreport
> used attachment and File->Export to PDF
> Reproduced:
> 3.5.7 and 3.6.3 on RFR 17 64 bit
> 3.5.0 and 3.6.3 on Windows XP 32 bit
> 
> Not reproduced:
> 3.4.2, 3.5.0, 3.5.4 on Windows XP 32 bit
> 
> Looks like regression appears after 3.5.4 version (I do not know when
> exactly)

On my laptop (Win 7 64bit) the problem does not exist in 3.5.7.2 and appears only in 3.6.x and continues to 4.0 RC2. Real shame as I cannot upgrade beyond 3.5.7 due to this bug.
Comment 5 Adam 2013-03-27 13:52:58 UTC
There is also a similar bug reported in 61859. It may be a duplicate.

In addition to pdf export, printing is also affected the same way.
Comment 6 Joel Madero 2013-04-27 17:36:58 UTC
I can confirm this on Bodhi Linux with Version 3.6.0.4 release, updating version to reflect earliest confirmed version.
Comment 7 Joel Madero 2013-05-02 17:31:18 UTC
Unfortunately bibisect is useless here, problem occurs prior to 3.6alpha1.

Removing bibisectrequest
Comment 8 ign_christian 2013-06-18 08:09:33 UTC
*** Bug 65879 has been marked as a duplicate of this bug. ***
Comment 9 Christopher POTTER 2013-06-24 16:35:21 UTC
confirmed with 4.0.4 Win7 64bit home edition

very annoying bug
Comment 10 tommy27 2013-07-31 05:26:05 UTC
Created attachment 83339 [details]
PDF exports 4.0.4 & 4.1.0

I confirm the pdf export of test file is messy with 4.0.4 while it works fine with 4.1.0 (see attached files).

it seems that it has been fixed somehow during 4.1.x development.
maybe devs may investigate which committ did the fix and see if it can be backported to 4.0.5.

changing status to RESOLVED FIXED
Comment 11 Joel Madero 2013-07-31 05:27:47 UTC
The correct status is WFM as we don't know the patch that fixed the problem. Marking as such
Comment 12 Robinson Tryon (qubit) 2015-12-17 06:52:42 UTC
Migrating Whiteboard tags to Keywords: (bibisectrequest)
[NinjaEdit]