Bug 37247 - PDF Export in WRITER/Hatch not exported in some cases
Summary: PDF Export in WRITER/Hatch not exported in some cases
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
3.4.0 Beta1
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:3.5.0
Keywords:
: 34272 (view as bug list)
Depends on: 34272 35180
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-15 23:37 UTC by SURCOUF
Modified: 2012-01-14 10:40 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
WRITER sample (13.50 KB, application/vnd.oasis.opendocument.text)
2011-05-15 23:37 UTC, SURCOUF
Details
PDF sample (17.45 KB, application/pdf)
2011-05-15 23:38 UTC, SURCOUF
Details
Screenshots of sample file with red circle (184.22 KB, application/vnd.oasis.opendocument.graphics)
2011-05-25 08:43 UTC, SURCOUF
Details
Screenshots of sample file with red circle PDF version (17.81 KB, application/pdf)
2011-05-25 08:44 UTC, SURCOUF
Details

Note You need to log in before you can comment on or make changes to this bug.
Description SURCOUF 2011-05-15 23:37:04 UTC
Created attachment 46756 [details]
WRITER sample

Hello,

Since LibO beta 3, part of drawing from DRAW in WRITER is not exported to PDF. This bug affects the WIN version also. It did not exist in under the LibO3.3.2 version. When hatched the part is not exported yet it's OK when colored. (See attached file)

Thank for working on it.

Bunty
Comment 1 SURCOUF 2011-05-15 23:38:48 UTC
Created attachment 46757 [details]
PDF sample
Comment 2 Petr Mladek 2011-05-23 12:22:05 UTC
@SURCOUF: I do not see any differences on the first look. Could you please describe the non-exported stuff in more details or attach screenshots with red circles around the important parts?
Comment 3 SURCOUF 2011-05-25 08:43:35 UTC
Created attachment 47150 [details]
Screenshots of sample file with red circle
Comment 4 SURCOUF 2011-05-25 08:44:17 UTC
Created attachment 47151 [details]
Screenshots of sample file with red circle PDF version
Comment 5 SURCOUF 2011-05-25 08:44:35 UTC
(In reply to comment #2)
> @SURCOUF: I do not see any differences on the first look. Could you please
> describe the non-exported stuff in more details or attach screenshots with red
> circles around the important parts?

I added a red circle around the features which just disapeared when exported ti a PDF file.

Feel free to ask for more precision.

Bunty
Comment 6 clio 2011-05-25 08:52:27 UTC
I can confirm this with LibO 3.4 rc1 (Linux).
Comment 7 clio 2011-05-25 12:07:09 UTC
With the sample.odg from https://bugs.freedesktop.org/attachment.cgi?id=40492 (see Bug 31851) the hatch not exported neither with LibO 3.3.2 nor with LibO 3.4.0 rc2.
Comment 8 clio 2011-05-25 12:11:31 UTC
I think this bug could be a duplicate of Bug 34272 (Hatching area fill pattern does not export to pdf) or Bug 35180 (objects with invisible line style and hatched area fill may not export to pdf)
Comment 9 Björn Michaelsen 2011-12-23 12:03:04 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 10 SURCOUF 2011-12-23 21:23:26 UTC
Just tested under LibO3.5.0 Beta 1. The export to PDF seems to be OK. To be confirmed by other users.

Thanks for all.

Bunty
Comment 11 Rainer Bielefeld Retired 2012-01-14 10:35:57 UTC
@SURCOUF:
Please use WORKSFORME if no fix is known!
Comment 12 Rainer Bielefeld Retired 2012-01-14 10:37:50 UTC
*** Bug 34272 has been marked as a duplicate of this bug. ***
Comment 13 Rainer Bielefeld Retired 2012-01-14 10:40:10 UTC
*** Bug 44785 has been marked as a duplicate of this bug. ***