Bug 41000 - FILEOPEN - Filter Selection dialog needs structure and preselection
Summary: FILEOPEN - Filter Selection dialog needs structure and preselection
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: high enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 34483 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-09-19 01:00 UTC by Tristan Miller
Modified: 2014-02-25 10:59 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Screenshot showing overwhelming Filter Selection dialog (38.88 KB, image/png)
2011-09-19 01:00 UTC, Tristan Miller
Details
Mock-up of proposal. (19.50 KB, image/png)
2011-09-20 10:03 UTC, Stefan Knorr (astron)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tristan Miller 2011-09-19 01:00:24 UTC
Created attachment 51328 [details]
Screenshot showing overwhelming Filter Selection dialog

If you open a file of a format that LibreOffice doesn't recognize, a "Filter Selection" dialog appears asking the user to choose from a list of file formats.  This list contains about 180 entries in no particular order; it's madness asking users to find the correct entry from it.

Please add some structure to this list:  for example, the formats could be grouped firstly by application type (e.g., word processor, spreadsheet, graphics/drawing, presentation, etc.), and then within each type they should be sorted alphabetically.

Also, it's not particularly user-friendly to drop the user immediately into this dialog without first giving some explanation of the problem.  It would have been helpful if the dialog could include some text to this effect, such as "LibreOffice cannot determine the type of this file.  Please select it from this list."

Steps to reproduce:
1. $ libreoffice3.4 foo.bar
(where foo.bar is a file of unknown type)

Observed behaviour:
2. Overwhelming "Filter Selection" dialog appears

Expected behaviour
2. A user-friendly dialog appears which a) states the problem LibreOffice had opening the file, and b) provides an organized list from which the user can select the appropriate file format.
Comment 1 Tristan Miller 2011-09-19 01:17:19 UTC
Problem also exists in LibreOffice 3.4.3.
Comment 2 Rainer Bielefeld Retired 2011-09-19 05:34:57 UTC
That is some OOo heritage. Indeed, sort order is without any cognizable order and too long. 

There should be sort order and a preselector "show only xyz documents" for particular file types leaving an option to see the complete list.

@christoph:
Have there ever been thoughts concerning this dialog?
Comment 3 Stefan Knorr (astron) 2011-09-20 10:03:51 UTC
Created attachment 51412 [details]
Mock-up of proposal.

I made a little mock-up after Tristan's description. So, hopefully, if any dev comes along now, s/he can go right ahead...
Comment 4 Rainer Bielefeld Retired 2011-09-20 10:13:23 UTC
@Aaron Strontsman:
Yes, that looks good. Unfortunately I do not know which developer might proceed that.
Comment 5 Björn Michaelsen 2011-12-23 13:25:23 UTC
Since all new unconfirmed bugs start in state UNCONFIRMED now and old unconfirmed bugs were moved to NEEDINFO with a explanatory comment, all bugs promoted above those bug states to NEW and later are automatically confirmed making the CONFIRMED whiteboard status redundant. Thus it will be removed.
Comment 6 Rainer Bielefeld Retired 2011-12-28 03:41:43 UTC
*** Bug 34483 has been marked as a duplicate of this bug. ***
Comment 7 Tristan Miller 2012-08-15 19:25:16 UTC
I can't reproduce this behaviour with LibreOffice 3.6.0.4.  Almost every unknown file type I open throws up a Calc import dialog, which IMHO is even worse behaviour.
Comment 8 Stefan Knorr (astron) 2012-08-15 21:41:02 UTC
Tristan, would you mind opening a new bug for the new behaviour?
Comment 9 Rainer Bielefeld Retired 2012-08-16 05:04:29 UTC
@Tristan Miller
Indeed, this morning I found no way to bring up the dialog with Server Installation of  "LibreOffice 3.6.0.4  German UI/Locale [Build-ID:  932b512] on German WIN7 Home Premium (64bit) 

I submitted a new "Bug 53570 - FILEOPEN unknown file type brings up Spreadsheet CSV import dialog instead of filter list" for this new problem, can you please try to confirm it?
Comment 10 Rainer Bielefeld Retired 2012-08-16 05:05:02 UTC
@Ivan:
Please set Status to ASSIGNED and add yourself to "Assigned To" if you accept this Bug or forward the Bug if it's not your turf.
Comment 11 Tristan Miller 2012-08-16 06:21:21 UTC
As I mentioned, the new problem occurs with "almost every unknown file type".  See Bug 53553 and Bug 53554 for two unknown file types which produce different (but also wrong) behaviour.
Comment 12 Ivan Timofeev (retired) 2012-08-16 11:18:23 UTC
Nice idea and mock-up, I like it. Well, assigned, though this will require some documentation/code reading, I currently know nothing about filters, how to categorize them, where to get strings for the category names etc... So I don't promise a quick result. :)
Comment 13 Rainer Bielefeld Retired 2012-08-16 11:28:35 UTC
Pleasant anticipation also is some nice feeling :-)
Thx. for taking this one!
Comment 14 Rainer Bielefeld Retired 2013-02-25 09:55:37 UTC
We still have several cases (see Bug 47808) where the filter comes up, so this one should be fixed.

May I suggest to add file name extensions to the file type list as we see them in the file type selector in file dialog?
Comment 15 Ivan Timofeev (retired) 2013-12-15 16:54:31 UTC
Set to NEW, because I don't contribute to LibreOffice anymore.
Comment 16 Maxim Monastirsky 2014-02-25 10:59:13 UTC
AFAIK This dialog will never show with recent versions, because PlainTextFilterDetect should catch all files.