Bug Hunting Session
Bug 41543 - Mentioned Menu item 'Edit - Hyperlink' does not exist
Summary: Mentioned Menu item 'Edit - Hyperlink' does not exist
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.4.3 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
: 44491 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-10-06 20:35 UTC by Allan Jacobs
Modified: 2017-01-17 07:54 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Allan Jacobs 2011-10-06 20:35:58 UTC
There is a Hyperlink tool in the standard tool bar.  There is supposed to be a Hyperlink menu option in the Edit menu.  But, it is not there.

1. Create a new spreadsheet.
2. Focus in an empty cell.
3. Insert->Hyperlink
4. Internet tab.
5. Target: http://www.oracle.com/
6. Form: text
7. Text: Oracle
8. Name: External link
9. Apply
10. Right click cell.
11. Click on the Hyperlink icon in the standard toolbar.
12. Internet tab.
13. Target: http://freeedesktop.com/
14. Form: text
15. Text: Free Desktop
16. Apply
17. Right click cell.
18. Menu: Edit

The user guide says:  "To edit an existing link, place the cursor anywhere in the link and click the Hyperlink icon on the Standard toolbar or select Edit → Hyperlink from the menu bar. The Hyperlink dialog (Figure 268) opens. If the Hyperlink is in button form, the spreadsheet must have Design Mode on in order
to edit the Hyperlink. Make your changes and click Apply. If you need to edit several hyperlinks,  you can leave the Hyperlink dialog open until you have edited all of them. Be sure to click Apply after each one. When you are finished, click Close."

There is no Edit->Hyperlink menu item.  There is an Edit->Links... menu item, but it will be greyed out.
Comment 1 Rainer Bielefeld Retired 2011-10-06 22:29:02 UTC
Reproducible for  LibreOffice 3 Calc Guide -  Chapter 10  Page 261

Allan Jacobs:
I believe the problem is a wrong Text in the manual, there is no such Edit menu item "Edit → Hyperlink", manual is faulty.

Correct text should be: " ... or select Insert → Hyperlink from the menu bar"

Menu 'Edit -> Links" is for something completely different: linked contents!

Help is correct.

@David:
Please feel free to reassign (or reset Assignee to default) if it’s not your area or if provided information is not sufficient. Please set Status to ASSIGNED if you accept this Bug.
Comment 2 Björn Michaelsen 2011-12-23 12:38:06 UTC Comment hidden (obsolete)
Comment 3 Rainer Bielefeld Retired 2012-07-03 22:33:50 UTC
But the question is: why do we have menu 'Edit -> Hyperlink' in Writer and Draw, but not in Calc? 'Edit -> Hyperlink' brings up the same dialog as 'Insert -> Hyperlink' for a selected text with hyperlink

I believe in a first step we should think about unifying UI, then about Documentation + Help.

@Cédric, Kohei, Radek
Can you please decide whether we need menu 'Edit -> Hyperlink' in all applications or no one (or why not in Calc)?
Comment 4 Rainer Bielefeld Retired 2012-07-03 22:36:48 UTC
*** Bug 44491 has been marked as a duplicate of this bug. ***
Comment 5 Rainer Bielefeld Retired 2012-08-13 16:55:44 UTC
Please also see "Bug 53444 - UI: Different Menu Items for creation and EDITING hyperlinks"
Comment 6 Cédric Bosdonnat 2014-01-20 09:00:25 UTC
Restricted my LibreOffice hacking area
Comment 7 QA Administrators 2015-09-04 02:49:13 UTC Comment hidden (obsolete)
Comment 8 David Clayton 2015-11-04 10:06:51 UTC
This is still an issue (5.0.3 Windows), although I believe it more of a 'feature improvement' than a bug, and I think it would be sensible to review the hyperlink dialogue to include a remove button, and create a context menu for 'remove'. I will go through and attempt to link similar bugs.
Comment 9 Julien Nabet 2016-05-27 08:50:30 UTC
ux-team: just to know what is expected here (in terms of functionality/help, etc.)
Indeed, with master sources updated today, I don't see any option to modify an hyperlink with right click or with edit menu.
Comment 10 Robinson Tryon (qubit) 2016-08-25 05:49:34 UTC Comment hidden (obsolete)
Comment 11 Cor Nouws 2017-01-16 21:09:06 UTC
let me close as WorksForMe.
Menu items have changed a lot. There is an Insert > Hyperlink in all modules, that handles editing too.
The Help should be up to date too, and if not, reported issues will be fixed.
Comment 12 Heiko Tietze 2017-01-17 07:54:18 UTC
(In reply to Cor Nouws from comment #11)
> There is an Insert > Hyperlink ...

Hyperlink was renamed to just Link. Just to mention.