Bug 42629 - SUM, COUNT, COUNT², MAX, MIN,etc. Status bar toggle box for selections - Allow more than one
Summary: SUM, COUNT, COUNT², MAX, MIN,etc. Status bar toggle box for selections - Allo...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: high enhancement
Assignee: Dennis Francis
QA Contact:
URL:
Whiteboard: target:5.2.0
Keywords:
: 66220 94778 98951 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-11-05 11:32 UTC by Nicolás Adamo
Modified: 2016-08-14 11:09 UTC (History)
13 users (show)

See Also:
Crash report or crash signature:


Attachments
screenshot example (548.61 KB, image/png)
2013-02-03 17:07 UTC, Justin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nicolás Adamo 2011-11-05 11:32:25 UTC
When selecting a range of cells, there's a sort of status bar to the left of the zoom slider where you can read by default the sum of the range. If you right click this text, you can choose wether to show the average, the count, max, min, etc. 
This is great; the request I'm asking for is to show more than one of this indicators. On normal monitor resolutions there's space for adding aditional information, so I think joinig data strings is possible. Maybe the quickest way to develop this is to change the toogle box for a tick box, allowing the user to select more than one option.

That's all, thanks.
Comment 1 Dag Wieers 2011-11-06 13:45:58 UTC
What's even more, this is a regression of some sort, as a few people were used to seeing both Sum and Average at the same time.

I often used this, and it's no longer there. In OpenOffice 3.2 you had only 2 options in that list:

    Sum/Average
    None

Where the first one would show: Sum=<value> Average=<value>

Ideally we could tick more than one option to have it added to the list, but if that's not possible/desired, at least the option "Sum/Average" would need to be restored.
Comment 2 Cor Nouws 2011-11-21 06:10:44 UTC
for those interested, I came accross some related identifiers in
/svx/source/stbctrls/stbctrls.src
Comment 3 Crusader 2013-01-13 18:33:28 UTC
Is this valuable suggestion (which is > a year old) dead?

The ability to see multiple values of one's choosing on the status bar is of immense value and can only add a feather to LibreOffice's cap.

In the real world, these kinds of "small, non-life threatening" features make a big difference when office software adoption is considered.  Please don't let LibreOffice lose out!
Comment 4 Justin 2013-02-03 17:07:00 UTC
Created attachment 74147 [details]
screenshot example

This screen shot shows the implementation in Excel. Its excellent and useful every day.
Comment 5 Justin 2013-02-03 17:07:47 UTC
I really want this feature.
Comment 6 Cor Nouws 2013-02-03 20:34:53 UTC
(In reply to comment #5)
> I really want this feature.

thanks for the example.
If you really want this, pls think about how you would be able to help.
Cor
Comment 7 Justin 2013-02-03 22:10:16 UTC
Wish i was a programmer. I will be happy to test the feature in beta if someone codes it. Seems like a pretty easy enhancement if inwas a programmer :p
Comment 8 Prashant 2013-04-16 17:51:29 UTC
Hi,

I'd recently implemented 'Selection count' feature in the same list of selections : 'Sum', 'Count', ... 

I feel that having worked on it, I may find myself comfortable working on it. Can I get some pointers for the same please ?

Thanks and Regards,
Prashant
Comment 9 Nicolas 2013-06-26 19:56:14 UTC
*** Bug 66220 has been marked as a duplicate of this bug. ***
Comment 10 Edward 2014-04-29 23:49:11 UTC
Not sure how to vote for this, but does anyone know the status? Is this still not implemented due to lack of code contribution for it or lack of agreement that it should indeed be implemented?
Comment 11 Cor Nouws 2014-04-30 11:07:07 UTC
Hi,

(In reply to comment #10)
> Not sure how to vote for this, but does anyone know the status? Is this
> still not implemented due to lack of code contribution for it or lack of
> agreement that it should indeed be implemented?

I don't expect disagreement on this. It's just that developers work on different stuff atm. If you have a little experience: it's not that hard with help of other developers to start working on this..
Comment 12 Nikhil pushkaran 2014-11-22 06:07:13 UTC
Team,
I am working in a company which need to manage large volume of data.
For my case, I need count and sum at the same status bar.
Currently all are depending excel to manage the medium sized data,
If any one try to use libeO, there are certain difficulties to overcome like this.
This is one of those simple bugs to be fixed for libO spread sheet's smooth running.
I dont know why, you team is not working on this.
This is not a request, a prayer from spread sheet users.

Keenly waiting ,

Regargs;
Nikhil
India
919946609086
Comment 13 Björn Michaelsen 2014-11-28 09:42:16 UTC Comment hidden (obsolete)
Comment 14 Valter Mura 2015-01-17 12:10:00 UTC
(In reply to Nicolás Adamo from comment #0)
> When selecting a range of cells, there's a sort of status bar to the left of
> the zoom slider where you can read by default the sum of the range. If you
> right click this text, you can choose wether to show the average, the count,
> max, min, etc. 
> This is great; the request I'm asking for is to show more than one of this
> indicators. On normal monitor resolutions there's space for adding aditional
> information, so I think joinig data strings is possible. Maybe the quickest
> way to develop this is to change the toogle box for a tick box, allowing the
> user to select more than one option.
> 
> That's all, thanks.

I'm not a programmer but a user, and I vote it as an important enhancement request.
Comment 15 Cor Nouws 2015-01-17 13:30:10 UTC
Hi all,

This is a very valuable enhancement request!

Is is an improvement compared to the original OpenOffice.org behaviour.
Therefore the version is set to "Inherited from OOo" The field shows the oldest version with the behaviour.
Pls don't change that value :)
Comment 16 Cor Nouws 2015-01-17 13:33:35 UTC
Hi Prashant,

(In reply to Prashant from comment #8)

> I'd recently implemented 'Selection count' feature in the same list of
> selections : 'Sum', 'Count', ... 

Thanks a lot for that :)
(I've been distracted for some time and missed this news)

> I feel that having worked on it, I may find myself comfortable working on
> it. Can I get some pointers for the same please ?

Do you still have time/interest :) ? Usually entering the developer list is the way to go. If needed.. I could help finding a contact, but that may be superfluous ;)

Regards,
Cor
Comment 17 Gabriele Ponzo 2015-01-19 20:52:03 UTC
I'm not a programmer anymore (unfortunately), but I'd like to see this feature implemented.

Could it be a good idea to insert it among "Easy Hacks"? Or it's not that so easy?

I know a coder wondering to join TDF…
Comment 18 cantanna 2015-01-20 16:20:11 UTC
nice.
Comment 19 arnaud c 2015-07-21 12:41:07 UTC
hi
same topic, but another feature that would be good to implement:
when you right-click on the "Sum=XX", it could display the value beside each function.
Google spreadsheet does this, it's very pleasurable
Comment 20 Giovanni Sardisco 2015-09-14 23:47:52 UTC
It is a really useful feature. 
I need this. 
Is not it difficult to implement. 
Will be implemented in 5.1? :) 
Come on, come on, come on! :D
Comment 21 Cor Nouws 2015-09-15 12:28:28 UTC
(In reply to Giovanni Sardisco from comment #20)
> It is a really useful feature. 
> I need this. 
> Is not it difficult to implement. 

Sure :)

> Will be implemented in 5.1? :) 

Well... https://wiki.documentfoundation.org/Development/GetInvolved
Comment 22 raal 2015-10-05 10:34:24 UTC
*** Bug 94778 has been marked as a duplicate of this bug. ***
Comment 23 Dennis Francis 2016-02-02 03:42:41 UTC
I will make an attempt to add this feature.
Comment 24 Dennis Francis 2016-02-02 18:59:33 UTC
Submitted a patch for this at https://gerrit.libreoffice.org/#/c/22060/
for review.
Comment 25 Commit Notification 2016-03-11 21:47:23 UTC
Dennis Francis committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=7bc97db5b972f27693161beb9182f8a5850f5551

tdf#42629 : Allow multiple status bar functions at a time

It will be available in 5.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 26 Óvári 2016-03-12 09:20:36 UTC
(In reply to Commit Notification from comment #25)
> Affected users are encouraged to test the fix and report feedback.

For the selected range C6:C9 in the screenshot the ‘Customize Status Bar’ has left justified Average, Count and Sum and right justified 2.5, 4 and 5, respectively.

Would it be possible to implement this feature in LibreOffice too?

Additionally, would Minimum and Maximum values of 2 and 3 respectively show in the Customize Status Bar for LibreOffice also? 

Thank you
Comment 27 Dag Wieers 2016-03-13 02:11:00 UTC
Great to see this addition !

If I can make a suggestion, currently there is no spacing between functions in the status bar. Which makes it hard to read.

E.g.

    Average=4.5;Count=8;Max=8;Sum=36

I think quadruple-spacing and using colons works out better:

    Average: 4.5    Count: 8    Max: 8    Sum: 36

This is exactly what Microsoft Office is doing. Spacing may depend on the font, here it seems a lot because of the proportional font.
Comment 28 Cor Nouws 2016-03-13 10:15:04 UTC
Hi Dag,

(In reply to Dag Wieers from comment #27)

> I think quadruple-spacing and using colons works out better:
> 
>     Average: 4.5    Count: 8    Max: 8    Sum: 36

Yes, nice.
But you don't build LibreOffice yourself (yet ;) ) ?
I assume Dennis would not mind if you do that change.
But of course: feel free, no obligation :)
Cheers - Cor
Comment 29 Dag Wieers 2016-03-13 21:14:47 UTC
Cor,

Nope, never succeeded :-/

But for this I don't need to be able to compile.

https://github.com/LibreOffice/core/pull/6

PS Unfortunately it doesn't seem the project is actually using Github.
Comment 30 Dag Wieers 2016-03-13 21:37:29 UTC
BTW Someone needs to revise the instructions at:

https://wiki.documentfoundation.org/Development/gerrit

I couldn't make Google OpenID work, the OAuth stuff doesn't seem to be available (not sure how it is supposed to work either) and the only other OpenID provider I have from the list is StackExchange and while I authenticated fine, I cannot login or register properly.

(4 successful logins according to StackExchange OpenID provider, fails in Gerrit)

Sorry, but with GitHub I had it forked, patched and committed in 2 minutes. I now spend 20 minutes (!) trying to make register with Gerrit and failed... Do we really want to alienate drive-by contributors ?
Comment 31 Dag Wieers 2016-03-13 22:27:57 UTC
Finally, https://gerrit.libreoffice.org/#/c/23196/ !
Comment 32 Cor Nouws 2016-03-13 23:02:51 UTC
@jani: 

(In reply to Dag Wieers from comment #30)
> BTW Someone needs to revise the instructions at:
> 
> https://wiki.documentfoundation.org/Development/gerrit
> 
(read comment #30 )

@dag
(In reply to Dag Wieers from comment #31)
> Finally, https://gerrit.libreoffice.org/#/c/23196/ !

Hurray :)
Comment 33 Dag Wieers 2016-03-13 23:10:40 UTC
@jani:

(cfr. comment #30)

I succeeded by using my Yahoo ID, which I didn't know I had but apparently was related to my old ICQ account ! So at least that did work.

(Never expected to get an email when I tried the "forgot password" link...)
Comment 34 Óvári 2016-03-14 20:57:14 UTC
(In reply to Dag Wieers from comment #31)
> Finally, https://gerrit.libreoffice.org/#/c/23196/ !

https://gerrit.libreoffice.org/#/c/23196/1/sc/source/ui/view/tabvwsha.cxx
You changed
  aStr += "=";
to
  aStr += ":";
Did you mean
  aStr += ": ";

Your change seems to produce
  Average:4.5    Count:8    Max:8    Sum:36

Instead of your proposed change at comment #27
  Average: 4.5    Count: 8    Max: 8    Sum: 36
Comment 35 Dag Wieers 2016-03-14 22:30:26 UTC
There was a second commit adding that space in Gerrit.

I don't know how Gerrit works, but I couldn't figure out the equivalent of a pull-request in Github where on can add another commit to the pull-request before it is merged.

So I was basically forced to add a second commit to Gerrit...
Comment 36 jani 2016-03-15 08:16:05 UTC
(In reply to Dag Wieers from comment #35)
> There was a second commit adding that space in Gerrit.
> 
> I don't know how Gerrit works, but I couldn't figure out the equivalent of a
> pull-request in Github where on can add another commit to the pull-request
> before it is merged.
> 
> So I was basically forced to add a second commit to Gerrit...

If you do not know how gerrit works, then it is a good idea to read about it, e.g. in our wiki.


Here is a link (which you got earlier):
https://wiki.documentfoundation.org/Development/GetInvolved

that gives you a simple way of using gerrit.
Comment 37 jani 2016-03-15 08:28:57 UTC
(In reply to Cor Nouws from comment #32)
> @jani: 
> 
> (In reply to Dag Wieers from comment #30)
> > BTW Someone needs to revise the instructions at:
> > 
> > https://wiki.documentfoundation.org/Development/gerrit
> > 
> (read comment #30 )


These instruction are correct, just checked them, the problem here seems different.

@dag
we do not use github for many reasons, but have a mirror of the code base there. This means you can perfectly pull from github, but need to submit using gerrit.

We use gerrit, because it gives a lot better workflow, than the usual push requests in Github. Gerrit is used to review all patches, before they are merged to master, which saves us from quite a lot of problem.

When you use gerrit, your patch gets automatically build and verified on all our supported platforms.


> 
> @dag
> (In reply to Dag Wieers from comment #31)
> > Finally, https://gerrit.libreoffice.org/#/c/23196/ !
> 
> Hurray :)
Comment 38 Adolfo Jayme 2016-03-16 07:55:38 UTC
(In reply to Dag Wieers from comment #35)
> There was a second commit adding that space in Gerrit.
> 
> I don't know how Gerrit works, but I couldn't figure out the equivalent of a
> pull-request in Github where on can add another commit to the pull-request
> before it is merged.
> 
> So I was basically forced to add a second commit to Gerrit...

The trick is to preserve the “Change-Id” line so that it matches the one from the commit you want to amend. I’ve explained it a bit further in your second Gerrit thread.  Now I’ve locally squashed both of your patches together and pushed.

I’ll close this bug again as FIXED since Dennis has fulfilled the original request (thanks!). A RESOLVED bug doesn’t mean that it won’t accept further tweaks, so no need to reopen it ;-)
Comment 39 Commit Notification 2016-03-18 08:45:52 UTC
Dag Wieers committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f1ff9375184607b86ae8807d7cf1220962425b51

Related: tdf#42629 Improve the readability of the status bar functions

It will be available in 5.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 40 Dag Wieers 2016-03-18 10:50:15 UTC
It is unfortunate that the initial proposal was modified to only use a single space between name-value pairs.

That was exactly what made it harder to read. And likely is the reason why Microsoft also choose multiple spaces between name-value sequences.

Also adding a semicolon delimiter brings absolutely nothing to the status-bar except for making it harder to read for people with sight-disabilities.

Mind you that 4 spaces with a non-proportional font is not that much. I think Microsoft even uses more spacing in between name-value pairs.


So we went from the original proposal:

    Average=4.5;Count=8;Max=8;Sum=36

to an improvement:

    Average: 4.5    Count: 8    Max: 8    Sum: 36

and almost back to square one:

    Average: 4.5; Count: 8; Max: 8; Sum: 36


A big mistake IMO
Comment 41 Kevin Suo 2016-03-18 13:10:11 UTC
(In reply to Dag Wieers from comment #40)
In my opinion it's a waste of spaces to have so four spaces for the calculation result. The space can be used for more functionalities in yhe future.
Comment 42 Dag Wieers 2016-03-18 13:20:12 UTC
Of course it is not a waste if it improves readability.

Again the spaces in a non-proportional fonts are smaller than what you see here, so it may be deceiving you. Please copy&paste it into LibreOffice with a non-proportional font and look for yourself.

Can we maybe have a usability expert involved ?

PS If you'd look at Microsoft Office we wouldn't actually be discussing this here...
Comment 43 Adolfo Jayme 2016-03-19 23:31:46 UTC
Dag: Just because Microsoft does it, it doesn’t mean we should as well.
Comment 44 Dag Wieers 2016-03-20 01:03:46 UTC
Adolfo, did I just say that ? No I did not.

I said that if you would be seeing the difference between the current LibreOffice implementation and what Microsoft has implemented, it is very obvious that what Microsoft is doing is far more readable (less effort to parse it) than with semicolons and a single space.

Don't take my word (or your Microsoft-aversion) for it, look at it instead of theorizing.

Anyway, this is going nowhere. Good luck.
Comment 45 Óvári 2016-03-23 10:39:23 UTC
Bug 42629


+1 for Dag Wieers suggestion at comment #27, i.e.
    I think quadruple-spacing and using colons works out better:
      Average: 4.5    Count: 8    Max: 8    Sum: 36
It would seem that Cor Nouws agrees too (comment #28).


Whitespace is easier on the eyes than punctuation, aka “Improve the readability of the status bar functions”.

This feature would seem most useful with devices which have a larger monitor/screen.


Solutions to satisfy the concerns of Samuel Mehrbrodt and Adolfo Jayme Barrientos (https://gerrit.libreoffice.org/#/c/23196/) are:
a) Implement comment #26; and/or
b) Implement a Tooltip/Popover (http://caolanm.blogspot.com.au/2016/02/current-libreoffice-native-gtk3-elements.html) to show values, i.e.
   Average: 4.5
   Count: 8
   Max: 8
   Sum: 36
or
   Average: 4.5; Count: 8; Max: 8; Sum: 36


Please re-implement Dag Wieers patch and if required, provide a:
a) patch for comment #26; and/or
b) Tooltip/Popover showing the values.


Thank you
Comment 46 Cor Nouws 2016-03-29 12:04:23 UTC
*** Bug 98951 has been marked as a duplicate of this bug. ***
Comment 47 Cor Nouws 2016-03-29 12:13:12 UTC
Hi all,

So something sadly derailed here :\

I can only imagine that Adolfo joined here with best intentions and spent efforts to help.
However the current state is not looking fair for Dag his work, notably the first he did with all extra efforts involved..
As Óvári makes clear, I see no reason too for not following the initial patch from Dag.
@Adolfo, what do you think?

Thanks a lot!
Cor