Bug Hunting Session
Bug 46167 - CONFIGURATION: improber registry of 6 Inprocserver32
Summary: CONFIGURATION: improber registry of 6 Inprocserver32
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
3.5.1 release
Hardware: x86-64 (AMD64) Windows (All)
: low minor
Assignee: Andras Timar
URL:
Whiteboard: BSA target:3.6.0 target:3.5.1
Keywords:
: 43708 46473 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-02-16 05:37 UTC by Rune Grysbæk
Modified: 2012-04-05 08:05 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rune Grysbæk 2012-02-16 05:37:39 UTC
Problem description: 

Steps to reproduce:
1. Install with standard 
2. ....
3. ....

Current behavior:
search in registry for shlxthdl under HKEY_CLASSES_ROOT\CLSID\
found path like this:
C:\Program Files (x86)\LibreOffice 3.5\shlxthdl\shlxthdl.dll

Expected behavior:
path like this:
C:\Program Files (x86)\LibreOffice 3.5\program\shlxthdl\shlxthdl.dll

Platform (if different from the browser): 
              
Browser: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0.1) Gecko/20100101 Firefox/10.0.1
Comment 1 Not Assigned 2012-02-17 04:05:07 UTC
Andras Timar commited a patch related to this issue to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=2786c354ce4f7ff215fffe83ef242ee3b411fb13

fdo#46167 fix path of shell extension dll in registry
Comment 2 Andras Timar 2012-02-17 04:13:07 UTC
Thanks for the bug report!
Comment 3 Not Assigned 2012-02-17 08:01:31 UTC
Andras Timar commited a patch related to this issue to "libreoffice-3-5":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=02f57086c2d35b68b35c2f62926ef9597eb7a85f&g=libreoffice-3-5

fdo#46167 fix path of shell extension dll in registry


It will be available in LibreOffice 3.5.1.
Comment 4 Andras Timar 2012-02-17 11:06:27 UTC
*** Bug 43708 has been marked as a duplicate of this bug. ***
Comment 5 Andras Timar 2012-02-24 01:17:56 UTC
*** Bug 46473 has been marked as a duplicate of this bug. ***
Comment 6 Iker 2012-03-21 02:29:23 UTC
Although the wrong registry entries are fixed in 3.5.1, the shell extensions are still not enabled after a clean installation of LibreOffice 3.5.1 in Windows x64. 

Procedure:
In a clean Windows 7 x64 system you install LibreOffice 3.5.1. After installation, libreoffice document properties and images are not shown in windows explorer.

Manually registering the following dlls (win admin rights) solves the problem:
regsvr32 "C:\Program Files (x86)\LibreOffice 3.5\program\shlxthdl\ooofilt_x64.dll"
regsvr32 "C:\Program Files (x86)\LibreOffice 3.5\program\shlxthdl\shlxthdl_x64.dll"

Best regards.
Comment 7 Andras Timar 2012-03-24 08:43:49 UTC
Iker, thanks for the bug report, but I think it should be a new bug, not reopening of another, related bug. I filed bug 47805.
Comment 8 Rainer Bielefeld Retired 2012-04-05 08:05:33 UTC
I added Fix submitter as assignee because this will ease queries and bug tracking.