Bug Hunting Session
Bug 46519 - embedded VC++ runtime install fails (error code 1935)
Summary: embedded VC++ runtime install fails (error code 1935)
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
3.5.0 release
Hardware: Other Windows (All)
: medium normal
Assignee: Andras Timar
URL:
Whiteboard: BSA target:3.6.0 target:3.5.4
Keywords:
: 46238 46593 49462 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-02-23 05:52 UTC by patheticcockroach
Modified: 2012-05-23 06:05 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot of the error dialog (15.13 KB, image/png)
2012-02-23 05:52 UTC, patheticcockroach
Details

Note You need to log in before you can comment on or make changes to this bug.
Description patheticcockroach 2012-02-23 05:52:35 UTC
Created attachment 57524 [details]
Screenshot of the error dialog

Problem description: The installer just fails to complete with the attached error message (Error 1935. An error occurred during the installation of assembly 'policy.9.0.Microsoft.VC90.CRT,publicKeyToken="1fc8b3b9a1e18e3b,version="9.0.30729.6161",.....)

I suspect this has pretty much the same causes as a similar issue with the Graphviz installer, cf http://notepad.patheticcockroach.com/1683/fixing-grapvizs-installation-error-related-to-microsoft-vc80-crt/

A very trivial way to fix this would thus be to provide a VC++ runtime-less installer.

Platform: Win 7 x64
              
Browser: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:13.0) Gecko/20120221 Firefox/13.0a1
Comment 1 Andras Timar 2012-02-24 03:23:31 UTC
I cannot reproduce it and others have not reported it, so I lower the severity. It would be good to find the root cause.
Comment 2 Andras Timar 2012-02-24 03:27:14 UTC
*** Bug 46238 has been marked as a duplicate of this bug. ***
Comment 3 Andras Timar 2012-02-24 03:27:58 UTC
Confirmed by a duplicate.
Comment 4 patheticcockroach 2012-02-24 03:55:01 UTC
I think that to reproduce it, you'd need to perform the install on a Windows where you've had _a lot_ of VC runtimes installations, reinstallations, updates, etc (so definitely not in some fresh new virtual machine), as per the description of the "solution" on Microsoft's bug page: https://connect.microsoft.com/VisualStudio/feedback/details/121817/error-1935-an-error-occurred-during-the-installation-of-assembly-microsoft-vc80-mfc-processorarchitecture-x86-publickeytoken-1fc8b3b9a1e18e3b "This is known issue when installing multiple interim releases."

This indeed occurs on one of my PCs, but not the other, although both have the very same version of Windows 7, with the same updates. The only difference between them is that the one where LibO fails to install was installed earlier (like 9 months before), and used more, notably for intrusive programming software such as Intel C++ compiler, Visual C++, etc = lots more of VC runtimes installations performed (not to mention the monthly Catalyst updates, which often come with VC updates too).
Comment 5 Patrick Dep 2012-02-27 05:01:33 UTC
I encounter the same failure 1935 durin installation. 3.4.5 installs without problems.
'Microsoft.VC80.CRT,type="win32",version="8.0.50727.42", publicKeyToken="1fc8b3b9a1e18e3b",processorArchitecture="amd64"'. 
I install until the failure appears, copy the installes files to another drive, reinstall 3.4.5 and copy the 3.5.0 file over the 3.4.5 files. It works, but it's not the ay it should be done. I also think that an installation without the redist-module would work fine.
Comment 6 Andras Timar 2012-03-02 07:04:06 UTC
*** Bug 46593 has been marked as a duplicate of this bug. ***
Comment 7 Andras Timar 2012-03-02 07:09:03 UTC
(In reply to comment #5)
> I also think that an installation without
> the redist-module would work fine.

We need the redist module, because it is not part of the operating system and LibreOffice cannot work without it. Currently it is part of the gm_Root feature. I wonder what happens, if I put it under gm_Vcredist feature. That way users could suppress its installation from the command line:

msiexec /i LibO<whatever>.msi REMOVE=gm_Vcredist

Let me check.
Comment 8 patheticcockroach 2012-03-02 07:20:31 UTC
(In reply to comment #7)
> I wonder what happens, if I put it under gm_Vcredist feature. That way
> users could suppress its installation from the command line:
> 
> msiexec /i LibO<whatever>.msi REMOVE=gm_Vcredist
Sounds good enough to me. I'll try it when you add it to some RC/beta build.
Comment 9 0RUBn0 2012-03-14 07:43:56 UTC
I also have this problem, and I think I tried everything. Besides that information that I will put below, I am completely stuck. What is the the thing

P.S. Check  the "processorArchitecture="amd64" in my error below?  Is amd64 OK for a 64 bit intel processor? Maybe it's just a term for compatible processors or?

INFO:
**ERROR first words
Error 1935.An error occurred during the installation of assembly
'policy.9.0.Microsoft.VC90.CRT,publicKeyToken="1fc8b3b9a1e18e3b",version="9.0.30729.6161",processorArchitecture="amd64",type="win32-policy"'.
Please refer to Help and Support for more information. 


** Tried:
- if service "Windows Modules Installer" was missing.
	It wasn't missing, it was even "started"
- Keeping "Windows Modules Installer" service on manual, stopping it and trying to install again
	Same result. Funny: it's not started at all, ever. (Manual should start it when requested!)
- Stopping and restarting WMI and then starting setup
	Same result.
- Deleting values under registry key HKLM\SOFTWARE\Microsoft\SQMClient\Windows\DisabledSessions
	No improvement
- Reinstalling dotnet (developer edition, x86 x64)
	No improvement
- Reinstalling "windows installer" is not on option on windows 7 (redistributable for 5.x doesn't exist)
- Running installer with default options (otherwise always custom, because it's not in the language I want, etc.)
	No improvement
- sfc /scannow
	Windows Resource Protection found corrupt files but was unable to fix some of them.
		(Log : "D:\Users\Ruben\Documents\Configs, addresses\Software\Windows problems\scannow log 2012-02-28.txt")
 But this is to my opinion, as stated above, possibly normal Windows status for a developer laptop where some installs have that effect.
Comment 10 0RUBn0 2012-03-14 07:45:26 UTC
P.S. I tried 3.5.0 and pre-release 3.5.1 (downloaded on 2012-03-14)
Comment 11 Andras Timar 2012-03-14 08:33:12 UTC
You listed many things which are IMHO unrelated. Try to remove VC++ runtimes instead, I guess you have many versions installed (in WinSxS folder).
Comment 12 0RUBn0 2012-03-14 08:42:34 UTC
Thanks for taking the trouble to answer me.
I have many and I read somewhere not to touch that folder.
So, which one do I exactly remove and won't it bother other programs?
Comment 13 0RUBn0 2012-03-14 09:41:53 UTC
I risked it anyway, I moved all folders in WinSxS that were find via "*vc90*" and I still have the same problem. Do I have to reset anything or so?
Comment 14 Andras Timar 2012-03-14 10:06:34 UTC
System will always use the latest available version from WinSxS folder. So older versions of the same components are just backups, if you happen to remove the latest version, you'll still have the "latest-1" version, etc. 

If I were you, I'd remove all versions of Microsoft Visual C++ 2008 Redistributable from Add/Remove Programs. That may, help.
Comment 15 0RUBn0 2012-03-14 10:32:25 UTC
First of all, for the record, I advice everyone NOT to remove those folders like I did, since I have several programs totally not working now!

Andras, I fail to understand how it will use the latest versions, since in your link it states to remove áll of those folders, which of course include the latest versions.
Anyway, it didn't help even with the latest ones.

Next trial (without putting those folders back yet):
I had 3 "Microsoft Visual C++ 2008" entries  in "Remove programs" (Redistributables I think), removed them and restarted. 
Still not installing.

But you are talking about 2008? I hope that doesn't mean I had to remove VC80 folders and not VC90?  Since your link points to a problem of VC80 and proposes to remove VC80 folders, I gathered that for a VC90 problem VC90 folders should be removed. Which ones did you remove?

I think after 2 man-days working on this problem, some fix in some next version is very welcome.
I am giving up. I am going to a corner now and cry.

Thanks for trying though!
Comment 16 Andras Timar 2012-05-10 12:20:02 UTC
*** Bug 49462 has been marked as a duplicate of this bug. ***
Comment 17 Not Assigned 2012-05-14 14:20:29 UTC
Andras Timar committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=80a921e88a036d42b4b884bb3e0b651fc083c1cd

fdo#46519 workaround of MSI installer error 1935
Comment 18 Andras Timar 2012-05-14 14:22:15 UTC
In some circumstances installation of embedded VC++ runtime fails with error code 1935. This usually occurs, when there are many different versions of VC++ runtimes installed on the computer, including beta versions. We can workaround this Microsoft bug, if we don't install our VC++ runtime. A new property was introduced. It is called VC_REDIST, and installation of VC++ runtime depends on its value. (BTW the solution is general, ComponentCondition can be used for any merge module, now we have only the VC++ runtime merge module.) When the user experiences error code 1935, he should try to install LibreOffice with the following command line: 
msiexec /i <msi file name> VC_REDIST=0 

The patch fixes another minor issue. 64-bit VC++ runtime will not be installed on 32-bit systems any more.
Comment 19 Not Assigned 2012-05-15 02:06:15 UTC
Andras Timar committed a patch related to this issue.
It has been pushed to "libreoffice-3-5":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f994abc0e669a0f4722a9c9e1d6d9fad5fb20c82&g=libreoffice-3-5

fdo#46519 workaround of MSI installer error 1935


It will be available in LibreOffice 3.5.4.
Comment 20 Rainer Bielefeld Retired 2012-05-19 10:40:30 UTC
Modified Version due to "Bug 46593 - Version 3.5 will not install"

@patheticcockroach@patheticcockroach.com
<http://wiki.documentfoundation.org/BugReport_Details#Version>
Comment 21 patheticcockroach 2012-05-23 06:05:13 UTC
(In reply to comment #19)
> Andras Timar committed a patch related to this issue.
> 
> fdo#46519 workaround of MSI installer error 1935
> 
> 
> It will be available in LibreOffice 3.5.4.
Thanks, 3.5.4rc1 installs fine for me.