Download it now!
Bug 49247 - Implement "Soft Edges" effect
Summary: Implement "Soft Edges" effect
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.3.4 release
Hardware: All All
: medium enhancement
Assignee: Mike Kaganski
URL:
Whiteboard: target:7.0.0 target:7.1.0 target:7.0.0.1
Keywords:
: 132463 (view as bug list)
Depends on: SoftEdgeFallout
Blocks: DTP
  Show dependency treegraph
 
Reported: 2012-04-28 03:09 UTC by sasha.libreoffice
Modified: 2020-09-28 08:56 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
pptx file with picture effects and screenshot (759.09 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2012-04-28 03:09 UTC, sasha.libreoffice
Details

Note You need to log in before you can comment on or make changes to this bug.
Description sasha.libreoffice 2012-04-28 03:09:49 UTC
Created attachment 60723 [details]
pptx file with picture effects and screenshot

Attachment contains:
1 slide: picture with effect (something like fuzzy borders)
2 slide: screenshot of first slide made in PP 2007 on Windows 7

reproduced in 3.3.4 and 3.5.2 on Fedora 64 bit and Windows 7 32 bit

What is interesting: in Power Point picture shown without effect during of editing it. Effects appears only when we select another object. (spare CPU consuming)
Comment 1 Rainer Bielefeld Retired 2012-04-28 08:48:32 UTC
Effect is reproducible with "LibreOffice 3.5.3.2 (RC2) German UI/Locale [Build-ID: 235ab8a-3802056-4a8fed3-2d66ea8-e241b80] on German WIN7 Home Premium (64bit).

I believe that the root of the problem is that DRAW does not support such an effect.

@sasha:
Do you agree with my suspect? That would mean we need an enhancement.
Comment 2 sasha.libreoffice 2012-04-28 09:02:53 UTC
I agree. This bug depends from this enhancement.
Comment 3 Heiko Tietze 2016-05-03 13:40:41 UTC
Extended image manipulation is not in the major focus of LibreOffice Draw. The mentioned effect can be done easily with any external tool. 

However, Impress (which would be the first to open Powerpoint documents, by the way) allows to apply a filter to an image (aging, charcoal, invert etc.) that could be made available in Draw (resp. for all modules) as well. And it's nothing to say against adding more options there.

Microsoft puts the focus on the visual style (that's how it is called there) meaning the presentation of the image. Effects are: Shadow, Reflection, Glow, Soft Edges, Bevel, 3-D Rotation. There are also "artistic effects" that correspond with Impress' image filters. Enough room for enhancements.

Setting component to Impress.
Comment 4 Regina Henschel 2019-07-16 17:22:50 UTC
The name of the effect in PowerPoint is "Soft Edges". It is missing, same as other effects too.
Comment 5 Mike Kaganski 2020-05-07 20:24:49 UTC
*** Bug 132463 has been marked as a duplicate of this bug. ***
Comment 6 Commit Notification 2020-05-10 22:13:34 UTC
Mike Kaganski committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/5952331844450dad93e21d2e329d51841ae1700e

tdf#49247: implement soft edges document model and import/export

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 m.a.riosv 2020-05-11 08:00:30 UTC
*** Bug 132897 has been marked as a duplicate of this bug. ***
Comment 8 Commit Notification 2020-05-11 16:25:10 UTC
Mike Kaganski committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/d8d31f74236e87ea878f7fac5538e707df5b13ca

tdf#49247: no need in extra boolean property, radius is enough

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2020-05-13 21:30:50 UTC
Mike Kaganski committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/cbc13ac0624685582ebd4634812681274db803aa

tdf#49247: draw soft edges

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2020-05-14 06:13:40 UTC
Mike Kaganski committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/fcb945e37dc31c11bcc3195fcbe835a63bb5bf5f

tdf#49247: add sidebar panel for soft edges effect

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Commit Notification 2020-05-26 11:09:39 UTC
Mike Kaganski committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/39b1e229232d83cce08d9c95e2927a0fd52eff81

tdf#49247, tdf#101181: gtk needs "upper", otherwise the control is disabled

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Commit Notification 2020-05-29 04:24:27 UTC
Mike Kaganski committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/541e5a9e84c42fbf20158b01a4feaa0f226e9ed0

tdf#49247, tdf#101181: Fix effect bounds

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Commit Notification 2020-05-29 04:24:49 UTC
Mike Kaganski committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/2cfe93da835eb500c9a170d22fce19fbd1de9473

tdf#49247, tdf#101181: don't rely on automatic scaling of alpha mask

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 Commit Notification 2020-05-29 04:26:29 UTC
Mike Kaganski committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/425125e31f9053e0e4895fb13e1e267ec5d26487

tdf#49247: Reimplement soft edges to keep object transparency

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 15 Commit Notification 2020-05-29 04:26:40 UTC
Mike Kaganski committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/9dcbf7b0098e59c22ec17d86c270d610e0416f72

tdf#49247, tdf#101181: output glow and soft edge effects to metafile

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 16 Commit Notification 2020-05-29 08:31:42 UTC
Mike Kaganski committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/58e74f32a8f0b003226b8897d51bfd5516a966bb

tdf#49247, tdf#101181: Fix effect bounds

It will be available in 7.0.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 17 Commit Notification 2020-05-29 08:32:03 UTC
Mike Kaganski committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/d0aff1174189983a1a090f61a504d6a3c7fca095

tdf#49247, tdf#101181: don't rely on automatic scaling of alpha mask

It will be available in 7.0.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 18 Commit Notification 2020-05-29 08:32:19 UTC
Mike Kaganski committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/a89d2a19930ba4f14bc498978664c45bfd3e8b58

tdf#49247: Reimplement soft edges to keep object transparency

It will be available in 7.0.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 19 Commit Notification 2020-05-29 08:33:38 UTC
Mike Kaganski committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/c8787b8469053bfa1105697d7852dbdac4a184ba

tdf#49247, tdf#101181: output glow and soft edge effects to metafile

It will be available in 7.0.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 20 Andras Timar 2020-06-01 17:54:58 UTC
Seems to be good in my LibreOffice 7.0 snapshot build. Thanks Mike!
Comment 21 Gerald Pfeifer 2020-06-01 22:41:53 UTC
Three days ago I saw the effect working in edit mode, alas not in presentation
mode.  That seems to have been addressed in those last 72 hours (according to my
tests at least)?

This is an important one really helping interoperability. Nice!
Comment 22 Mike Kaganski 2020-06-02 05:49:41 UTC
(In reply to Gerald Pfeifer from comment #21)
> Three days ago I saw the effect working in edit mode, alas not in
> presentation
> mode.  That seems to have been addressed in those last 72 hours (according
> to my
> tests at least)?

You are absolutely correct! :-)
Comment 23 Adolfo Jayme 2020-06-15 20:38:41 UTC
Lovely new feature, Mike 💜