Bug 57147 - EDITING: Paste stops working after several copy-paste
Summary: EDITING: Paste stops working after several copy-paste
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.0.2 rc
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
: 68013 (view as bug list)
Depends on:
Blocks: Paste
  Show dependency treegraph
 
Reported: 2012-11-15 09:05 UTC by Matti Ruhanen
Modified: 2019-04-21 10:02 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Matti Ruhanen 2012-11-15 09:05:27 UTC
Problem description: 

Steps to reproduce:
1. Coping text into clipboard and paste it into writer. This working fine for a while (several copy/paste phases should happend).
2. Libre writer application stacking after many copy/paste phases (application not responding) and it taking ~4-5min while application working again proberly but paste not working anymore.
3. I should restart Libre Writer. Copy/paste working again. This same problem reproduced for me during same date several times. 

Current behavior:
Paste the text not working into Libre writer
Anywhere else the same working at the same time

Expected behavior:
Paste should work also for writer

Platform (if different from the browser): 
Win8 professional
Comment 1 billhook 2012-11-16 01:29:19 UTC
Any chance you can try reproducing this on a different version of Windows? (e.g. Win7, XP etc)

How big is the text you are pasting? 5 lines? 50 lines? 500 lines?

Are you pasting into an empty document? Or an existing document?
Comment 2 Mike Lister 2013-01-13 19:48:42 UTC
(In reply to comment #1)
> Any chance you can try reproducing this on a different version of Windows?
> (e.g. Win7, XP etc)
> 
> How big is the text you are pasting? 5 lines? 50 lines? 500 lines?
> 
> Are you pasting into an empty document? Or an existing document?

I frequently cut online newspaper articles from Firefox and paste into LibreOffice Writer.  Using the release 3.6 and the RC 4.1 after several cut and pastes LibreOffice gets stuck and will only paste an old paste.
At that point I can cleanly paste into Microsoft Word but not LibreOffice without exiting the program and reloading LibreOffice.
I am using Windows 8 Professional with up-to-date patches.  I can repeat this easily and it stops me using LibreOffice as this becomes tiresome.

I do not have older versions of Windows available.  Can easily replicate after 4 or 5 paste operations.  Can supply screen recording if needed.
Comment 3 Mike Lister 2013-01-31 11:15:55 UTC
I can confirm this problem is still a repeatable bug in LibreOffice 4 rc 2 using Windows 8 Pro.
Comment 4 VX 2013-01-31 14:50:08 UTC
I can not confirm this for LO 4.0 RC 2 Win 7 64bit. I have no Java installed.

Maybe Java is the culprit? Try uninstall Java and report back if it helps.
Comment 5 Mike Lister 2013-02-26 14:08:22 UTC
(In reply to comment #4)
> I can not confirm this for LO 4.0 RC 2 Win 7 64bit. I have no Java installed.
> 
> Maybe Java is the culprit? Try uninstall Java and report back if it helps.

I can confirm problem still exists in Writer without Java with version 4.003 and Windows 8 Professional. Problem appears randomly - pasting in Word 2010 at point of problem is OK so problem is Writer specific. I could run debug version if you have one.  I have had periods where 20 pastes are OK before the problem - other times after 2-3 pastes. Each time I'm pasting newspaper articles and copying a  heading to create a filename. Writer retains the heading and not the next paste.
Restarting LibreOffice clears the problem.
Comment 6 Mike Lister 2013-03-12 18:42:47 UTC
I can confirm this random bug is still present in version 4.0.1.2 in Windows 8 Professional.
It may be related to occasionally LibreOffice losing user input for a minute or so – e.g. cursor will not show pointer to do a save.  This may be unrelated but happened prior to the paste problem.  Note cursor problem is LibreOffice specific and not any other running Windows programs.
Comment 7 Mike Lister 2013-03-22 17:38:38 UTC
I can confirm this random bug is still present in Writer LibreOffice Version 4.0.2.1 (Build ID: 7e5467ff8f30d821f4fbf69cb2769163eb64c2c).

It’s a shame this isn’t being dealt with as copy and paste are the two most common word processing functions according to Microsoft user captured data form Word.  It gives the impression to non-technical users the program is less robust than it actually is.

I’m prepared to help track it down.
Comment 8 Mikael Jonasson 2013-05-05 21:24:50 UTC
It looks like you guys have found the same bug as I have found?
For me File Explorer on Win8 needs to be closed to make copy/paste work without issues. Release version or latest Dev it is all the same.
It is possible that other applications too can create this effect on LibreOffice. For me this has been possible to replicate on a fresh install of Win8 with only Panda Cloud Antivirus and Windows debugger installed. Nothing else is currently running on the system.
Works fine without an open File Explorer. Open File Explorer, open an odt (I guess any filetype works) or create a new one (leave File Explorer open), copy and paste some text (one or a few times), and it does not work properly anymore.

This does not affect either WinXP or Win7. Only Win8, and only with File Explorer open (in my case).

If you have not seen my bug newly added as an "see also" here it is:
https://bugs.freedesktop.org/show_bug.cgi?id=64235
Comment 9 Mike Lister 2013-05-13 17:40:35 UTC
I can confirm this is still a problem on Windows 8 using Version 4.0.3.3.
Comment 10 Mikael Jonasson 2013-05-15 17:51:05 UTC
(In reply to comment #9)
> I can confirm this is still a problem on Windows 8 using Version 4.0.3.3.

Same for me. I have ran the debug version and collected info the best I could on this. But it was too close to the 4.0.3.3 release I guess. Hopefully my info have helped someone developer at least. If only my programming skill were less limited...

Can you always replicate this regardless of what applications you have open otherwise?
Comment 11 Mike Lister 2013-05-17 13:02:56 UTC
Yes I can always replicate.  I have tried many permutations of programs running or not running and I removed Java as suggested.  Usually I have Firefox running as I cut and paste articles from the web to read in LibreOffice with much larger text.  (I have poor vision for reading the computer screen)   As I mentioned this is LibreOffice specific as any other program will paste correctly.

I cannot believe more people haven't reported this unless LibreOffice users are primarily Linux based.
Comment 12 Mike Lister 2013-06-13 10:52:51 UTC
I can confirm this is still a problem with Version 4.0.3.3 (Build ID: 0eaa50a932c8f2199a615e1eb30f7ac74279539.
Comment 13 Mikael Jonasson 2013-06-15 08:30:26 UTC
https://www.youtube.com/watch?v=hQm_JVdOpx4 , first attempt crash
Comment 14 Mike Lister 2013-06-22 16:36:23 UTC
I confirm this is still a problem with Version 4.0.4.2 (Build ID: 9e9821abd0ffdbc09cd8c52eaa574fa09eb08f2)
Comment 15 Jürgen 2013-11-04 08:15:46 UTC
*** Bug 68013 has been marked as a duplicate of this bug. ***
Comment 16 Sal 2015-03-22 03:29:12 UTC
I confirm this paste bug is still a problem with Version 4.4.1.2. 
Here is either the same or very similar paste bug I've reported in Writer. 
https://bugs.documentfoundation.org/show_bug.cgi?id=90120
Comment 17 Sal 2015-03-22 03:31:23 UTC
I'm using Win7 64, and Win XP 32.
Comment 18 Jean-Baptiste Faure 2015-03-28 13:33:20 UTC
*** Bug 68013 has been marked as a duplicate of this bug. ***
Comment 19 tommy27 2016-04-16 07:23:51 UTC Comment hidden (obsolete)
Comment 20 Jürgen 2016-04-18 09:11:13 UTC
Error was solved in last versions of 4.X but now appears again in 5.0.5.2 in a similiar way.
I paste a text from Thunderbird into LO Write - works fine.
I try to copy a second text:
The "Clipboard"-Icon in LO changes from coloured to gray and no paste is available.
I push Ctrl+C a second (or sometimes a third or fourth) time - Clipboard-Icon becomes coloured again and paste is available.
Comment 21 QA Administrators 2017-05-22 13:24:15 UTC Comment hidden (obsolete)
Comment 22 Jürgen 2017-05-22 13:34:55 UTC Comment hidden (obsolete)
Comment 23 Timur 2017-07-18 18:15:18 UTC
(In reply to Jürgen from comment #22)
> The bug has same behavior in Version 5.2.6.2 / Windows 10

This could be the old problem: Bug 46406, Bug 107515. 
But unfortunately it can only be solved if reproducible. 
Since LO 5.2 there's crash report but you don't mention it, it's not invoked?
Please see https://bugs.documentfoundation.org/show_bug.cgi?id=107515#c11
Comment 24 Jürgen 2018-02-26 12:36:39 UTC
In 5.2.7.2. Bug is still present. As it occurs just once a day it is hard to reconstruct. Still after copying Text from Thunderbird (52.6.0 - 32 bit) the Clipboard-Symbol disappears. Repeating Ctrl+C once or several times lets the symbol appear again an text can be pasted.
May be important, that the text is combined with database for Mailings.
Comment 25 Timur 2018-02-27 10:41:58 UTC Comment hidden (obsolete)
Comment 26 Kevin Suo 2018-03-01 13:37:22 UTC Comment hidden (obsolete)
Comment 27 Buovjaga 2018-10-18 13:19:14 UTC
(In reply to Kevin Suo from comment #26)
> I have been suffering from this bug for a long time, in Linux, but I never
> had a chance to get the steps to 99% reproducing this.
> Most of the time I was trying to copy paste from PDF documents and
> frenqently switching between windows when this bug incurre.

Adjusting fields as this is not Win-only after all
Comment 28 bugzilla2 2019-04-21 10:02:27 UTC
Seems like I have found a way to make it reproduceable:

1. Open Vivaldi or Opera (possibly any chromium based browser might work...)
2. Go to https://www.heise.de/newsticker/
3. mark and copy (CTRL + C) the first newsticker headline (but ONLY the headline, currently for example "Malware-Angriff legt US-Wettersender zeitweise lahm". Do NOT rightclick the link and copy the link, but mark the text and copy the text. This is why Firefox or IE doesn't work, because you can't select the text there.
4. open a new Writer Document
5. paste the clipboard with CTRL + SHIFT + V -> unformated Text -> OK
6. Make a new line in Writer
7. Copy the second newsticker headline
8. try to paste clipboard in writer with CTRL + SHIFT + V -> unformated Text -> OK
9. If its still working on the second try, try again. It shouldn't take long to make it break.

Result for me:
the first paste is working, the second doesn't. If that happend once, there are some interesting effects:

1.) You cant paste with CTRL + SHIFT + V but you can still paste with CTRL + V
2.) Even though CTRL + V does work, the options in the GUI (EDIT -> PASTE) does NOT work
3.) restarting LibO (including quickstart) brings everything back to normal, but its reproducable