Bug 57337 - FORMATTING: Impossible to configure the default bullet styles
Summary: FORMATTING: Impossible to configure the default bullet styles
Status: RESOLVED DUPLICATE of bug 69724
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 106995 (view as bug list)
Depends on:
Blocks: Numbering-Formats
  Show dependency treegraph
 
Reported: 2012-11-20 19:09 UTC by Samuel Atkins
Modified: 2019-09-09 11:48 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Samuel Atkins 2012-11-20 19:09:30 UTC
An elderly friend of mine regularly wants to print out tick lists. It is possible to style lists in this way in Writer, but you have to select a box character from the 'Options' tab. This is a bit beyond him, and he told me he previously gave up on using OpenOffice because it didn't allow him to do this, whereas MS Word97, which he was otherwise using, has checkbox bullets easily selectable.

I think perhaps a good solution might be to allow the user to customise the 8 bullet styles that appear on the 'Bullets' tab. Perhaps right-clicking on one would allow you to modify it. Then, these styles would be saved so that when creating a new document, the user's customised bullet styles would be displayed.

While searching, I found a similar issue, Bug 36574. I think this also would be solved by this.

I would be happy to help out with developing a solution if someone pointed me in the right direction.
Comment 1 A (Andy) 2012-12-24 19:33:52 UTC
I would agree that LO's BULLETS AND NUMBERING function should be really improved like in this bug report commented.  For instance it should also be easily be possible to amend the bullets like to change the character or for instance the colour of a bullet.
Comment 2 A (Andy) 2013-05-04 10:31:19 UTC
@Miklós: Could this issue maybe be something for you?

In MSO 2007 you have the option for instance to change the color of a bullet and this is an option which I really miss in my daily work in LO.  Therefore, it would be great if we could implement this in LO.
Comment 3 Matias 2016-06-24 18:30:25 UTC
I think that this is a big issue considering than many other programs have already given a solution. We need an easy way and more configurable and I have to say a nicer window or tool to change the colour, font, character, size and anything that you can actually do with any paragraph but with bullets and numbering lists. 
Regardless, I can't stop saying thanks for LibreOffice, your work is excellent.
Comment 4 Regina Henschel 2017-04-07 13:57:33 UTC
*** Bug 106993 has been marked as a duplicate of this bug. ***
Comment 5 Regina Henschel 2017-04-07 13:58:55 UTC
*** Bug 106995 has been marked as a duplicate of this bug. ***
Comment 6 Cor Nouws 2017-04-07 14:08:22 UTC
(In reply to Samuel Atkins from comment #0)

> I think perhaps a good solution might be to allow the user to customise the
> 8 bullet styles that appear on the 'Bullets' tab. 

You can't modify the default list.
But there are 10 list styles offered, and you can modify those and create a hundred more. With settings as you like.

I don't understand the problem.
Comment 7 Cor Nouws 2017-04-07 15:41:50 UTC
work around, not chique of course, is to add one paragraph in the file with the changed default bullet/number. That makes that it is saved in the file too ..
Comment 8 Dieter Praas 2018-12-06 08:43:10 UTC
(In reply to Cor Nouws from comment #6)
> You can't modify the default list.
> But there are 10 list styles offered, and you can modify those and create a
> hundred more. With settings as you like.
> 
> I don't understand the problem.

It would be much more comfortable, if you could connect "Toggle Numbered List" button and the "Toggle Bulleted List" button to a customized default style.
Comment 9 Timur 2019-09-09 11:48:58 UTC
If I understand what was written first, this is a duplicate of Bug 69724. 
We normally keep the former, but we had some comments there, so I'll mark this one as a duplicate.

*** This bug has been marked as a duplicate of bug 69724 ***