Bug Hunting Session
Bug 58144 - unreadable text used during installation on Windows XP
Summary: unreadable text used during installation on Windows XP
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
4.0.0.0.alpha0+ Master
Hardware: Other Windows (All)
: medium normal
Assignee: Andras Timar
URL:
Whiteboard: target:4.2.0 target:4.1.3 target:4.0.6
Keywords: regression
: 63764 64667 67789 69338 69472 (view as bug list)
Depends on:
Blocks: mab4.0
  Show dependency treegraph
 
Reported: 2012-12-11 14:48 UTC by Andras Timar
Modified: 2013-10-15 15:35 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments
Installing Libreoffice 4.0.2.2 (496.00 KB, image/jpeg)
2013-03-28 15:20 UTC, Domingo Sacristan
Details
sample of partially readable text, see comment 30 (7.52 KB, image/png)
2013-09-21 12:03 UTC, Klaus
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andras Timar 2012-12-11 14:48:36 UTC
During basic install mode (msiexec /i libreoffice-4-0~2012-12-06_02.46.58_LibO-Dev_4.0.0.0.alpha1_Win_x86_install_en-US.msi /qb) I get boxes instead of characters in the MSI progress dialog. The log indicated that MSI loaded Estrangelo Edessa font, which is a font for Syriac script and does not contain latin letters. 

MSI (c) (5C:E0) [15:44:14:203]: Font created.  Charset: Req=1, Ret=0, Font: Req=, Ret=Arial

MSI (c) (5C:E0) [15:44:14:203]: Font created.  Charset: Req=1, Ret=1, Font: Req=Estrangelo Edessa, Ret=Estrangelo Edessa


The bug does not occur on Windows 7, there Arial font is loaded and used. I could not find a place in out installer where we could modify "Arial" to something else. Changing Arial to Tahoma in TextStyle table had no effect.

The bug may be related to database codepage. 
http://cgit.freedesktop.org/libreoffice/core/commit/?id=0475a7904978566dfb9f6e83497392b3841c0efc
In this commit I set the codepage for all database tables uniformly to UTF-8. I would not like to revert it, if it is possible.
Comment 1 Don't use this account, use tml@iki.fi 2012-12-11 15:02:04 UTC
It's just in the uninstallation progress bar window that the boxes show up, right? (At least, that's what I think I saw myself.) And that window doesn't request any complex input or action from the user, it has only a "Cancel" button (which *does* show the correct text).

I don't think it's that serious then, just a minor irritation. I don't think we should revert any useful changes to get it fixed...
Comment 2 Andras Timar 2012-12-20 06:58:13 UTC
*** Bug 58494 has been marked as a duplicate of this bug. ***
Comment 3 Pedro 2013-01-03 12:26:16 UTC
I can confirm the odd characters during Uninstall of LOdev 4.0Beta2 under Windows XP x86 SP3
These characters do not show up on the 3.5 or 3.6 uninstaller so it's a regression.
Comment 4 Marco Menardi 2013-01-12 16:11:41 UTC
RC1 installation shows a very brief problem (a sort of "flash") then all the subsequent messages are correct (I've installed in Italian and in English).
But uninstall has still this problem, so I thins Bug 58494 is NOT a duplicate
Comment 5 Andras Timar 2013-02-18 19:11:51 UTC
*** Bug 58494 has been marked as a duplicate of this bug. ***
Comment 6 Pedro 2013-03-27 11:58:12 UTC
Just lost all my unsaved data because an incomprehensible message during Uninstall of a LibreOffice Help package only had two options: Yes or No.

Turns out the message asked if I wanted to reboot immediately. Unfortunately I thought that it was confirming if I really wanted to uninstall the package...

This is NOT cosmetic!

Can someone please rise the Importance?
Comment 7 retired 2013-03-27 12:10:27 UTC
Pedro: Could you provide more detail? Which version of LO did you try to uninstall? On which OS was that? Is this problem reproducible for you? If so, could you please provide a screenshot showing the unclear confirmation dialogue?
Comment 8 Domingo Sacristan 2013-03-28 15:04:37 UTC
i confirm this behavior for the installations msi files from 
Libreoffice 4.0.1
Libreoffice 4.0.2.1
under win XP
Comment 9 Domingo Sacristan 2013-03-28 15:08:28 UTC
Sorry, i have forgotten
This happens by start the installation from the commandline
with the command msiexec ...
Comment 10 Domingo Sacristan 2013-03-28 15:20:04 UTC
Created attachment 77158 [details]
Installing Libreoffice 4.0.2.2

The problem persists installing Libreoffice 4.0.2.2
Comment 11 Andras Timar 2013-03-28 15:27:21 UTC
Thanks, but this bug has been confirmed already. Please do not add more confirmations. 

I spent quite a lot of time looking for solution but I have not found any. It seems installer under Windows XP cannot cope with UTF8 encoded MSI package. Why on earth Windows wants to load Estrangelo Edessa font, instead of Tahoma or Arial, this is a mystery. Please post only useful comments or patches to this bug from now on. Thanks. Note, that this bug is specific to Windows XP, whose extended-extended-extended support is ending on April 8, 2014, so hopefully people will move on to newer OSes anyway.
Comment 12 Rainer Bielefeld Retired 2013-04-16 15:30:35 UTC
Something went wrong here, this one has nothing to do with Bug 63585
Comment 13 Jan Holesovsky 2013-04-19 16:53:55 UTC
I'd say - let's mark this as wontfix.  The reason was found (switch to UTF-8), it is a change we need, and no workaround was found.  Also, this is only during uninstallation, and no user input is expected; so hopefully people can live with this until they upgrade to a newer Windows ;-)
Comment 14 Andras Timar 2013-04-21 06:35:11 UTC
*** Bug 63764 has been marked as a duplicate of this bug. ***
Comment 15 Pedro 2013-04-22 00:42:38 UTC
Hi Kendy

(In reply to comment #13)
> I'd say - let's mark this as wontfix.  The reason was found (switch to
> UTF-8), it is a change we need, and no workaround was found.  Also, this is
> only during uninstallation, and no user input is expected; so hopefully
> people can live with this until they upgrade to a newer Windows ;-)

As I mentioned in Comment #6 there is a combination of events where the installer asks for a Reboot. Can you please confirm there is such a message? I don't remember the sequence of events that led to that message but this caused data loss (under Windows XP x86 SP3 en_US). There are nearly 40% of PC users *worldwide* still using Windows XP (http://en.wikipedia.org/wiki/Usage_share_of_operating_systems). IMO this is not a negligible portion of the users.
Comment 16 Urmas 2013-05-16 15:10:26 UTC
*** Bug 64667 has been marked as a duplicate of this bug. ***
Comment 17 Urmas 2013-08-12 19:06:11 UTC
*** Bug 67789 has been marked as a duplicate of this bug. ***
Comment 18 Urmas 2013-09-14 01:29:05 UTC
*** Bug 69338 has been marked as a duplicate of this bug. ***
Comment 19 Urmas 2013-09-17 17:50:51 UTC
*** Bug 69472 has been marked as a duplicate of this bug. ***
Comment 20 Pedro 2013-09-17 23:34:04 UTC
(In reply to comment #13)
> Also, this is
> only during uninstallation, and no user input is expected; so hopefully
> people can live with this until they upgrade to a newer Windows ;-)

User input is expected and even a reboot can be performed because the messages are unreadable.

See Bug report and attachments within
https://bugs.freedesktop.org/show_bug.cgi?id=69472

If no one can find a solution for the moment at least don't close the bug. 

If TDF doesn't want any more Windows XP related bug reports please let me know.
Comment 21 Michael Meeks 2013-09-18 08:21:15 UTC
Andras - just to get a better view of this: what languages does this impact ?

It seems that the bug referenced in your commit: fdo#39595 is primarily focused on accelerating the make_installer.pl. Is that really a good trade-off ? how much time does that really save when build/packaging ? or is there another win that increases language support somehow ?
Comment 22 Andras Timar 2013-09-18 08:48:01 UTC
There is a workaround for unreadable characters. In Control Panel - Regional and Language Options - Language tab, check the two checkboxes of Supplemental language support.
Comment 23 Pedro 2013-09-19 10:40:14 UTC
(In reply to comment #22)
> There is a workaround for unreadable characters. In Control Panel - Regional
> and Language Options - Language tab, check the two checkboxes of
> Supplemental language support.

That is a Catch22... You need to Install system fonts which require a reboot (assuming you have your Windows XP install CD at hand)...

So when you are faced with the unreadable message that asks for a Reboot should you at that point install the fonts which also require a reboot? :)
Comment 25 Tor Lillqvist 2013-09-21 06:26:30 UTC
Pedro, "WONTFIX" is a valid bug resolution. But if you prefer a bug to be open but ignored, whatever.
Comment 26 Tor Lillqvist 2013-09-21 06:29:08 UTC
Michael, the unreadable output during uninstallation shows up even in a very plain Latin script -using Windows XP installation. I have seen it myself and I used a Swedish XP, and I certainly don't know Syriac or other complex script languages and had not set XP to use any such.
Comment 27 Pedro 2013-09-21 09:15:32 UTC
(In reply to comment #25)
> Pedro, "WONTFIX" is a valid bug resolution. But if you prefer a bug to be
> open but ignored, whatever.

Tor, of course it is a valid resolution. But I believe it applies to some absurd request (like "Make function SUM calculate an AVERAGE") and the developer replies WONTFIX meaning "We won't fix that"

In this case RESOLVED as WONTFIX means no one else will even try because it is RESOLVED. This is still a real problem that can cause DATA LOSS.

If it is OPEN you can ignore it but someone else can give it a try.
Comment 28 Andras Timar 2013-09-21 09:47:48 UTC
I found a workaround. We can disable the Remove button on Add or Remove Programs Control Panel applet - only when VersionNT < 600 (XP, 2003 Server). So the user will not encounter the corrupted characters. If the user wants to uninstall LibreOffice, it is possible with the Change button, and LibreOffice can be uninstalled by the Wizard, where characters are not corrupted. Update is not affected, a newer version silently removes the older version. Is it acceptable?
Comment 29 Pedro 2013-09-21 10:13:21 UTC
(In reply to comment #28)
> I found a workaround. We can disable the Remove button on Add or Remove
> Programs Control Panel applet - only when VersionNT < 600 (XP, 2003 Server).
> So the user will not encounter the corrupted characters. If the user wants
> to uninstall LibreOffice, it is possible with the Change button, and
> LibreOffice can be uninstalled by the Wizard, where characters are not
> corrupted. Update is not affected, a newer version silently removes the
> older version. Is it acceptable?

Hi Andras

I tested uninstalling using Remove and did not come across the Reboot message (but then again it doesn't show everytime). 
It seems a much better option than WONTFIX :)
Can you add that change and I will test it as soon as it's available in a daily build?

Thanks!
Comment 30 Klaus 2013-09-21 12:01:58 UTC
Two strange observations that might help:

The texts "removing old versions" and "preparing to remove old versions" are always readable, what is different with these texts?

Sometimes the upper lines of the broken texts can be made visible by moving another window across the installer window.
Comment 31 Klaus 2013-09-21 12:03:15 UTC
Created attachment 86239 [details]
sample of partially readable text, see comment 30
Comment 32 Andras Timar 2013-09-21 20:23:19 UTC
Pedro, if you try to uninstall when LibreOffice is running, you will get the reboot dialog. (Of course, you will also get it, if e.g. indexer is running, but it is unpredictable.)

Klaus, your screenshot is amazing! :) Windows at its best.
Comment 33 Commit Notification 2013-09-21 21:31:33 UTC
Andras Timar committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=d5295408b1f69b8fd694dabca00e0a923c3e959f

fdo#58144 - disable the ARP 'Remove' button on Windows XP



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 34 Andras Timar 2013-10-02 19:02:26 UTC
Fixed with workaround described in comment 28. I submitted the patch to all release branches for review.
Comment 35 Commit Notification 2013-10-04 12:47:08 UTC
Andras Timar committed a patch related to this issue.
It has been pushed to "libreoffice-4-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=e41365b3657780170016a0bd3c13d6d665ac422c&h=libreoffice-4-1

fdo#58144 - disable the ARP 'Remove' button on Windows XP


It will be available in LibreOffice 4.1.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 36 Commit Notification 2013-10-04 12:47:27 UTC
Andras Timar committed a patch related to this issue.
It has been pushed to "libreoffice-4-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=fb8db80319d5a88ee12b30064d89d4a176f8b537&h=libreoffice-4-0

fdo#58144 - disable the ARP 'Remove' button on Windows XP


It will be available in LibreOffice 4.0.7.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 37 Commit Notification 2013-10-15 15:35:03 UTC
Andras Timar committed a patch related to this issue.
It has been pushed to "libreoffice-4-0-6":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=51b71f0a9ca0c7504849ccea8dae9c9896d2eeb1&h=libreoffice-4-0-6

fdo#58144 - disable the ARP 'Remove' button on Windows XP


It will be available already in LibreOffice 4.0.6.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.