Bug 58177 - EDITING: Complete crash due to Duden plugin when right mouse button clicked on OLE objects and images
Summary: EDITING: Complete crash due to Duden plugin when right mouse button clicked o...
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.6.4.3 release
Hardware: x86-64 (AMD64) Mac OS X (All)
: medium major
Assignee: Not Assigned
QA Contact:
URL:
Whiteboard: BSA
Keywords:
: 47250 56430 59130 65732 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-12-12 08:06 UTC by Marcus Hudritsch
Modified: 2013-06-23 15:09 UTC (History)
12 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marcus Hudritsch 2012-12-12 08:06:39 UTC
Complete crash due to the Duden plugin when right mouse button clicked on OLE objects and images.
It was stated that this will be fixed in 3.6.4:

------------------------------------------------------------
libreoffice-bugs@lists.freedesktop.org changed bug 47250 
What	Removed	Added
Whiteboard	target:3.7.0	target:3.7.0 target:3.6.4
Comment # 26 on bug 47250 from libreoffice-bugs@lists.freedesktop.org
Caolan McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-3-6":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=83be8c5b81feaf7e843898f4f6a1387c7ade183a&g=libreoffice-3-6
Related: fdo#47250 fdo#56430 catch harder
It will be available in LibreOffice 3.6.4.
-------------------------------------------------------------

Here is the crash log:

Process:         soffice [852]
Path:            /Applications/LibreOffice.app/Contents/MacOS/soffice
Identifier:      org.libreoffice.script
Version:         3.6.4.3 (???)
Code Type:       X86 (Native)
Parent Process:  launchd [237]
User ID:         501

Date/Time:       2012-12-12 09:04:42.835 +0100
OS Version:      Mac OS X 10.8.2 (12C3006)
Report Version:  10

Interval Since Last Report:          603644 sec
Crashes Since Last Report:           14
Per-App Crashes Since Last Report:   2
Anonymous UUID:                      663C3B41-0758-9A3A-1E72-454CDF99CF07

Crashed Thread:  0  Dispatch queue: com.apple.main-thread

Exception Type:  EXC_CRASH (SIGABRT)
Exception Codes: 0x0000000000000000, 0x0000000000000000

Application Specific Information:
abort() called
terminate called throwing an exception

Thread 0 Crashed:: Dispatch queue: com.apple.main-thread
0   libsystem_kernel.dylib        	0x90bc4a6a __pthread_kill + 10
1   libsystem_c.dylib             	0x94d5aacf pthread_kill + 101
2   libsystem_c.dylib             	0x94d914f8 abort + 168
3   libc++abi.dylib               	0x947c880c abort_message + 151
4   libc++abi.dylib               	0x947c6275 default_terminate() + 34
5   libc++abi.dylib               	0x947c62b5 safe_handler_caller(void (*)()) + 13
6   libc++abi.dylib               	0x947c629a unexpected_defaults_to_terminate() + 23
7   libc++abi.dylib               	0x947c62fb __cxxabiv1::__unexpected(void (*)()) + 14
8   libc++abi.dylib               	0x947c71d9 __cxa_call_unexpected + 58
9   dudenkorrektor.uno.dylib      	0x1a346a96 Duden::ContextMenuInterceptor::notifyContextMenuExecute(com::sun::star::ui::ContextMenuExecuteEvent const&) + 2922
10  libsfxlo.dylib                	0x007d3968 SfxViewShell::TryContextMenuInterception(Menu&, rtl::OUString const&, Menu*&, com::sun::star::ui::ContextMenuExecuteEvent) + 376
11  libsfxlo.dylib                	0x00767903 SfxPopupMenuManager::ExecutePopup(ResId const&, SfxViewFrame*, Point const&, Window*) + 387
12  libsfxlo.dylib                	0x005927f2 SfxDispatcher::ExecutePopup(unsigned short, Window*, Point const*) + 242
13  libswlo.dylib                 	0x156a0472 SwEditWin::Command(CommandEvent const&) + 5714
14  libvcllo.dylib                	0x01aca895 ImplCallCommand(Window*, unsigned short, void*, unsigned char, Point*) + 245
15  libvcllo.dylib                	0x01acd07e ImplHandleMouseEvent(Window*, unsigned short, unsigned char, long, long, unsigned long, unsigned short, unsigned short) + 5598
16  libvcllo.dylib                	0x01acd4d2 ImplWindowFrameProc(Window*, SalFrame*, unsigned short, void const*) + 850
17  libvcllo.dylib                	0x01b2f288 -[SalFrameView sendMouseEventToFrame:button:eventtype:] + 520
18  libvcllo.dylib                	0x01b2b702 -[SalFrameView rightMouseDown:] + 66
19  com.apple.AppKit              	0x95c29bf1 -[NSWindow sendEvent:] + 7432
20  com.apple.AppKit              	0x95c24a0f -[NSApplication sendEvent:] + 4278
21  libvcllo.dylib                	0x01b210fc -[VCL_NSApplication sendEvent:] + 108
22  libvcllo.dylib                	0x01ad8714 AquaSalInstance::Yield(bool, bool) + 516
23  libvcllo.dylib                	0x017eff60 Application::Yield(bool) + 96
24  libvcllo.dylib                	0x017f0061 Application::Execute() + 97
25  libsofficeapp.dylib           	0x000784db desktop::Desktop::Main() + 6171
26  libvcllo.dylib                	0x017f9582 ImplSVMain() + 354
27  libvcllo.dylib                	0x01ad7d7b AquaSalInstance::handleAppDefinedEvent(NSEvent*) + 75
28  libvcllo.dylib                	0x01b211cb -[VCL_NSApplication sendEvent:] + 315
29  com.apple.AppKit              	0x95b3e72c -[NSApplication run] + 951
30  com.apple.AppKit              	0x95ae16f6 NSApplicationMain + 1053
31  libvcllo.dylib                	0x01ad9337 ImplSVMainHook(int*) + 343
32  libvcllo.dylib                	0x017f9611 SVMain() + 17
33  libsofficeapp.dylib           	0x000a74e5 soffice_main + 437
34  org.libreoffice.script        	0x00001f0e main + 30
35  org.libreoffice.script        	0x00001872 _start + 216
36  org.libreoffice.script        	0x00001799 start + 41

Thread 1:
0   libsystem_kernel.dylib        	0x90bc48e2 __psynch_cvwait + 10
1   libsystem_c.dylib             	0x94d5e289 _pthread_cond_wait + 938
2   libsystem_c.dylib             	0x94debb30 pthread_cond_timedwait + 47
3   libuno_sal.dylib.3            	0x00014928 rtl_cache_wsupdate_all(void*) + 280
4   libsystem_c.dylib             	0x94d59557 _pthread_start + 344
5   libsystem_c.dylib             	0x94d43cee thread_start + 34

Thread 2:: Dispatch queue: com.apple.libdispatch-manager
0   libsystem_kernel.dylib        	0x90bc59ae kevent + 10
1   libdispatch.dylib             	0x9000bc71 _dispatch_mgr_invoke + 993
2   libdispatch.dylib             	0x9000b7a9 _dispatch_mgr_thread + 53

Thread 3:
0   libsystem_kernel.dylib        	0x90bc3eb6 __accept_nocancel + 10
1   libsystem_kernel.dylib        	0x90bc2e91 accept + 39
2   libuno_sal.dylib.3            	0x0000754a osl_acceptPipe + 58
3   libsofficeapp.dylib           	0x000a434e desktop::OfficeIPCThread::execute() + 46
4   libuno_salhelpergcc3.dylib.3  	0x004d1da2 salhelper::Thread::run() + 34
5   libuno_salhelpergcc3.dylib.3  	0x004d2152 threadFunc + 18
6   libuno_sal.dylib.3            	0x0000dc12 osl_thread_start_Impl + 434
7   libsystem_c.dylib             	0x94d59557 _pthread_start + 344
8   libsystem_c.dylib             	0x94d43cee thread_start + 34

Thread 4:
0   libsystem_kernel.dylib        	0x90bc48e2 __psynch_cvwait + 10
1   libsystem_c.dylib             	0x94d5e289 _pthread_cond_wait + 938
2   libsystem_c.dylib             	0x94debafc pthread_cond_wait + 48
3   libuno_sal.dylib.3            	0x00031a78 osl_waitCondition + 104
4   liblnglo.dylib                	0x1716e0a3 GrammarCheckingIterator::DequeueAndCheck() + 2563
5   libuno_sal.dylib.3            	0x0000dc12 osl_thread_start_Impl + 434
6   libsystem_c.dylib             	0x94d59557 _pthread_start + 344
7   libsystem_c.dylib             	0x94d43cee thread_start + 34

Thread 5:
0   libsystem_kernel.dylib        	0x90bc48e2 __psynch_cvwait + 10
1   libsystem_c.dylib             	0x94d5e289 _pthread_cond_wait + 938
2   libsystem_c.dylib             	0x94debb30 pthread_cond_timedwait + 47
3   libuno_sal.dylib.3            	0x00031b29 osl_waitCondition + 281
4   libupdchk.dylib               	0x08a08659 (anonymous namespace)::UpdateCheckThread::run() + 345
5   libupdchk.dylib               	0x08a0a652 threadFunc + 18
6   libuno_sal.dylib.3            	0x0000dc12 osl_thread_start_Impl + 434
7   libsystem_c.dylib             	0x94d59557 _pthread_start + 344
8   libsystem_c.dylib             	0x94d43cee thread_start + 34

Thread 6:
0   libsystem_kernel.dylib        	0x90bc50ee __workq_kernreturn + 10
1   libsystem_c.dylib             	0x94d5c04c _pthread_workq_return + 45
2   libsystem_c.dylib             	0x94d5be19 _pthread_wqthread + 448
3   libsystem_c.dylib             	0x94d43cca start_wqthread + 30

Thread 7:
0   libsystem_kernel.dylib        	0x90bc50ee __workq_kernreturn + 10
1   libsystem_c.dylib             	0x94d5c04c _pthread_workq_return + 45
2   libsystem_c.dylib             	0x94d5be19 _pthread_wqthread + 448
3   libsystem_c.dylib             	0x94d43cca start_wqthread + 30

Thread 8:
0   libsystem_kernel.dylib        	0x90bc50ee __workq_kernreturn + 10
1   libsystem_c.dylib             	0x94d5c04c _pthread_workq_return + 45
2   libsystem_c.dylib             	0x94d5be19 _pthread_wqthread + 448
3   libsystem_c.dylib             	0x94d43cca start_wqthread + 30

Thread 0 crashed with X86 Thread State (32-bit):
  eax: 0x00000000  ebx: 0xbfffe764  ecx: 0xbfffe6dc  edx: 0x90bc4a6a
  edi: 0xac695a28  esi: 0x00000006  ebp: 0xbfffe6f8  esp: 0xbfffe6dc
   ss: 0x00000023  efl: 0x00200206  eip: 0x90bc4a6a   cs: 0x0000000b
   ds: 0x00000023   es: 0x00000023   fs: 0x00000000   gs: 0x0000000f
  cr2: 0x1a3a00d8
Logical CPU: 0



              
Operating System: Mac OS X
Comment 1 Julien Nabet 2012-12-13 22:15:55 UTC
Marcus: what's the Duden version you use?
Comment 2 Marcus Hudritsch 2012-12-14 06:50:11 UTC
Hi Julien,
in my opinion the latest: 9.0.0.2
I reported the bug also to Duden.
Marcus

Von:  <bugzilla-daemon@freedesktop.org>
Datum:  Donnerstag, 13. Dezember 2012 23:15
An:  Marcus Hudritsch <m.hudritsch@vtxmail.ch>
Betreff:  [Bug 58177] EDITING: Complete crash due to Duden plugin

    
 Julien Nabet <mailto:serval2412@yahoo.fr>  changed bug 58177
<https://bugs.freedesktop.org/show_bug.cgi?id=58177>
  
 What Removed Added
 CC     bugs@eikota.de, serval2412@yahoo.fr

 

 Comment # 1 <https://bugs.freedesktop.org/show_bug.cgi?id=58177#c1>  on bug
58177 <https://bugs.freedesktop.org/show_bug.cgi?id=58177>  from  Julien
Nabet <mailto:serval2412@yahoo.fr>
Marcus: what's the Duden version you use?
 
 

 

 You are receiving this mail because:
* You reported the bug.
Comment 3 Roman Eisele 2012-12-14 07:22:20 UTC
Well, according to the stack backtrace this is exactly the same bug as bug 56430 - “EDITING: Reproducable total crash on a right mouse click on a image due to the Duden extension (v9.0.0.2)”, also reported by Marcus Hudritsch.

But bug 56430 is marked as a duplicate of bug 47250 - “Writer crashes when control-clicking/right-clicking on table cells, if DudenKorrektor extension is installed”. And, of course, the stack trace looks the same to me (but I am just a simple-minded bug wranger).

So, does this mean that bug 47250, or some way to trigger bug 47250, is not really fixed in LibreOffice 3.6.4?!?


@ Caolán:
Hi Caolán, you have fixed bug 47250, but this one looks like a Wiedergänger(*)
of bug 47250; or it is yet another way to trigger the same crash which appeared in bug 47250 ...
Can you please take a look at this issue and decide how this issue should be handled?

Thank you very much!


(*) http://en.wikipedia.org/wiki/Wiederg%C3%A4nger
Comment 4 Caolán McNamara 2012-12-14 16:38:02 UTC
crap, there is no work around after all on our side, it's got to be fixed on the Duden side. :-(

Either by... 

a) ensuring that the exception thrown from Duden::ContextMenuInterceptor::notifyContextMenuExecute conforms to 
the exception signature of...

notifyContextMenuExecute( const css::ui::ContextMenuExecuteEvent& aEvent ) throw (::com::sun::star::uno::RuntimeException) = 0;

i.e. they can only throw ::com::sun::star::uno::RuntimeException from their implementation of notifyContextMenuExecute

or... 

b) (if they are using true gcc and not clang) then with an additional -fno-enforce-eh-specs option to gcc
Comment 5 Caolán McNamara 2012-12-14 16:38:17 UTC
*** Bug 56430 has been marked as a duplicate of this bug. ***
Comment 6 Caolán McNamara 2012-12-14 16:38:39 UTC
*** Bug 47250 has been marked as a duplicate of this bug. ***
Comment 7 Michael Stahl 2012-12-14 16:50:00 UTC
there are actually several possibilities:

1) Duden code throws the exception and it is not allowed to pass though
Duden::ContextMenuInterceptor::notifyContextMenuExecute(com::sun::star::ui::ContextMenuExecuteEvent const&)

2) the implementation of this method has a wrong exception specification:
Duden::ContextMenuInterceptor::notifyContextMenuExecute(com::sun::star::ui::ContextMenuExecuteEvent const&)

3) the Duden code calls some LibreOffice API, which throws an exception that it is allowed to throw

4) the Duden code calls some LibreOffice API, which throws an exception that it is not allowed to throw (i.e. that is not listed in the exception specification of the API)

1) 2) 3) would be bugs in the Duden code, while 4) would be a bug in LibreOffice code

in case of 4) it would still crash in this way because LibreOffice is compiled with -fno-enforce-eh-specs.

somebody with a Mac should do an --enable-dbgutil build (which does not use -fno-enforce-eh-specs) and then try to reproduce the problem; if you get the same stack then one of 1) 2) 3) is happening, while if you get terminate directly in LO code then it is 4)

also, sberg is of the opinion that option b) in comment #4 is not a solution but only a workaround
Comment 8 Roman Eisele 2012-12-15 10:04:10 UTC
(In reply to comment #7)
> somebody with a Mac should do an --enable-dbgutil build (which does not use
> -fno-enforce-eh-specs) and then try to reproduce the problem; if you get the
> same stack then one of 1) 2) 3) is happening, while if you get terminate
> directly in LO code then it is 4)

But who can do this? I can’t, sorry ;-( So CCing some people who can (IIRC) build LibO with --enable-dbgutil on Mac OS X ...


@ Tor Lillqvist,
@ Alex Thurgood,
@ Norbert Thiebaud,
@ all:
Can anyone of you build LibO on Mac OS X with --enable-dbgutil enabled,
and do the check proposed by Michael Stahl?

Seems that we can not get any progress here without such a test,
so any help would be very much appreciated ...
and this issue is important, of course (the Duden plugin is one of the most important commercial extensions for LibreOffice/OOo).

Thank you very much!
Comment 9 Don't use this account, use tml@iki.fi 2012-12-16 11:43:32 UTC
Would it then be too much to expect those who get commercial benefit from said extension to take part in helping making it work?
Comment 10 Roman Eisele 2012-12-24 10:22:22 UTC
(In reply to comment #9)
> Would it then be too much to expect those who get commercial benefit from
> said extension to take part in helping making it work?

Hi Tor --

no, it would not be too much to expect this ;-) I completely agree that the Duden people should take care of this issue ... I did not want to offend you!

The reason why I asked you and Norbert to help here was just Michael Stahl’s comment #7, which mentions the possibility (no. 4 in his list) that this bug, despite how it looks, was actually a bug in LibreOffice itself (not in the Duden extension), and that only somebody who can do an --enable-dbgutil build on Mac OS X could clarify the situation. Therefore I asked the people which AFAIK can do such a debug build (you and Norbert) if they could help here ...

But we can also go the other way around: if somebody (who?) is in contact with the Duden people, they should try to fix this issue, and only if they don’t succeed, we need to look deeper into this issue. Then, of course, your help might be necessary ;-)

*

So the question is: has somebody contacted the Duden people about this bug? Or who could/should do so? It would be helpful if somebody with some authoritative appearance, e.g. somebody from TDF, could do that ... Many Germans are authority-dependent, and will not listen to a simple bug wrangler like me („Wer sind Sie überhaupt? Da kann ja jeder kommen!“).
Comment 11 Stephan Bergmann 2013-01-07 10:11:59 UTC
(In reply to comment #10)
> So the question is: has somebody contacted the Duden people about this bug?
> Or who could/should do so? It would be helpful if somebody with some
> authoritative appearance, e.g. somebody from TDF, could do that ... Many
> Germans are authority-dependent, and will not listen to a simple bug
> wrangler like me („Wer sind Sie überhaupt? Da kann ja jeder kommen!“).

My understanding is that Thorsten Behrens (now on cc) has contacts to the developers of that extension.
Comment 12 Roman Eisele 2013-01-08 12:51:35 UTC
(In reply to comment #11)
> My understanding is that Thorsten Behrens (now on cc) has contacts to the
> developers of that extension.

OK, that’s wonderful! So I suppose the Duden guys are already informed about this bug, and there is nothing left to do on our side (developers and QA people) except waiting for their results?! Nice!

Only a little aks/suggestion: if a developer is already in contact with the people responsible for handling some bug, it would be very nice if he/she could leave a short notice in the bug report about this. Such a short notice would prevent us bug wranglers from annoying innocent developers about the bug in question; I would have never written comment #8 and #10, and Tor and Stephan would not had to write comments #9 and #11, if I had known that somebody is already in contact with the Duden people ... Thank you very much!
Comment 13 Thorsten Behrens (CIB) 2013-01-08 13:25:59 UTC
(In reply to comment #12)
> Such a short notice would prevent us bug wranglers from annoying innocent 
> developers about the bug in question ...
>
Nah, please still raise those things - I was only aware of the problem as of yesterday. No time wasted / hacker annoyed FWICT. ;)
Comment 14 retired 2013-06-02 11:53:04 UTC
From what I read this is RESOLVED NOTOURBUG. It is an external plugin users pay for. The issue is on their side. So totally out of our hands and notourbug.
Comment 15 Don't use this account, use tml@iki.fi 2013-06-03 05:01:44 UTC
James, *if* LibreOffice's ABI has (intentionally) changed in such a way that binary extension no longer work, then LO prevent an attempt to use incompatible plugins. If LO still attempts to use a now incompatible extensions, that is a bug. And if the ABI has changed by mistake, that is also a bug. Based on the (little) information here it is too early to simply shrug this bug off as "NOTOURBUG". James, are you interested in investigating what is going on?

James, is it the fact that Duden is proprietary that irks you? Please note that the very idea of LO (and OOo) extensions has always been to enable even proprietary extensions from a licensing point of view. So you shouldn't interpret my comment #9 as meaning it is OK to just close this bug. (On the other hand, I still do think it would be "fair" if the Duden dudes did some investigation, and reported what they find out here.)
Comment 16 Don't use this account, use tml@iki.fi 2013-06-03 05:02:25 UTC
(And please note that even if I re-opened the bug, that doesn't mean that I would promise to start working on it.)
Comment 17 Marcus Hudritsch 2013-06-03 06:24:36 UTC
No, this bug is not at all fixed:

Process:         soffice [11722]
Path:            /Applications/LibreOffice.app/Contents/MacOS/soffice
Identifier:      org.libreoffice.script
Version:         4.0.3.3 (???)
Code Type:       X86 (Native)
Parent Process:  launchd [221]
User ID:         501

Date/Time:       2013-06-03 08:21:16.969 +0200
OS Version:      Mac OS X 10.8.3 (12D78)
Report Version:  10
Sleep/Wake UUID: DC300A70-B93E-49DD-B920-A891F238C0C6

Interval Since Last Report:          3141041 sec
Crashes Since Last Report:           159
Per-App Crashes Since Last Report:   6
Anonymous UUID:                      663C3B41-0758-9A3A-1E72-454CDF99CF07

Crashed Thread:  0  Dispatch queue: com.apple.main-thread

Exception Type:  EXC_CRASH (SIGABRT)
Exception Codes: 0x0000000000000000, 0x0000000000000000

Application Specific Information:
abort() called
terminate called throwing an exception

Thread 0 Crashed:: Dispatch queue: com.apple.main-thread
0   libsystem_kernel.dylib        	0x94e29a6a __pthread_kill + 10
1   libsystem_c.dylib             	0x98661b2f pthread_kill + 101
2   libsystem_c.dylib             	0x986984ec abort + 168
3   libc++abi.dylib               	0x9a72d7e0 abort_message + 151
4   libc++abi.dylib               	0x9a72b249 default_terminate() + 34
5   libc++abi.dylib               	0x9a72b289 safe_handler_caller(void (*)()) + 13
6   libc++abi.dylib               	0x9a72b26e unexpected_defaults_to_terminate() + 23
7   libc++abi.dylib               	0x9a72b2cf __cxxabiv1::__unexpected(void (*)()) + 14
8   libc++abi.dylib               	0x9a72c1ad __cxa_call_unexpected + 58
9   dudenkorrektor.uno.dylib      	0x0e444a96 Duden::ContextMenuInterceptor::notifyContextMenuExecute(com::sun::star::ui::ContextMenuExecuteEvent const&) + 2922
10  libsfxlo.dylib                	0x00815478 SfxViewShell::TryContextMenuInterception(Menu&, rtl::OUString const&, Menu*&, com::sun::star::ui::ContextMenuExecuteEvent) + 376
11  libsfxlo.dylib                	0x007a755d SfxPopupMenuManager::ExecutePopup(ResId const&, SfxViewFrame*, Point const&, Window*) + 397
12  libsfxlo.dylib                	0x008171d2 SfxDispatcher::ExecutePopup(unsigned short, Window*, Point const*) + 242
13  libswlo.dylib                 	0x2685eb38 SwEditWin::Command(CommandEvent const&) + 5672
14  libvcllo.dylib                	0x01b1c475 ImplCallCommand(Window*, unsigned short, void*, unsigned char, Point*) + 245
15  libvcllo.dylib                	0x01b1eb1c ImplHandleMouseEvent(Window*, unsigned short, unsigned char, long, long, unsigned long, unsigned short, unsigned short) + 5692
16  libvcllo.dylib                	0x01b1eef2 ImplWindowFrameProc(Window*, SalFrame*, unsigned short, void const*) + 850
17  libvcllo.dylib                	0x01b7c5a8 -[SalFrameView sendMouseEventToFrame:button:eventtype:] + 520
18  libvcllo.dylib                	0x01b78a12 -[SalFrameView rightMouseDown:] + 66
19  com.apple.AppKit              	0x927fab61 -[NSWindow sendEvent:] + 7432
20  com.apple.AppKit              	0x927f597f -[NSApplication sendEvent:] + 4278
21  libvcllo.dylib                	0x01b6e47c -[VCL_NSApplication sendEvent:] + 108
22  libvcllo.dylib                	0x01b309f4 AquaSalInstance::Yield(bool, bool) + 516
23  libvcllo.dylib                	0x017cea40 Application::Yield(bool) + 96
24  libvcllo.dylib                	0x017ceb2c Application::Execute() + 76
25  libsofficeapp.dylib           	0x00077cfd desktop::Desktop::Main() + 5085
26  libvcllo.dylib                	0x017d7308 ImplSVMain() + 344
27  libvcllo.dylib                	0x01b2ff5b AquaSalInstance::handleAppDefinedEvent(NSEvent*) + 75
28  libvcllo.dylib                	0x01b6e54b -[VCL_NSApplication sendEvent:] + 315
29  com.apple.AppKit              	0x9270f69c -[NSApplication run] + 951
30  com.apple.AppKit              	0x926b2666 NSApplicationMain + 1053
31  libvcllo.dylib                	0x01b314f7 ImplSVMainHook(int*) + 343
32  libvcllo.dylib                	0x017d7371 SVMain() + 17
33  libsofficeapp.dylib           	0x000a8bd5 soffice_main + 437
34  org.libreoffice.script        	0x00001f0e main + 30
35  org.libreoffice.script        	0x00001872 _start + 216
36  org.libreoffice.script        	0x00001799 start + 41
Comment 18 retired 2013-06-03 07:18:06 UTC
Tor, thanks for re-opening and sorry for the noise. I'm still rather confused what to make of this bug.

Comment 10 suggests to wait for the Duden folks to fix this. They have neither showed up here nor updated the extension in such a manner that it works.

Comment 15 now says that part of this might be a LO bug in a manner so that broken extensions should not be loaded at all. I agree but don't have the technical expertise to investigate. Yet, if that's the case, maybe we should adjust the title, which should then say "Prevent LO from loading broken extensions".

Marcus: no one said the bug was fixed.

So whatever the case, from what I read, action on the LO side is still necessary.
Comment 19 Marcus Hudritsch 2013-06-03 07:34:42 UTC
Please, do not deactivate this plugin. The plugin works fine and does a very good job in correcting my german grammatical insufficiencies. The context menu also works fine on the text. It just crashes on images an OLE's.
Regards
Marcus
Comment 20 Stephan Bergmann 2013-06-03 07:56:31 UTC
(In reply to comment #18)
> Comment 15 now says that part of this might be a LO bug in a manner so that
> broken extensions should not be loaded at all. I agree but don't have the
> technical expertise to investigate. Yet, if that's the case, maybe we should
> adjust the title, which should then say "Prevent LO from loading broken
> extensions".

No, do not change the title.  This bug is about a specific problem for which the reason is not yet clear.

(There is a general problem that extensions can stop working correctly due to incompatibilities in LO, and it is a well-known shortcoming of LO that it does not detect such cases.  This issue might or might not be a duplicate of that well-known shortcoming; we cannot tell without further data, providing which requires access to the Duden extension.)
Comment 21 Julien Nabet 2013-06-04 17:25:54 UTC
*** Bug 59130 has been marked as a duplicate of this bug. ***
Comment 22 Julien Nabet 2013-06-14 19:47:30 UTC
*** Bug 65732 has been marked as a duplicate of this bug. ***
Comment 23 Gerri 2013-06-22 21:08:23 UTC
Salut Julien,

sorry for the delay in getting back to you. I've attached the answer from Duden-Support. In short: Duden-Korrektor is not officially built for LO 4. It will only work with limitations. 
They know about the bug and refuse to work on it, because it's a slow-selling piece of software. Version 9 will be the last build for LO. Avoid right-clicks and use the buttons "Format", "Edit" or "Insert" when working on graphics.

What a pity.

All the best from Germany

Gerri
--------------------------------------------------------------------------------------------------------------------------------------------------------------------
Sehr geehrter Herr ,

vielen Dank für Ihre Anfrage und Ihr Interesse an unserer Software.

https://bugs.freedesktop.org/show_bug.cgi?id=65732
Die Duden-Rechtschreibprüfung 9.0 ist offiziell nicht für LibreOffice 4 freigegeben und kann somit nur mit Einschränkungen verwendet werden.

https://bugs.freedesktop.org/show_bug.cgi?id=58177
Der Fehler ist uns bekannt und wird leider auch nicht mehr behoben, da die Duden Rechtschreibprüfung 9.0, Aufgrund der geringen Nachfrage, vorerst die letzte Version für OpenOffice / LibreOffice sein wird.

Wir können Ihnen derzeit nur raten, die Funktionen, welche sie per Rechtsklick nutzen wollen, über die oberen Menü-Schaltflächen "Format", "Bearbeiten" bzw. "Einfügen" zu nutzen.
Auf diesem Wege können Sie die gleichen Aktion durchführen, wie auch zuvor über den Rechtsklick.

Mit freundlichen Grüßen
Ihr Team der Duden-Hotline für den Privatkundenbereich

Bei Rückfragen zu diesem Sachverhalt halten Sie bitte die Bearbeitungsnummer bereit um eine schnelle Zuordnung zu erleichtern, oder antworten Sie per Rückantwort direkt auf diese Mail.

http://www.duden.de

Bibliographisches Institut GmbH
Dudenstraße 46, 68167 Mannheim
Sitz der Gesellschaft: Mannheim; Registergericht: Amtsgericht Mannheim, HRB 709363
Geschäftsführer: Timo Blümer, Marion Winkenbach (Sprecherin)
Service-Hotline
Deutschland Tel: 01805/124578*
Schweiz Tel: 041/7108379 (Festnetztarif)
- Service Zeiten Mo-Fr 10:00-16:00 Uhr
(* 0,14 €/Min. für Anrufe aus dem deutschen Festnetz,
max. 0,42€/Min. für Anrufe aus Mobilfunknetzen)
Comment 24 retired 2013-06-23 15:09:11 UTC
With this latest info from comment 23

setting this to NOTOURBUG.

Duden is aware and also saying they won't fix this since Duden plugin won't be under development any longer.