Bug 59323 - Impress conversion to PPTX doesn't save (header and footer) fields - with sample or steps in Comment 7
Summary: Impress conversion to PPTX doesn't save (header and footer) fields - with sam...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: filters and storage (show other bugs)
Version:
(earliest affected)
3.3.0 release
Hardware: All All
: high major
Assignee: Sarper Akdemir
URL:
Whiteboard: interoperability target:7.3.0
Keywords: filter:pptx, implementationError
: 111860 117339 125072 142228 (view as bug list)
Depends on:
Blocks: PPTX-Corrupted PPTX-MasterSlide
  Show dependency treegraph
 
Reported: 2013-01-13 16:51 UTC by jcs.LibreOffice
Modified: 2021-07-21 08:11 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
ZIP file containing odp file and converted ppt and pptx files (256.86 KB, application/x-zip)
2013-01-13 16:51 UTC, jcs.LibreOffice
Details
PPTX saved with LO 4.4 then repaired with MSO 2013.pdf (156.16 KB, application/x-force-download)
2017-05-03 11:18 UTC, Timur
Details
PPTX saved with LO 5.4+ then repaired with MSO 2013.pdf (227.19 KB, application/x-force-download)
2017-05-03 11:34 UTC, Timur
Details
Screenshot of the original document and its PPTX version in Impress (152.25 KB, image/png)
2021-01-29 08:11 UTC, NISZ LibreOffice Team
Details
How it looks in 7.2 immediatelly after import (196.10 KB, image/jpeg)
2021-03-25 08:22 UTC, Attila Bakos (NISZ)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description jcs.LibreOffice 2013-01-13 16:51:13 UTC
Created attachment 72961 [details]
ZIP file containing odp file and converted ppt and pptx files

An Impress presentation saved as PPTX format fails to open when using Office 2010.
 
Message says

"PowerPoint has found a problem with current <filename>. Powerpoint can attempt to repair the presentation"

The repair fails.

Saving as PPT format everything works correctly and the PowerPoint presentation runs in Office 2010 PowerPoint.

The presentation within the attached ZIP file contains a subset consisting of two slides from the presentation as PPTX bug.odp and two files generated by Impress, PPTX bug.ppt which is OK and PPTX bug.pptx which fails to open in Office 2010.

the first slide contains Tables
the second slide contains an animation

Environment:
ODP file created on a Vista Home edition 32 bit machine with LO 3.6.2.2 release

The PowerPoint 2010 attempting to open PPT and PPTX files is running on W7 enterprise 64 bit.
Comment 1 Gergely Rácz 2014-03-17 11:20:26 UTC
I have reproduced the same issue with Office 2013 and LibO Calc 4.2.2.1 (Win 7 x64).
Comment 2 Joel Madero 2015-05-02 15:43:45 UTC Comment hidden (obsolete)
Comment 3 jcs.LibreOffice 2015-05-02 17:34:13 UTC
Following a request to check the status of this bug I have updated Libre Office to the latest version 4.4.2.2. I also have the latest Microsoft Office available.

I have tested the odp, ppt and pptx files included in the bug report.

The odt and ppt files open correctly in both LO and Powerpoint and the animation on the second slide work

The pptx file does not open in either Libre Office or Power Point. The second slide does not have any animation. Powerpoint reports errors on opening and that some content has been removed.

In short  there is no change - the bug is still present.
Comment 4 QA Administrators 2016-09-20 09:37:31 UTC Comment hidden (obsolete)
Comment 5 Timur 2017-05-03 11:18:13 UTC
Created attachment 133024 [details]
PPTX saved with LO 4.4 then repaired with MSO 2013.pdf

With PPTX saved in LO 4.4 there was Repair in MSO 2013 that yielded document as attached, with data loss.
Comment 6 Timur 2017-05-03 11:34:18 UTC
Created attachment 133025 [details]
PPTX saved with LO 5.4+ then repaired with MSO 2013.pdf

With PPTX saved in current LO 5.3 or 5.4+ there is no footer data. 
There's still Repair in MSO 2013 that gives better document as attached, with smaller data loss, just footer.
So I'll rename this bug. 
I'm not sure if this is now a duplicate of Bug 97083.
Comment 7 Timur 2017-05-03 11:40:47 UTC
To reproduce: 
1. Open blank presentation in Impress
2. Insert - Header and Footer... fields (which are on Master slide). 
3. Save as PPTX and close. 
4. On PPTX reopen, there are no fields.
5. (optionally) open PPTX in MSO, there's Repair and also no fields.
Comment 8 QA Administrators 2018-05-04 02:40:19 UTC Comment hidden (obsolete)
Comment 9 Aron Budea 2018-07-19 04:10:50 UTC
Header/footer fields still don't get saved in LO 6.1.0.1, either.
I couldn't reproduce the corruption part, though, neither with 6.1.0.1, nor with 5.3.0.3. I used steps in comment 7.
Comment 10 Timur 2019-05-09 09:48:21 UTC
Repro 6.3+ with sample from attachment 72961 [details] or from scratch per comment 7. 
No repair in MSO 2016.
Comment 11 Timur 2019-05-09 09:50:13 UTC
*** Bug 125072 has been marked as a duplicate of this bug. ***
Comment 12 Timur 2019-05-09 09:59:03 UTC
*** Bug 111860 has been marked as a duplicate of this bug. ***
Comment 13 Timur 2019-05-09 09:59:39 UTC
*** Bug 117339 has been marked as a duplicate of this bug. ***
Comment 14 NISZ LibreOffice Team 2021-01-29 08:11:37 UTC
Created attachment 169257 [details]
Screenshot of the original document and its PPTX version in Impress

Still a problem in:

Version: 7.2.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 7eb289c49cc7245ef3001a39be0c15d06bbe875b
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: en-US (hu_HU); UI: en-US
Calc: CL

However the PPTX version is opened without invalid contents warning in my PP 2013.
Comment 15 Attila Bakos (NISZ) 2021-03-25 08:22:01 UTC Comment hidden (obsolete)
Comment 16 Attila Bakos (NISZ) 2021-03-25 08:24:00 UTC
(In reply to Attila Bakos (NISZ) from comment #15)
> Created attachment 170730 [details]
> How it looks in 7.2 immediatelly after import
> 
> I do not think this is an export only problem, see my attachment.
> Impress does not imports correctly that fields, they are only textboxes, and
> the options is disabled, so when export comes according to the options it
> does not export the content. However the steps in comment 7 shows that there
> is an export problem too. In my opinion this should be separated to two
> different problems, and firstly i try to solve the import and if i works
> fine then the export one.

Oh sorry i forgot to write the import file comes from MSO.
Comment 17 NISZ LibreOffice Team 2021-06-10 07:34:30 UTC
(In reply to Attila Bakos (NISZ) from comment #15)
> In my opinion this should be separated to two
> different problems, and firstly i try to solve the import and if i works
> fine then the export one.

Right, I filed some new bugs about these:
- bug 142221 is header-footer settings import
- bug 142218 is header-footer settings import for handouts/notes
- bug 142228 is header-footer settings export (technically a duplicate of this one)
- bug 142220 is header-footer settings export for handouts/notes
Comment 18 Commit Notification 2021-06-14 10:06:54 UTC
Sarper Akdemir committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/b2869ca51c2e30128456cbdee7e526bacd9cc905

tdf#59323: ooxml import: add OOXML to LO datetime helper

It will be available in 7.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 19 Commit Notification 2021-06-14 10:29:12 UTC
Sarper Akdemir committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/c5676a08eb57d30c11bd201f8d2c328165c8143f

tdf#59323: ooxml import: hasShapeStyleRefs

It will be available in 7.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 20 Commit Notification 2021-06-14 12:43:37 UTC
Sarper Akdemir committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/cc7c0387506b546333d5951af98dcfb0fbf75c55

tdf#59323: ooxml import: hasNonInheritedShapeProperties

It will be available in 7.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 21 Commit Notification 2021-06-15 07:30:11 UTC
Sarper Akdemir committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/4a3b9d2092ff5ce8336cc87cacbdc421f3d26ea7

tdf#59323: ooxml import: hasVisualRunProperties

It will be available in 7.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 22 Commit Notification 2021-06-15 07:31:25 UTC
Sarper Akdemir committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/b187c36e019f773a71687c819c3cf6a2c3fd2b89

tdf#59323: ooxml import: hasParagraphProperties

It will be available in 7.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 23 Commit Notification 2021-06-15 07:54:33 UTC
Sarper Akdemir committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/7882f2425499e6d12894a74696f30b718468c4a4

tdf#59323: ooxml import: hasNoninheritedBodyProperties

It will be available in 7.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 24 Commit Notification 2021-06-15 07:55:45 UTC
Sarper Akdemir committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/2cfccfba09faa5c3bb973136ffe99d534d09c881

tdf#59323: ooxml import: hasListStyleOnImport

It will be available in 7.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 25 Timur 2021-06-15 08:24:51 UTC
Hi Sarper. Congrats for you being one of the first to add in 7.3. 
Please explain what you do here, is it header-footer import and export to PPTX, as listed in Comment 17 as bug 142221 and bug 142228.
IIUC, other listed bug 142218 and bug 142220 should depend on See Also LO bug 37011.
Comment 26 Sarper Akdemir 2021-06-15 11:44:10 UTC
Hey Timur, not all of the implementation is merged yet and still up for review at gerrit, but yes what I do here is bug 142221 and bug 142228.
When https://gerrit.libreoffice.org/c/core/+/117008 is merged that should fix bug 142221.
And when https://gerrit.libreoffice.org/c/core/+/117012 is merged  that should fix bug 142228.

Current range of patches on gerrit do not include a fix for bug 142218 or bug 142220.
Comment 27 Commit Notification 2021-06-16 12:33:33 UTC
Sarper Akdemir committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/166671f4aa19deec47c10a220ae1d29fa57faa93

tdf#59323: pptx import: import footer fields as properties

It will be available in 7.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 28 Commit Notification 2021-06-16 12:34:45 UTC
Sarper Akdemir committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/ba66d49db89678628975b29612c0caab49457adf

tdf#59323: pptx export: add datetime field type helpers

It will be available in 7.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 29 Commit Notification 2021-06-16 12:57:25 UTC
Sarper Akdemir committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/1178d2978d3328de0bf0bccb9920fbc8b9a3a414

tdf#59323: pptx export: add placeholder index to master footer placeholders

It will be available in 7.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 30 Commit Notification 2021-06-16 13:02:43 UTC
Sarper Akdemir committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/0f9dc676eefce79ea63218edd910af486a09a52b

tdf#59323: pptx export: add initial support for lstStyles in textboxes

It will be available in 7.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 31 Commit Notification 2021-06-16 13:05:58 UTC
Sarper Akdemir committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/25ae0de974befb9c279936046056a850d77e0dca

tdf#59323: pptx export: add support for slide footers

It will be available in 7.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 32 Commit Notification 2021-06-16 13:07:08 UTC
Sarper Akdemir committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/f283ec0bf68734558e903339f2f0d86633cc9a62

tdf#59323: pptx export: slide footers roundtrip unit test

It will be available in 7.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 33 NISZ LibreOffice Team 2021-06-22 07:09:27 UTC
*** Bug 142228 has been marked as a duplicate of this bug. ***
Comment 34 Commit Notification 2021-07-19 14:48:23 UTC
Sarper Akdemir committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/7ec4a0872d16eb20d790eb8079ba538898fd2ff6

tdf#59323 tdf#142221: fix pptx datetime import export format

It will be available in 7.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 35 Commit Notification 2021-07-19 14:49:43 UTC
Sarper Akdemir committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/888a71bc9253bd309d78b3affbed6fdd5ecd7bd8

tdf#59323 tdf#142228 pptx export: fix datetime footers backwards compatibility

It will be available in 7.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 36 Commit Notification 2021-07-19 14:50:02 UTC
Sarper Akdemir committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/ee922e67097c094293f6012e8cf35acce8317ebf

tdf#59323 pptx export: test for datetime footer backwards compatibility

It will be available in 7.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 37 Sarper Akdemir 2021-07-21 08:11:06 UTC
The remaining part of this bug is filed at bug 142220. I think it makes sense to close this one.