Bug 62074 - FILEOPEN: LibreOffice calc does not freeze window in all tables
Summary: FILEOPEN: LibreOffice calc does not freeze window in all tables
Status: RESOLVED DUPLICATE of bug 49742
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.6.0.0.alpha1
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-03-09 19:41 UTC by wfheua
Modified: 2013-06-05 15:23 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
ODS Spreadsheet containing 7 empty tables with first row frozen. Step 1 to 3 - saved as .ODS (7.48 KB, application/vnd.oasis.opendocument.spreadsheet)
2013-03-09 19:41 UTC, wfheua
Details

Note You need to log in before you can comment on or make changes to this bug.
Description wfheua 2013-03-09 19:41:08 UTC
Created attachment 76240 [details]
ODS Spreadsheet containing 7 empty tables with first row frozen. Step 1 to 3 - saved as .ODS

Problem description: 
When opening an xls spreadsheet containing multiple tables, freeze window is not applied to all tables

Steps to reproduce:
1. Create a new spreadsheet
2. Add 6 new tables (7 tables in total)
3. For all 7 tables select column A2 and use Window->Freeze
4. Save file as "Microsoft Excel 97/2000/XP/2003 (.xls) (*.xls)"
5. Close file or application
6. Re-Open file

Current behavior:
Only first two tables have the first row frozen.

Expected behavior:
First row should be frozen on all tables

You can reproduce the issue, opening the attached file and continuing with step 4 (save as .xls, close file, re-open)
Operating System: Windows 7
Version: 4.0.1.2 release
Comment 1 A (Andy) 2013-04-13 21:43:31 UTC
not reproducible with LO 4.0.2.2 (Win7 Home, 64bit)
Does this issue still persist for you with the latest release of LO?

Only for clarification: 
Note to step 3: there is a typing error; it should mean "cell" instead of "column"
Comment 2 Joel Madero 2013-04-15 02:41:34 UTC
Thank you for reporting this issue! I have been able to confirm the issue on:
Version: 4.1.0.0.alpha0+Build ID: 6e3e6ef7257e93743a72719581ef6fe0016e58e
Date:   Thu Apr 11 15:24:38 2013 +0200 
Platform: Bodhi Linux 2.2 x64

+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + +
As I've been able to confirm this problem I am marking as:

New (confirmed)
Minor - doesn't prevent high quality work
Medium - regression (works fine in 3.6.5.2)

Keywords - regression

Whiteboard Status - bibisectrequest

+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + +
LibreOffice is powered by a team of volunteers, every bug is confirmed (triaged) by human beings who mostly give their time for free. We invite you to join our triaging by checking out this link:
https://wiki.documentfoundation.org/QA/BugTriage and join us on freenode at #libreoffice-qa

There are also other ways to get involved including with marketing, UX, documentation, and of course developing -  http://www.libreoffice.org/get-help/mailing-lists/. 

Lastly, good bug reports help tremendously in making the process go smoother, please always provide reproducible steps (even if it seems easy) and attach any and all relevant material

Master 4.1 – Confirmed Enhancement Request
Thank you for reporting this enhancement request! I can confirm that this is a valid enhancement request on:
Version: 4.1.0.0.alpha0+Build ID: 6e3e6ef7257e93743a72719581ef6fe0016e58e
Date:   Thu Apr 11 15:24:38 2013 +0200 
Platform: Bodhi Linux 2.2 x64
+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + 
As I've been able to confirm the enhancement request I am marking as:

New (confirmed)
Enhancement
IMPORTANCE

Keywords - 

Whiteboard Status -

+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + 
LibreOffice is powered by a team of volunteers, every bug is confirmed (triaged) by human beings who mostly give their time for free. We invite you to join our triaging by checking out this link:
https://wiki.documentfoundation.org/QA/BugTriage

There are also other ways to get involved including with marketing, UX, documentation, and of course developing -  http://www.libreoffice.org/get-help/mailing-lists/. 

Lastly, good bug reports help tremendously in making the process go smoother, please always provide reproducible steps (even if it seems easy) and attach any and all relevant material
Comment 3 bug51066.10.pr0rsus 2013-04-26 02:12:46 UTC
This seems identical to bug 51066, see comment 10:
https://bugs.freedesktop.org/show_bug.cgi?id=51066
Comment 4 Joel Madero 2013-05-02 19:53:26 UTC
ah, I've done more work with this one and it is NOT a regression but an even stranger behavior.

It seems like freeze panes are only stored for the worksheet you are currently on and worksheets PRIOR TO this one (to the left visually).

To confirm this:

Open file attached
Click on 5th worksheet
Save as -> xls
Close
Open new file

See that worksheet freeze pain is good from 1-5, on 6th & 7th sheet are not saved. This is consistent as far back as 3.6.0.0.alpha (updating version).

Removing regression and bibisectrequest
Comment 5 wfheua 2013-05-03 18:18:53 UTC
Opening a file with Microsoft Office shows that freeze panes are stored for all worksheets, however when opening a file with LibreOffice we get the already described behaviour.
Comment 6 ign_christian 2013-05-07 13:42:04 UTC
Same as:
Bug 51066
Bug 63224
Bug 63103
Bug 62045
Comment 7 ign_christian 2013-05-09 09:47:56 UTC

*** This bug has been marked as a duplicate of bug 61060 ***
Comment 8 ign_christian 2013-06-05 15:23:50 UTC

*** This bug has been marked as a duplicate of bug 49742 ***