Download it now!
Bug 64276 - SVG: Problem with some svg file.
Summary: SVG: Problem with some svg file.
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: All All
: medium major
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: notBibisectable, regression
: 79854 (view as bug list)
Depends on:
Blocks: Draw-Images 64549 SVG-Open
  Show dependency treegraph
 
Reported: 2013-05-06 13:33 UTC by qfeng.chen
Modified: 2018-06-20 17:03 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
drawing can not render this file correctly (635.35 KB, image/svg+xml)
2013-05-06 13:33 UTC, qfeng.chen
Details
Screenshot for the svg in the first attachment. (147.47 KB, image/png)
2013-08-28 19:03 UTC, Christina Rossmanith
Details
SVG-very-wrong-when-imported-in-Draw.png (98.14 KB, image/png)
2013-11-28 14:06 UTC, Gerry
Details
ungrouped SVG elements out of image bounds (149.18 KB, image/png)
2014-12-12 01:32 UTC, V Stuart Foote
Details
original SVG ungrouped and out of bounds elements clipped (550.38 KB, image/svg+xml)
2014-12-12 01:33 UTC, V Stuart Foote
Details
original SVG ungrouped and out of bounds elements clipped, "plain" SVG (538.40 KB, image/svg+xml)
2014-12-12 01:42 UTC, V Stuart Foote
Details

Note You need to log in before you can comment on or make changes to this bug.
Description qfeng.chen 2013-05-06 13:33:52 UTC
Created attachment 78926 [details]
drawing can not render this file correctly

Problem description: 

Can not render the svg file correctly.              
Operating System: Debian
Version: 4.0.2.2 release
Comment 1 Jorendc 2013-05-06 14:46:03 UTC
Thanks for reporting!

I can reproduce this behavior using Linux Mint 14 x64 with Version: 4.1.0.0.alpha0+ Build ID: c458ea6d15465d9dada06f259946f854e9e5ccf

Therefore I mark this bug as NEW.

Kind regards,
Joren
Comment 2 Gerry 2013-05-07 12:19:50 UTC
This bug is a regression: In LibreOffice 3.6.2.2 inserting (Insert->Picture) the SVG-file works excellent with perfect rendering, in LO 4.0.0.3 the inserted image is not usable. It is rendered very badly.

With regards to importing the SVG file (File->Open) both LibreOffice versions render the SVG file wrong. The imported file is not usable.

System: Ubuntu 12.10

P.S. I am a bit confused with the importance status. Joel increased a similar bug from "medium" to "high" and here we increase from "normal" to "major". Probably all the same :-)
Comment 3 Gerry 2013-05-07 12:31:44 UTC
I felt free to add the keyword "regression" since this is quite obvious the case.

I also added some urls of similar bugs to "See also" (all of them are regressions (!))
Comment 4 Christina Rossmanith 2013-08-28 19:02:18 UTC
Looks fine here (just without any animation - or is that meant with "cannot render correctly"?).

Version: 4.2.0.0.alpha0+
Build ID: d00e125cbe33da88b881d177cbc09a9045d32349
Comment 5 Christina Rossmanith 2013-08-28 19:03:49 UTC
Created attachment 84809 [details]
Screenshot for the svg in the first attachment.

svg is rendered correctly for me.
Comment 6 Christina Rossmanith 2013-08-28 19:20:59 UTC
Forgot to mention that I've used Insert->Picture from file.
Comment 7 Jorendc 2013-10-04 11:02:56 UTC
Already reproducible using Mac OSX 10.8.5 with LibreOffice Version 4.0.0.3 (Build ID: 53fd80e80f44edd735c18dbc5b6cde811e0a15c)
TinderBox: MacOSX TDF Release, Branch:libreoffice-4-0, Time: 2013-01-31_11:01:36
Both Insert > Picture > From File and File > Open result in bad behavior. (although the insertion is a bit less ugly :p)

In LibreOffice 4.1.2.3 rc Opening the svg using File > Open result in bad behavior, but inserting it is correct.

@Christina: not sure why inserting the image works, but importing it result in such bad rendering. Doesn't these both rely on the same import filter?

Kind regards,
Joren
Comment 8 Gerry 2013-11-28 14:06:57 UTC
Created attachment 89956 [details]
SVG-very-wrong-when-imported-in-Draw.png

Tested SVG with LibreOffice 4.2 Beta1:

* Inserting as image in Writer: Perfect!
* Opening in Draw: The result is unusable, totally broken. Please see attached screenshot.
Comment 9 V Stuart Foote 2014-12-12 01:32:15 UTC
Created attachment 110762 [details]
ungrouped SVG elements out of image bounds

Seems that the example SVG is corrupt.

On open in Inkscape, an ungroup reveals there is a grouped text object sitting off the art board at (-74.84, -157.82), clip attached.

When that out of bounds element is removed from the SVG, and it is saved the SVG opens without issue in Draw.

Will also attach the revised SVG if anyone want to diff them.
Comment 10 V Stuart Foote 2014-12-12 01:33:16 UTC
Created attachment 110763 [details]
original SVG ungrouped and out of bounds elements clipped
Comment 11 V Stuart Foote 2014-12-12 01:42:54 UTC
Created attachment 110764 [details]
original SVG ungrouped and out of bounds elements clipped, "plain" SVG

SVG corrected in Inkscape and saved as a "plain", rather than Inkscape extended" SVG.
Comment 12 V Stuart Foote 2014-12-16 08:21:24 UTC
*** Bug 79854 has been marked as a duplicate of this bug. ***
Comment 13 Xisco Faulí 2015-11-16 15:52:10 UTC
The problem is that SVG filter doesn't support styles defined inside <style type="text/css">.

*** This bug has been marked as a duplicate of bug 94765 ***
Comment 14 Yousuf Philips (jay) (retired) 2015-11-17 06:08:41 UTC
Bug 94765 is an svgInsert bug and this is an svgOpen bug.
Comment 15 Yousuf Philips (jay) (retired) 2015-11-17 06:09:08 UTC
*** Bug 79854 has been marked as a duplicate of this bug. ***
Comment 16 Robinson Tryon (qubit) 2015-12-10 04:33:31 UTC Comment hidden (obsolete)
Comment 17 Rostislav 'R.Yu.' Okulov 2016-10-20 19:50:22 UTC
Fine with LO 5.2.2
Comment 18 Yousuf Philips (jay) (retired) 2016-10-22 17:26:49 UTC
(In reply to Rostislav 'R.Yu.' Okulov from comment #17)
> Fine with LO 5.2.2

No it isnt fine. You have to File > Open... and then select the file so it can open in Draw, where it hasnt changed how it looks since attachment 89956 [details].
Comment 19 Joel Madero 2016-10-24 03:33:24 UTC
This bug is a bit difficult because of different comments. Just focusing on the File -> Open issue in Draw, this isn't bibisectable. There's a separate bug that causes an input/output error in 3.5 series that prevents this from being bibisected.
Comment 20 QA Administrators 2018-02-08 03:36:08 UTC Comment hidden (obsolete)
Comment 21 Gerry 2018-02-11 15:06:22 UTC
Bug still exists in LO 6.0.

FILE -> OPEN still imports the SVG very wrongly. Still like in attachment " SVG-very-wrong-when-imported-in-Draw.png"

Version: 6.0.1.1
Build ID: 1:6.0.1~rc1-0ubuntu0.16.04.1~lo1
CPU threads: 4; OS: Linux 4.4; UI render: GL; VCL: gtk2; 
Locale: de-DE (de_DE.UTF-8)
Comment 22 Roman Kuznetsov 2018-06-17 15:14:52 UTC
I used File->Open in Draw in

Version: 6.1.0.0.beta2+ (x64)
Build ID: fe1a23b5c49c94410a604c8d4a6f50f43d575403
CPU threads: 4; OS: Windows 10.0; UI render: GL; 
TinderBox: Win-x86_64@42, Branch:libreoffice-6-1, Time: 2018-06-17_06:31:41
Locale: ru-RU (ru_RU); Calc: CL

and first attached SVG opens correctly

also "original SVG ungrouped and out of bounds elements clipped, "plain" SVG" opens correctly

Status -> WFM