Download it now!
Bug 64707 - Unable to start application using desktop menu on Linux
Summary: Unable to start application using desktop menu on Linux
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.1.0.0.beta1
Hardware: Other All
: medium critical
Assignee: Not Assigned
URL:
Whiteboard: target:4.1.0 target:4.2.0
Keywords:
: 65041 65211 (view as bug list)
Depends on:
Blocks: mab4.1
  Show dependency treegraph
 
Reported: 2013-05-17 09:44 UTC by Petr Mladek
Modified: 2013-05-31 15:56 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Petr Mladek 2013-05-17 09:44:00 UTC
I get the following error when starting a fresh 4.1.0.0.alpha1+ build from the desktop menu entry on SLED11-SP3:

      "/home/pmladek/%FILE% does not exist"

I guess that it is related to the fix for the bug #64311 and the commit http://cgit.freedesktop.org/libreoffice/core/commit/?id=363b82fdb4016bc42877fea2ebde9227b27579fe. I wonder how it is supposed to work :-)
Comment 1 Petr Mladek 2013-05-17 09:45:24 UTC
Michael, do you have any idea how to make it work on older systems? Or is it broken even on recent ones?
Comment 2 Michael Meeks 2013-05-17 09:54:09 UTC
Oh - that is bad; %FILE% should be replaced by %U or %F depending on whether you have gnome-vfs enabled see:

sysui/desktop/share/brand.pl

which should do that substitution. IIRC we cherry-picked that to -4-0 as well, so we should fix that ASAP if there is an issue.

It worked for me when I tested it but ... what configure options are you using ?
Comment 3 Petr Mladek 2013-05-17 09:56:41 UTC
I used options:

   --with-distro=LibreOfficeLinux
   --with-lang=en-US cs de
   --with-package-format=rpm deb
   --without-junit
   --with-parallelism=25
   --enable-online-update
   --without-doxygen
   --enable-icecream
   --enable-release-build
Comment 4 Commit Notification 2013-05-17 16:23:27 UTC
Petr Mladek committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=8550935cb17ccc07e4928613a43d15797f4fe5de

several fixes of Linux desktop integration after gbuildisation (fdo#64707)



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 5 Petr Mladek 2013-05-17 16:33:17 UTC
The primary problem was that we put non-processed desktop files into the final package.

This and several other problems should be fixed by the above mentioned commit. I hope that I did not miss any other problem. Anyway, the desktop integration work again for me now.
Comment 6 Flavio 2013-05-27 14:53:34 UTC
desktop-integration not present
Comment 7 Petr Mladek 2013-05-28 12:51:37 UTC
I am pretty sure that it was correct after my fix :-)

Ah, I see. It has got broken by the commit http://cgit.freedesktop.org/libreoffice/core/commit/?id=514d69eff398b32639fe4d91b503740da1aac3ae. I guess that David prepared it in a branch and did a mistake when merging with my changes.

I am going to fix it.
Comment 8 Jorendc 2013-05-28 13:03:21 UTC
*** Bug 65041 has been marked as a duplicate of this bug. ***
Comment 9 Commit Notification 2013-05-29 11:52:54 UTC
Petr Mladek committed a patch related to this issue.
It has been pushed to "libreoffice-4-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=12932acd59faafa0abdffd4871977c22e8aa1ebd&h=libreoffice-4-1

fix UNIXFILENAME variable for the Linux desktop integreation (fdo#64707)


It will be available in LibreOffice 4.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 10 Petr Mladek 2013-05-29 11:56:33 UTC
It should work again in the upcoming builds. I hope that it will stay like this :-)
Comment 11 Commit Notification 2013-05-29 12:00:52 UTC
Petr Mladek committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=5281a6c101d3a2b6ee54fbba7924510325ca37a6

fix UNIXFILENAME variable for the Linux desktop integreation (fdo#64707)



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 12 Jorendc 2013-05-31 15:56:36 UTC
*** Bug 65211 has been marked as a duplicate of this bug. ***