Bug 65102 - Windows Installation desktop icon gets installed regardless to chosen option
Summary: Windows Installation desktop icon gets installed regardless to chosen option
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
4.1.0.4 release
Hardware: All Windows (All)
: medium normal
Assignee: Andras Timar
QA Contact:
URL:
Whiteboard: target:4.2.0 target:4.1.4
Keywords: regression
: 67736 69334 69898 70447 70635 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-05-28 22:30 UTC by Thomas Arnhold
Modified: 2016-07-30 19:51 UTC (History)
11 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Arnhold 2013-05-28 22:30:17 UTC
With the latest master binaries the Windows desktop icon get's installed regardless if the option "Create start link on desktop" is set or not.

I don't know when this exactly began to occur, but this is my version:
Version: 4.2.0.0.alpha0+
Build ID: 2686d737c0e2695e274da55a3f3e147a24f77e2
Comment 1 Michał Sacharewicz 2013-07-31 04:33:49 UTC
I have exactly the same problem, and confirmed it through MSI file analysis.

I have compared, using ORCA, both recent releases: a last known proper one (4.0.4.2) and an affected one (4.1.0.4).

In 4.0.4.2 release you may find a component under attribute "Component/gid_brand_file_desktophelper_txt__libreoffice4_0_program" that is dependant on condition "CREATEDESKTOPLINK=1".

In 4.1.0.4 there is neither such exact component, nor any other component dependant on "CREATEDESKTOPLINK=1" condition.

It seems that someone has restructured the feature, changing previous value of "Component_" under the attribute "Shortcut\gid_Folderitem_Soffice_Desktop" into "gid_brand_file_bin_soffice__libreoffice4_program". The "CREATEDESKTOPLINK=1" confition has been lost.
Comment 2 Michał Sacharewicz 2013-07-31 04:57:18 UTC
Temporarily added info on the bug to Deployment and Migration wikipage near CREATEDESKTOPLINK definition:

https://wiki.documentfoundation.org/Deployment_and_Migration
Comment 3 Maxim Monastirsky 2013-08-04 09:02:22 UTC
*** Bug 67736 has been marked as a duplicate of this bug. ***
Comment 4 Pedro 2013-08-23 15:48:57 UTC
Bug confirmed under Windows XP Pro x86 en_US with build

Version: 4.2.0.0.alpha0+
Build ID: 45ef1eda9e8851d454237d91b7fc46299fd621eb
TinderBox: Win-x86@6-debug, Branch:master, Time: 2013-08-23_07:32:04

This does not occur in the 4.0 branch so it's a regression.
Comment 5 apollo2k4 2013-09-19 18:20:45 UTC
At a choice of the "custom install" of a daw from the menu to create a label it all the same appears.
LibreOffice 4.1.2.2
Comment 6 Maxim Monastirsky 2013-09-22 15:13:01 UTC
*** Bug 69334 has been marked as a duplicate of this bug. ***
Comment 7 Urmas 2013-09-28 05:39:27 UTC
*** Bug 69898 has been marked as a duplicate of this bug. ***
Comment 8 Thomas Arnhold 2013-10-03 10:51:40 UTC
mab4.1 candidate?
Comment 9 Andras Timar 2013-10-03 10:55:21 UTC
(In reply to comment #8)
> mab4.1 candidate?

No, please. This is a minor issue, not a MAB.
Comment 10 ign_christian 2013-10-14 08:58:39 UTC
*** Bug 70447 has been marked as a duplicate of this bug. ***
Comment 11 Robinson Tryon (qubit) 2013-10-19 13:43:50 UTC
*** Bug 70635 has been marked as a duplicate of this bug. ***
Comment 12 Joel Madero 2013-10-19 20:43:00 UTC
@F...

The name is in violation of our FDO policy (no swearing) so please change your name in account settings or we will be forced to ban your account on FDO.

Thanks
Comment 13 Lionel Elie Mamane 2013-10-20 15:53:06 UTC
(In reply to comment #14)

We ask for an email address to have a contact point when we need more information on the bug report (which is nearly always), so that we can ask the submitter to test the fix, and things like that.

With regards to spam, what several people do is setup a special email address that does only that, and that e.g. takes email _only_ from the particular domain or email address it is used for (e.g. in this case only the address bugzilla-daemon@freedesktop.org / www-data@freedesktop.org).
Comment 14 Joel Madero 2013-10-20 16:47:42 UTC
On that note - you are now being blocked for 24 hours - next time it will be permanent
Comment 15 Joel Madero 2013-10-20 16:48:41 UTC
Actually - I am skipping straight to permanent ban because it is so beyond our policy. I will notify the appropriate people so that it's documented
Comment 16 Joel Madero 2013-10-20 19:38:23 UTC
Okay fair enough, you win - congratulations. I will leave this in others hands now.
Comment 17 Björn Michaelsen 2013-10-20 20:36:59 UTC
Joel is absolutely right here, both in tone and action on this bug. Which unfortunately cant be said for other nonconstructive commenters on this bug.

Personally, I see this case as crystal clear: Those comments are selfdefeating and the account can consider itself banned, even if the appropriate actions have not been taken yet.

Just for reference, the board of directors was informed on previous instances of such transgressions and fully trusts Joels judgement:

 http://skyfromme.wordpress.com/2013/01/19/brothers-in-arms/

Finally, I may advise any triager to make sure to separate triaging information from any swearing rants he or she might feel the urge to share. The first belongs to bugzilla, the second does not under any circumstances (which by the way, are not helping in giving the comment more ponderosity, quite the contrary).
Comment 18 Joel Madero 2013-10-21 17:22:03 UTC
@Troll - is there any way that we can be adults and have a chat about your position? I'm available on IRC - we can arrange a time. Trying to reach out to find some middle ground here
Comment 19 Commit Notification 2013-10-25 14:43:51 UTC
Andras Timar committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=7d97ec9a3eba9ceacbea631a56185e40b62fdec7

fdo#65102 respect user's choice not to install desktop icon



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 20 Pedro 2013-10-26 10:09:22 UTC
Confirmed that it is fixed with
Version: 4.2.0.0.alpha0+
Build ID: 5570de06507559b68338a29d48bb429942373f8f
TinderBox: Win-x86@42, Branch:master, Time: 2013-10-25_22:59:11

Thank you, Andras!

Can this patch be cherry picked to the 4.1 branch?

It is too late for 4.1.3 but it could be included in 4.1.4 which in theory is the first "stable" version in the branch.

It would be nice to have this back in 4.1 since it was a regression from the 4.0 branch...
Comment 21 Commit Notification 2013-10-29 12:26:48 UTC
Andras Timar committed a patch related to this issue.
It has been pushed to "libreoffice-4-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=d8e049d4e3971632eb08692905c60130731d9980&h=libreoffice-4-1

fdo#65102 respect user's choice not to install desktop icon


It will be available in LibreOffice 4.1.4.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.