Bug Hunting Session
Bug 69881 - EDITING: Incomplete OpenType subfamilies names implementation
Summary: EDITING: Incomplete OpenType subfamilies names implementation
Status: RESOLVED DUPLICATE of bug 35538
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.0.4 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks: Font-Rendering
  Show dependency treegraph
 
Reported: 2013-09-27 12:14 UTC by Thomas Linard
Modified: 2018-01-23 21:32 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Linard 2013-09-27 12:14:53 UTC
Problem description: Fonts with subfamilies names (name ID 16, 17, 18)  not limited to regular-italic-bold-bold italic are invisible.

Steps to reproduce:
1. Use Calibri Light (or whatever font matching the problem description) on LibreOffice 4.1 for Windows
2. Open the doc with LibreOffice 4.1 for Mac OS, with the same font installed

Current behavior: font not found

Expected behavior: long term expectation: be able to select styles beyond r-i-b-bi; short term expectation: be able to select "Calibri Light, style: regular".

              
Operating System: Mac OS X
Version: 4.1.0.4 release
Comment 1 Thomas Linard 2013-09-27 22:15:32 UTC
The default UI doesn't permit to select beyond r-i-b-bi styles.

In the Characters window, the UI permits it. But in a localized form (not OS independent). For example, with a French LibreOffice, "Calibri Light" font on LibreOffice for Windows becomes "Calibri Maigre" on LibreOffice for Mac OS.
Comment 2 Cliff 2013-11-07 20:54:17 UTC
I can confirm this in LO 4.1.3.2. On the same system, but using LO 4.0.5 it works as specified in the original bug report. This occurs both on OSx 10.7 and OSx 10.9. 

For my previous system (OSx 10.7.5) and my current system (OSx 10.9.0) I have Calibri, Calibri Light and Calibri Light Italic installed.

It should show all three in the drop down list. In LO 4.0.5 it only shows Calibri and Calibri Light. In AOO 3.4.1 it shows all three as it should. LO 4.1.3.2 shows only Calibri.

Further, when using Format/character to access the Calibri Light font all is fine, but if I bold the characters then it substitutes Calibri Bold and not Calibri Light Bold which is very different in appearance.
Comment 3 Maxim Monastirsky 2013-11-07 21:37:13 UTC
Confirmed by comment 2, so marking as 'NEW'. Looks very similar to Bug 67744 & Bug 71034.
Comment 4 Adolfo Jayme 2013-12-22 12:36:28 UTC
*** Bug 72944 has been marked as a duplicate of this bug. ***
Comment 5 Alex Thurgood 2014-06-06 22:29:06 UTC
*** Bug 79726 has been marked as a duplicate of this bug. ***
Comment 6 Alex Thurgood 2014-06-06 22:36:01 UTC
*** Bug 71034 has been marked as a duplicate of this bug. ***
Comment 7 Alex Thurgood 2014-06-06 22:40:53 UTC

*** This bug has been marked as a duplicate of bug 69254 ***
Comment 8 Thomas Linard 2018-01-05 09:57:51 UTC

*** This bug has been marked as a duplicate of bug 35538 ***