Bug 79726 - FORMATTING: Futura Condensed font is displayed as regular
Summary: FORMATTING: Futura Condensed font is displayed as regular
Status: RESOLVED DUPLICATE of bug 69254
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.4.2 release
Hardware: x86 (IA32) Mac OS X (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-06-06 14:35 UTC by Geza
Modified: 2018-01-23 14:00 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
screenshot of Futura Condensed Medium text in LO and TextEdit (114.67 KB, image/png)
2014-06-06 14:35 UTC, Geza
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Geza 2014-06-06 14:35:38 UTC
Created attachment 100520 [details]
screenshot of Futura Condensed Medium text in LO and TextEdit

If I set the font of some text to Futura Condensed Medium, and an other one to Futura Regular (using the Format/Character.../Font dialog), they look the same, the text does not use the condensed style of Futura.
See attached screenshot. On the right side see the same text in TextEdit.

The same happens for Papyrus Regular and Condensed (also installed with the OS), and with third party fonts like Myriad and others as well.

I do not know wether it matters or not, in TextEdit there is no Futura Regular font, it is called Futura Medium - this is the "regular" style of the family.

The problem can be seen just in the sample field of Format/Character.../Font dialog. The sample does not change when you switch from Regular to Condensed and back.

I also lost condensed formatting in an odg document created in LO3.6.

Tested on OS X 10.8.5 Mountain Lion and 10.9.3 Mavericks.
Comment 1 Yousuf Philips (jay) (retired) 2014-06-06 20:12:12 UTC
From your screenshot, with Condensed Medium appearing above Regular, i believe that libreoffice isnt recognizing the font. And similar to what you said, its showing the Regular font, which happens when a variant of the font isnt found, so it substitutes it with one of its other variants. Do you know what file extension does the Condensed Medium font have?
Comment 2 Alex Thurgood 2014-06-06 20:28:21 UTC
This is a known problem, but I need to find the previous entry, and appears to have been introduced when work was done on coretext code during 4.2 development. If I've got time, I'll try and dig up the original bug report.
Comment 3 Geza 2014-06-06 20:58:42 UTC
(In reply to comment #1)
> From your screenshot, with Condensed Medium appearing above Regular, i
> believe that libreoffice isnt recognizing the font. And similar to what you
> said, its showing the Regular font, which happens when a variant of the font
> isnt found, so it substitutes it with one of its other variants. Do you know
> what file extension does the Condensed Medium font have?

These are in standard OS X 10.8.5 and 10.9.3 install:
/Library/Fonts/Futura.ttc
/Library/Fonts/Papyrus.ttc

The MyriadPro fonts are from here:
http://www.fontpalace.com/search.php?page=3&q=myriadpro
Neither of the condensed fonts are recognised correctly:
~/Library/Fonts/MyriadPro-Cond.otf
~/Library/Fonts/MyriadPro-Regular.otf
~/Library/Fonts/MyriadPro-Semibold.otf
~/Library/Fonts/MyriadPro-SemiboldCond.otf
Cond and Regular look the same, as Semibold and SemiboldCond do as well.
Comment 4 Geza 2014-06-06 21:41:12 UTC
(In reply to comment #2)
> This is a known problem, but I need to find the previous entry, and appears
> to have been introduced when work was done on coretext code during 4.2
> development. If I've got time, I'll try and dig up the original bug report.

In OS X 10.8.5 (with the same 4 Myriad Pro fonts installed):

LO 4.1.5.3 behaves like LO 4.2.4.2: there is no difference in Regular and Condensed typefaces in case of Futura, Papyrus, Myriad Pro (regular and semibold) fonts.

In LO 4.0.5.2 Futura and Papyrus behave like in LO 4.2.4.2, but Myriad fonts are shown as different families and they look fine!

(Creating an odt document in one version and opening it in a newer is another story.)
Comment 5 Yousuf Philips (jay) (retired) 2014-06-06 21:45:40 UTC
LibreOffice has problems with ttc font files similar to my bug 77910 when i tried to use Cambria in Linux.
Comment 6 Alex Thurgood 2014-06-06 22:29:06 UTC

*** This bug has been marked as a duplicate of bug 69881 ***
Comment 7 Alex Thurgood 2014-06-07 09:51:27 UTC

*** This bug has been marked as a duplicate of bug 69254 ***
Comment 8 Thomas Linard 2018-01-05 09:57:41 UTC

*** This bug has been marked as a duplicate of bug 35538 ***
Comment 9 Thomas Linard 2018-01-23 14:00:57 UTC

*** This bug has been marked as a duplicate of bug 69254 ***