Download it now!
Bug 71984 - FILEOPEN: Incorrect first line indentation (tab) in footnotes for MS Word documents (doc and rtf)
Summary: FILEOPEN: Incorrect first line indentation (tab) in footnotes for MS Word doc...
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: filters and storage (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
: 64026 82703 91656 (view as bug list)
Depends on:
Blocks: RTF RTF-Opening Footnote-Endnote
  Show dependency treegraph
 
Reported: 2013-11-25 12:44 UTC by pavel.lastovicka
Modified: 2019-03-19 20:24 UTC (History)
12 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample document (23.00 KB, application/msword)
2013-11-25 12:44 UTC, pavel.lastovicka
Details
in MS Word 2010 (2.80 KB, image/png)
2014-02-21 10:25 UTC, pavel.lastovicka
Details
in OOo / LO (1.81 KB, image/png)
2014-02-21 10:26 UTC, pavel.lastovicka
Details
Proposed solution (8.14 KB, patch)
2014-02-21 10:29 UTC, pavel.lastovicka
Details

Note You need to log in before you can comment on or make changes to this bug.
Description pavel.lastovicka 2013-11-25 12:44:16 UTC
Created attachment 89741 [details]
Sample document

Problem description: 
If a footnote has negative first line indentation, LibreOffice always adds indentation after footnote number. In Word documents, there is explicit tab character to achieve this. I think the problem applies to all Word document formats,  .doc, .docx, .rtf and .xml.

The problem was introduced with this change:
https://issues.apache.org/ooo/show_bug.cgi?id=32902

Steps to reproduce:
The attached sample document illustrates the problem.

Expected behavior:
MS Word document should look the same in LO as in software from other vendors.
              
Operating System: All
Version: Inherited From OOo
Comment 1 Robinson Tryon (qubit) 2013-12-19 06:54:55 UTC
Hi Pavel,

Could you please provide a screenshot of what it looks like on MS-Word vs. a current release of LO?

Thanks!
Comment 2 pavel.lastovicka 2014-01-02 12:00:53 UTC
Hello,

I have a fix practically ready but unfortunately I have been ill for weeks so I could not finish it.
I hope I will finish it soon.
Comment 3 pavel.lastovicka 2014-02-21 10:25:34 UTC
Created attachment 94496 [details]
in MS Word 2010
Comment 4 pavel.lastovicka 2014-02-21 10:26:38 UTC
Created attachment 94497 [details]
in OOo / LO

Adding requested screenshots.
Comment 5 pavel.lastovicka 2014-02-21 10:29:13 UTC
Created attachment 94499 [details]
Proposed solution
Comment 6 Andras Timar 2014-02-21 13:34:49 UTC
https://gerrit.libreoffice.org/#/c/8160/
Comment 7 Miklos Vajna 2014-02-27 09:53:07 UTC
See my comment in the gerrit review, I think it would be possible to avoid a layout compat option here, which is always the last resort when dealing with interop problems.
Comment 8 pavel.lastovicka 2014-03-10 11:49:27 UTC
Sorry I am not an expert on Writer. I made the change as compatibility option as it relates to compatibility with MS Office. The option is still available via UNO. So imho it could be added to user interface easily.
The only issue is that it needs to be set at document creation. Later change would require repainting the document.
Comment 9 Cor Nouws 2015-05-27 07:42:51 UTC
*** Bug 82703 has been marked as a duplicate of this bug. ***
Comment 10 Cor Nouws 2015-05-27 07:43:23 UTC
*** Bug 91656 has been marked as a duplicate of this bug. ***
Comment 11 João Paulo 2015-05-29 06:27:34 UTC
This bug makes difficult round tripping documents between text processors because one needs to erase all the tabs LibreOffice inserted when exporting the document.

I am having difficulties trying to convince my workmates to switch to LO because of this and other document exchange bugs. Worse, I will be forced to use Ms Word or copy, paste and review the formatting between LO and Ms Word :-(
Comment 12 Björn Michaelsen 2015-07-06 18:37:36 UTC
Comment on attachment 94499 [details]
Proposed solution

Marking the attached patch obsoleted by:
https://gerrit.libreoffice.org/#/c/8160/
(Even though that has been abandoned non-merged too -- still better to revive this on gerrit than with attached patches)
Comment 13 Cromatino 2016-01-05 11:55:48 UTC
At present, this is still one of the most troublesome obstacles to using Libreoffice (or Openoffice...) Writer in professional situations. If you create documents with LO or OO, when you save/convert the files as .doc or .docx for people who work with Microsoft Office (example: publishers), you have to remove manually all the unwanted tabs at the beginning of every single footnote. This is not feasible when you have to handle long texts with dozens, hundreds or thousands of footnotes. So, in professional contexts, people are compelled to write documents with MS Word from start to finish because of this trivial defect. I suggest to change the "importance" to "major". I think this is a duplicate of Bug 64026 (not fixed and not assigned).
Comment 14 Cor Nouws 2016-01-05 12:45:09 UTC Comment hidden (obsolete)
Comment 15 Cor Nouws 2016-01-05 12:48:10 UTC
*** Bug 64026 has been marked as a duplicate of this bug. ***
Comment 16 pavel.lastovicka 2016-01-06 12:54:30 UTC Comment hidden (obsolete)
Comment 17 Cor Nouws 2016-05-09 10:18:24 UTC
*** Bug 95637 has been marked as a duplicate of this bug. ***
Comment 18 Xisco Faulí 2017-07-13 10:53:28 UTC Comment hidden (obsolete)
Comment 19 Justin L 2018-03-31 07:40:24 UTC
The following duplicates are solved by the proposed fix for bug 106062 / LO 6.1.
-bug 82703 from comment 9
-probably bug 91656 from comment 10 (no example document provided...)
-bug 64026 from comment 15 (based on odt - probably several different angles in this bug though.)

Based on the details of comment 0, I'm sure this will have to be a WONTFIX. A hanging indent is critical for emulating LO default footnotes in MSO. The MSO workaround is to ensure that a hanging indent is not used.
Comment 20 BP 2018-06-27 17:15:32 UTC
Quickest workaround is to open the affected Word file, go into your first footnote, search for ^t and leave replace empty, replace all. This will leave the original space between the note number and the text.