Bug 74074 - FORMATTING: Ability to rearrange order of conditions in conditional formatting dialogs
Summary: FORMATTING: Ability to rearrange order of conditions in conditional formattin...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: high enhancement
Assignee: Not Assigned
QA Contact:
URL:
Whiteboard: BSA target:5.4.0
Keywords: needsDevEval, topicUI
: 74082 90060 90784 (view as bug list)
Depends on:
Blocks: Conditional-Formatting
  Show dependency treegraph
 
Reported: 2014-01-26 10:10 UTC by boicottms
Modified: 2017-04-12 21:28 UTC (History)
15 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description boicottms 2014-01-26 10:10:16 UTC
Problem description: 
If I need to change the order of conditions in conditional formatting i have to rewrite many of them
Steps to reproduce:
1. create two or more conditions in conditional formatting, save
2. try to change their order
3. ....

Current behavior:
not possible (to my knowlege)
Expected (wished) behavior:
drag'n'drop or up/down arrows icon should change the order of conditions
              
Operating System: Windows 7
Version: 4.1.4.2 release
Comment 1 m.a.riosv 2014-01-26 15:32:11 UTC
A very useful option.
Comment 2 m.a.riosv 2014-01-26 15:41:42 UTC
*** Bug 74082 has been marked as a duplicate of this bug. ***
Comment 3 Bernhard 2014-06-13 12:04:28 UTC
(In reply to comment #0)
> Problem description: 
> If I need to change the order of conditions in conditional formatting i have
> to rewrite many of them
> Steps to reproduce:
> 1. create two or more conditions in conditional formatting, save
> 2. try to change their order
> 3. ....
> 
> Current behavior:
> not possible (to my knowlege)
> Expected (wished) behavior:
> drag'n'drop or up/down arrows icon should change the order of conditions
>               
> Operating System: Windows 7
> Version: 4.1.4.2 release

Hi,

a very useful request.
Current workaround (very extensive):
- Adding a new empty condition with EXTRA-button.
- Copying previous conditions one by one to new position.
- Editing the condition to be inserted.

OS: Linux Ubuntu 14.04 i386/32bit
LO-Version: 4.2.4.2 release
Comment 4 JLGianaroli 2015-01-21 18:33:41 UTC
hi

This improved Conditional Formatting seems very important to me.
The order of priority different conditions is fixed for the moment.
Having the ability to add a condition to any place or be able to move around its conditions would allow users to work faster and smarter.

cordially

Of French to English translation with Google
Comment 5 m.a.riosv 2015-03-17 15:06:41 UTC
*** Bug 90060 has been marked as a duplicate of this bug. ***
Comment 6 Murz 2015-03-17 15:12:23 UTC
> Current workaround (very extensive):
> - Adding a new empty condition with EXTRA-button.
> - Copying previous conditions one by one to new position.
> - Editing the condition to be inserted.

This not work correctly, sometimes newly added conditions adds not to end of old conditions, but in middle :(

So I vote for adding interface for re-order condition in libreoffice caclc conditional formatting interface
Comment 7 Murz 2015-03-18 12:11:42 UTC
And example with easy demonstrating the problem from Bug 90060:

If first rule "greater than 5" apply Style "Red color", and second rule "greater than 10" on same cell apply Style "Green color" - all cells less than 10 and less than 5 will have Green color. This can be solved via change rule order, but there are no good way to change it.
Comment 8 raal 2015-04-22 16:29:33 UTC
*** Bug 90784 has been marked as a duplicate of this bug. ***
Comment 9 MarMar 2015-11-05 10:00:57 UTC
Deeply sorry for it but without the possibility to prioritize conditional formatting this feature is almost useless. IMHO, if we want to draw people away from Excel this should be fixed asap. In my case, even with a strong inclination to use Calc whenever possible and even when it sometimes is not as user friendly as Excel, this is a stopper for serious use. Having said this, I am aware of the effort many people are putting into LO and you are doing a great job (huge thanks)but we must sate things as they are...
Comment 10 Yousuf Philips (jay) 2015-11-05 21:35:12 UTC
As mentioned in my duplicate bug report, "As conditional formatting is applied based on the condition number in the sequence, we need 'Move Up' and 'Move Down' buttons next to the 'Add' and 'Delete' buttons so a user doesnt have to remove and re-add an entry to change the sequence ordering."

This is primarily needed in the conditional formatting management dialog (sc/uiconfig/scalc/ui/condformatmanager.ui) and entries in the dialog shouldnt be sorted alphabetically rather than how they were added into a document (bug 91654), but also needed in the conditional formatting dialog (sc/uiconfig/scalc/ui/conditionalformatdialog.ui) so that individual rules can be managed.
Comment 11 Robinson Tryon (qubit) 2015-12-14 06:09:33 UTC
Migrating Whiteboard tags to Keywords: ( needsDevEval topicUI)
[NinjaEdit]
Comment 12 Aprax 2016-06-23 17:55:13 UTC Comment hidden (me-too)
Comment 13 Philippe 2016-10-28 00:10:15 UTC Comment hidden (me-too)
Comment 14 Commit Notification 2017-04-07 10:44:13 UTC
Manfred Blume committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=1a95e2a2bbdd1b95d97d3e79b1ef0bc5da95a110

tdf#74074 Ability to rearrange order of conditions

It will be available in 5.4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 15 m.a.riosv 2017-04-08 11:37:49 UTC
Thanks @Manfred, I think a lot of people will appreciate it.
Tested with
Version: 5.4.0.0.alpha0+
Build ID: 2f7b05988e6853ddac68b614e9d83e05af08bc0f
CPU threads: 4; OS: Windows 6.19; UI render: GL; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-04-08_00:27:58
Locale: es-ES (es_ES); Calc: CL

Should not be solved as fixed?

Can it backported to 5.3?
Comment 16 Katarina Behrens (CIB) 2017-04-12 09:13:43 UTC
> Should not be solved as fixed?

Resolving accordingly
 
> Can it backported to 5.3?

The bugfix unfortunately involves UI & translatable string change, which excludes the possibility of backport [1]. Sry about that ... 

[1] unless one has L3 support and some1 also backports related translations for them
Comment 17 m.a.riosv 2017-04-12 21:28:17 UTC
(In reply to Katarina Behrens (CIB) from comment #16)

> The bugfix unfortunately involves UI & translatable string change, which
> excludes the possibility of backport [1]. Sry about that ... 
> 
> [1] unless one has L3 support and some1 also backports related translations
> for them

Forgive me for an inadequate request.