Download it now!
Bug 78644 - FILESAVE: Autosave moves the focus
Summary: FILESAVE: Autosave moves the focus
Status: RESOLVED DUPLICATE of bug 95797
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.3.2 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2014-05-13 02:55 UTC by ali
Modified: 2016-05-10 08:55 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ali 2014-05-13 02:55:22 UTC
Suppose you are editing a multipage research paper and you make a correction on page 1. You do not save the document yet and you just keep on reading, while leaving the cursor on page 1, at the location where the correction was made. Suppose you are now reading the i-th page (i>>1) and you have not moved the cursor from page 1, and suppose 15 minutes have passed since you made the change on page 1. All of the sudden the focus will jump back to page 1 as the AutoSave feature kicks in. This causes you to spend countless minutes trying to find which page the document we were reading, and possibly even lose your train of thought.

When LibreOffice Writer autosaves a document, it should not auto-scroll the document to the location where the cursor is. AutoSave should not cause any scrolling action. 
Operating System: Ubuntu
Version: 4.1.3.2 release
Comment 1 Joel Madero 2014-05-16 20:47:37 UTC
Cannot reproduce. Tested on:

Ubuntu 14.04 x64
LibreOffice 4.2.4.2 release + LibreOffice 4.3 master built two days ago.

Please test on 4.2.4.2 - if you still experience the problem put the bug back in Unconfirmed status and we'll try to test again.
Comment 2 mal 2015-12-04 15:51:26 UTC
This happens on openSUSE 5.0.3.2

Scenario 1

Create one page of text
Put cursor at the top
Scroll down so the cursor goes off the screen
Wait
Autosave happens 
Page stays still - good

Scenario 2

Create two pages of text ( if not enough add more  - my document has six pages ) 
Put cursor at top
Scroll down so the first page is completely off the screen
Wait
Autosave happens
LO jumps back to top of first page - annoying

Mal
Comment 3 tommy27 2015-12-04 21:00:16 UTC
not reproduced under Windows using LibO 5.0.3.1
anyway since there's a Linux confirmation the status is NEW
Comment 4 sdc.blanco 2016-04-30 09:13:33 UTC
Seems related or dup to bug 94663 and bug 93574

Removing from META Autorecovery / Autosave issues
Comment 5 Buovjaga 2016-05-10 08:55:49 UTC
Duping to bug 95797, although I suspect original reporter had cursor in a table like in bug 41063.

*** This bug has been marked as a duplicate of bug 95797 ***