Download it now!
Bug 93574 - Autosaving or regular saving change focus from the current page
Summary: Autosaving or regular saving change focus from the current page
Status: RESOLVED DUPLICATE of bug 95797
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.0.0.5 release
Hardware: Other Linux (All)
: low minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-08-21 12:33 UTC by Ljiljan
Modified: 2016-05-10 08:55 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ljiljan 2015-08-21 12:33:44 UTC
User-Agent:       Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/44.0.2403.155 Safari/537.36
Build Identifier: LibreOffice 5.0.0.5

If your document is saved (by you or auto-save option) while your text cursors is on page two, but you were scrolling down with mouse to page five, the focus from page five will be given to page two. This will force you to scroll back to the page you were reading.

Reproducible: Always

Steps to Reproduce:
1. Open document with more pages
2. Click anywhere on page two (leave your text cursor there)
3. Scroll down to page five (don't click, just scroll down with the mouse)
4. Click Save 
Actual Results:  
Focus from page five will be given to page two

Expected Results:  
The page I was reading should not change. 

[Information automatically included from LibreOffice]
Locale: en-US
Module: TextDocument
[Information guessed from browser]
OS: Linux (All)
OS is 64bit: yes


Reset User Profile?No
Comment 1 Joel Madero 2015-08-21 20:51:40 UTC
Confirmed

Ubuntu 15.04 x64
LibreOffice 5.0.0.5

Setting to:
NEW
Minor - can slow down but won't prevent high quality work;
Low - default

@Ljiljan - thanks for the fantastic report (very clear to read). If you ever have time to drop by and say hello to our QA team please do so!:
http://webchat.freenode.net/?channels=libreoffice-qa
Comment 2 Ljiljan 2015-09-13 07:12:01 UTC
I think this should be fixed as soon as possible. It does not prevent me from high-quality work, but it is making me nervous :-) 

I experience some crashing of LO in Ubuntu 14.04 (however, after removing 4.0 settings and letting 5.0 to create new one, I didn't experience any crash). Therefore, I decided to set autosave to 5 minutes... and it is terrible experience.

Should we set importance of this problem as "critical"? You open page 5, click there, then scroll with your mouse to the page 20. And you decide to save the document or autosave just started (but you forgot to click), and then... you are back to the page 5. I believe this problem is critical, but its solution should be trivial.
Comment 3 Joel Madero 2015-09-13 16:23:26 UTC
No this is a minor bug and comments like "I think we should fix this as soon as possible" are entirely unhelpful as what you are really saying is "I think YOU (volunteer) should fix MY pet bug as soon as possible." 

This is a minor bug and will remain as such.
Comment 4 Ljiljan 2015-09-13 18:40:17 UTC
I think this conversation is going into wrong direction. I believe volunteer are contributing to LibreOffice not for themself, but for wider audience (including me). Their purpose is not to serve me or anyone, but still they want to create free software using their specific knowledge and our FEEDBACK. 

This bug affects me as well. I will survive somehow, but people switching from other offices judge LO by such (very obvious) processes. It's a shame to fail at such simple test (such as saving document and losing focus of current page). This bug is trivial and very annoying for anyone actively using LibreOffice. Higher priority should be given to it. Otherwise, this trivial bug will be ignored (it's minor, why should we fix it?) and users will eventually create image of LO not being capable to deliver most simple processes without making mistake.

It's like you know how to drive the car, but you always forget to take keys with you.
Comment 5 Malachi Constant 2015-09-17 06:37:19 UTC
Confirmed in Writer 5.0.1.2 on Windows 10 Pro.

Regarding the question of this bug's urgency, I can tell you I will switch to Word if this is not fixed very soon. My workflow depends on a lot of reading & revision by cross-checking over multiple pages, and this is making it too hard for me to work.
Comment 6 Joel Madero 2015-09-17 14:50:11 UTC
I suggest switching to Word then. Those kinds of comments are entirely useless as well and doesn't help the community or get your pet bug fixed. "I'm going to switch to your competitor unless YOU with YOUR skills prioritize MY bug higher and volunteer YOUR time to get it fixed SOON" is about as ridiculous as a statement as you can make.

Enjoy Microsoft Word.
Comment 7 Malachi Constant 2015-09-18 05:08:46 UTC
I apologize if my comment appeared to be soliciting any special treatment. I am an advocate of open source software, and when I say this bug will make me switch from LibreOffice if it is not fixed soon, I do not say so glibly.

In open source, the opinions and preferences of the developers tend to drive the priorities, and I'd say rightly so. However, the users have to matter too. After all, who else does the whole operation exist for?

What I'm saying here is that I'm patient, I understand there is other work to be done, and I still believe in the LibreOffice project. However, I can only endure so much interruption to my work before I give up and say I've had enough. It's crazy-making.

By expressing this sentiment here, I'm letting it be known that there is one more user who feels this way. If enough users feel the same, an open source project ought to be responsive to it. Otherwise, you might consider that you really are fulfilling the worst stereotypes of rigid, delicate-egoed open source ideologues.

But, fine, perhaps commenting about it on the bug tracker does nothing toward getting the bug fixed. I'd like to try to fix it myself, but I don't have the coding chops, and I know nothing of LibreOffice's code base and its development practices.

Even though I'm in a position to get an MS Office license for $10, I'll pony up $50 as a bounty to get this bug fixed. I'm sure LibreOffice has given me at least that much in value over the years. Just let me know who at the Document Foundation I have to get in touch with to make it happen.
Comment 8 Ljiljan 2015-09-18 14:25:25 UTC
Madero, why did you assume that this bug report and my kind request to change priority to higher level is my attempt to "force LibreOffice developer to fix my pet bug"? Instead, why don't you appreciate feedback from loyal and active user of LibreOffice (and active promoter of LibreOffice in my community) who has discovered a very trivial bug that should be fixed as soon as possible? Not because it is my "pet bug", but because this is everyone's pet bug. I reported more than 10bugs and participated in discussion of other bugs' report, but none of my bugs' report seemed to be more important than this one. 

WPS office offers to continue editing your document from last position (I am considering should I suggest this improvement because someone might think that I am forcing my "pet wishes to come true")? But I should be thankful that LibreOffice developer invented the changing focus of current page while regular saving or auto-saving. Everyone enjoys when the page focus randomly changes... so let's give this bug low priority and let's invent following: "Spelling dialog no longer automatically closes once spellcheck is complete; Mail merge embedding of the datasource definition, Hide Whitespace option added to View menu" (LibreOffice 5.1. Release Notes). Thanks and please don't mind my report. If you can, remove it. Next time you can invent random color changes of my text or something like that.
Comment 9 Joel Madero 2015-09-19 16:10:17 UTC
There is no one within TDF to contact about bounties - TDF does not currently have a bounty program (for a variety of reasons). That being said, others have used third-party (not supported by TDF, nor guaranteed at all) sites such as freedomsponsors.

You could in theory get in contact with a certified developer - https://www.documentfoundation.org/certification/developers/

But in all honesty - $50 is very unlikely to inspire anyone to get it done. This is likely several hours worth of work (10,000,000 lines of code, just finding where the issue is could take a few hours). Paying a few bucks an hour hasn't (in my experience) resulted in a whole ton of work being done "for pay."

But - you're free to try the certified developers page of freedomsponsor (or any other third party site, again not at all guaranteed by TDF)
Comment 10 Malachi Constant 2015-09-25 05:24:00 UTC
Thanks, Joel - I appreciate your efforts.
Comment 11 Jerry 2015-12-04 23:26:55 UTC
Joel,

Why are you taking a request to upgrade the status of this bug so personally.  It really is annoying and a major interruption to the workflow in LO.  Fortunately I have installed 5.0.4.3 as a parallel installation with 4.4.4.3 and will remove 5. and go back to where I am happy. Meantime you might lighten up.

Jerry
Comment 12 John van Someren 2016-01-05 23:19:59 UTC
I am surprised at some of the judgmental statements made, and language used by the Joel Madero. Her criticisms of some of the comments are very unusual in such a web site and are not likely to advance the service you people provide.

I am on this page because I also spend a lot of time reading documents which need an occasional edit and it irks me when the autosave flips me back several pages.

I, like the person who reported it, consider this bug to be more than "minor importance", but how can I know what is Minor, what is Normal etc.

Is there some page where the user can read the criteria used by the people who make this assessment? I cannot believe that they just use their gut feel. There must be written criteria on a web site with so many users as this.

Thank you for considering my comment.

John van Someren
Comment 13 sdc.blanco 2016-04-30 09:09:25 UTC
This bug seems to be a duplicate or closely related to others. See Bug 94663 Bug 78644 and bug 41063  (and removing from Meta Autosave /Autorecovery issues)
Comment 14 Ljiljan 2016-05-07 09:20:33 UTC
Is it possible to delete this bug report completely? I believe nobody will ever try to solve it because they will think that they are solving "my pet bug" (conversation went into this direction). And I actually developted a habit of clicking on pages while scrolling and reading the documennt, so this is not "my pet bug" anymore.
Comment 15 Buovjaga 2016-05-10 08:55:07 UTC

*** This bug has been marked as a duplicate of bug 95797 ***