Download it now!
Bug 79928 - FORMATTING: Pasted text doesn't preserve it's formatting
Summary: FORMATTING: Pasted text doesn't preserve it's formatting
Status: RESOLVED DUPLICATE of bug 112697
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.2.4.2 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
: 79445 (view as bug list)
Depends on:
Blocks: Formatting-Text-Diverse
  Show dependency treegraph
 
Reported: 2014-06-11 20:16 UTC by Alexander
Modified: 2019-08-31 10:08 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander 2014-06-11 20:16:26 UTC
Problem description: 
Pasted text doesn't preserve it's formatting

Steps to reproduce:
1. Create a new presentation
2. Type some line and make it italic
3. Type next line (not italic). Let it be bold
4. Copy some text from the 2nd line and paste it somewhere in the middle of the 1st line

Current behavior:
The pasted text is italic - so annoying :(

Expected behavior:
The pasted text must be EXACTLY the same as it was copied. And it must be regardless of whether it's pasted into a blinking cursor position or instead of some selected text

It's also reproduced in LO Writer

Operating System: Windows 8
Version: 4.2.4.2 release
Comment 1 ign_christian 2014-06-12 04:43:35 UTC
*** Bug 79445 has been marked as a duplicate of this bug. ***
Comment 2 ign_christian 2014-06-12 04:48:28 UTC
Not reproducible on 4.0.6.2 - win7 x86. Copied format (bold) still preserved.
Comment 3 Alexander 2014-06-12 07:38:41 UTC
Hi, ign_christian,

I missed it in the initial topic. It must've been:

Current behavior:
The pasted text is BOLD AND italic
Comment 4 ign_christian 2014-06-12 07:53:09 UTC Comment hidden (obsolete)
Comment 5 Alexander 2014-06-12 08:23:33 UTC Comment hidden (obsolete)
Comment 6 Alexander 2014-06-12 09:23:32 UTC
Have tried it also in LO 3 on Ubuntu 12.4 (in VM Oracle VirtualBox) - it is reproduced in the same way. The text is italicized when being pasted to the right of an italic symbol.

Copied not italic text in LO Impress and inserted it into WordPad among italic symbols - the symbols preserved their size, style and font. 

Copied not italic text in WordPad and inserted it into LO Impress among italic symbols - the symbols italicized (also they changed their size).
Comment 7 raal 2014-10-21 13:17:30 UTC
I can reproduce with LO 4.3.2, windows7. Setting as new.
Occurs also in writer.
Comment 8 Jim Avera 2015-01-19 02:35:17 UTC
Works for me with 4.4.0.0.beta2 on Linux.   To reproduce this, should I just type text into the main body block of the presentation frame? That's what I did and copy/paste seems to preserve the copied characters' format exactly (I don't have any experience with Presentations so don't know my way around this application). 

However a possibly-related problem does exist in Writer - see bug 88380
Comment 9 QA Administrators 2016-02-21 08:36:11 UTC Comment hidden (obsolete)
Comment 10 Alexander 2016-02-21 21:04:09 UTC
Version: 5.1.0.3
Build ID: 5e3e00a007d9b3b6efb6797a8b8e57b51ab1f737
CPU Threads: 4; OS Version: Windows 6.2; UI Render: GL; 
Locale: en-US (en_US)

Still reproduced in both Impress and Writer.

Also in Impress "Home" and "End" buttons don't work.
Comment 11 QA Administrators 2018-02-24 03:34:15 UTC Comment hidden (obsolete)
Comment 12 Timur 2018-07-06 16:36:52 UTC
This bug wasn't triaged well. 
It's "negative observation" - Pasted text doesn't preserve it's formatting - instead of "positive action" - Add Option for pasted text to keep Source formatting. 
This issue is not just Impress nor Windows. Even Writer also doesn't have "Keep Source formatting". So this bug should be about adding that option. 
I'd change this myself but I need a confirmation we don't have dupes on this. And we need a proposed solution. Since having Paste options box was also another bug. 
What's default option is another issue.
Comment 13 Heiko Tietze 2018-07-20 08:05:43 UTC
needsUXEval requires CC libreoffice-ux-advise@...
Comment 14 Heiko Tietze 2018-07-26 09:49:18 UTC
I would make this a duplicate of bug 112697 since we have more discussion on that ticket (and a dev working on it).
Comment 15 Heiko Tietze 2018-10-28 12:21:41 UTC

*** This bug has been marked as a duplicate of bug 112697 ***