Bug 82218 - Chart app doesn't support displaying data table
Summary: Chart app doesn't support displaying data table
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: high major
Assignee: Tomaz Vajngerl
URL:
Whiteboard: target:7.5.0
Keywords:
: 112851 137691 (view as bug list)
Depends on:
Blocks: OOXML-Chart XLSX-Limitations ODF-import
  Show dependency treegraph
 
Reported: 2014-08-06 01:08 UTC by Yousuf Philips (jay) (retired)
Modified: 2022-09-16 13:50 UTC (History)
10 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
The example file in current nightly and Word 2013 (193.44 KB, image/png)
2022-09-15 20:53 UTC, Gabor Kelemen (allotropia)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2014-08-06 01:08:56 UTC
Steps:
1) Open attachment 104062 [details]
2) Notice that there isnt anything between 'Category 1' and 'Axis Title'
3) Look at Word 2010 VS 4.4 screenshot - attachment 104114 [details]

Tested in 4.4, 4.3.1, and 4.2.6 on Linux.
Comment 1 Joel Madero 2014-08-06 02:03:30 UTC
Bodhi Linux 2.4 - E17
LibreOffice 4.4 Built August 7, 2014

Confirmed:
New
Major - at least for user it appears like loss of data
High - default seems fine
Comment 2 Markus Mohrhard 2015-04-27 18:38:47 UTC
We have just no rendering support for data tables. We store them in the file and can export them again.
Comment 3 Markus Mohrhard 2015-06-02 12:12:58 UTC
Some notes for whoever is going to implement it:

https://wiki.documentfoundation.org/Unimplemented_Chart_ODF_Elements
Comment 4 Timur 2015-10-29 14:34:21 UTC
*** Bug 95345 has been marked as a duplicate of this bug. ***
Comment 5 Xisco Faulí 2017-09-29 08:51:26 UTC Comment hidden (obsolete)
Comment 6 mcjarod 2017-09-29 16:18:41 UTC
The problem continues without any change in Versión: 5.4.1.2 (x64) with Windows 7
Comment 7 QA Administrators 2018-11-17 03:47:48 UTC Comment hidden (obsolete)
Comment 8 Aron Budea 2019-02-20 15:43:04 UTC
*** Bug 112851 has been marked as a duplicate of this bug. ***
Comment 9 Aron Budea 2020-10-25 09:36:38 UTC
*** Bug 137691 has been marked as a duplicate of this bug. ***
Comment 10 Regina Henschel 2021-12-08 22:09:29 UTC
(In reply to Markus Mohrhard from comment #3)
> Some notes for whoever is going to implement it:
> 
> https://wiki.documentfoundation.org/Unimplemented_Chart_ODF_Elements

This is misleading. None of the there mentioned elements exists in ODF 1.3.
Comment 11 Gerald Pfeifer 2022-07-30 14:36:16 UTC
Miklos, in the ESC minutes I saw that you are working on this? If so,
this bug may be interesting (if for no other reason than to be able to
mark it resolved. ;-)
Comment 12 Miklos Vajna 2022-08-01 07:13:46 UTC
Tomaz works on this, let me set the assignee field accordingly.
Comment 13 Gabor Kelemen (allotropia) 2022-09-15 20:53:11 UTC
Created attachment 182476 [details]
The example file in current nightly and Word 2013

Looks like the DOCX import needs a bit more work to show data tables.

Version: 7.5.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 4ca5c021c91680f1a5df47225d9cb0d41c0a8637
CPU threads: 14; OS: Windows 10.0 Build 19044; UI render: Skia/Raster; VCL: win
Locale: en-US (hu_HU); UI: en-US
Calc: threaded
Comment 14 Gabor Kelemen (allotropia) 2022-09-16 06:49:14 UTC
Okay, that was just me. See attachment 182484 [details] for how it looks with default ODF version set to 1.3 extended - now it all correctly appears.