Bug 82942 - EDITING: First line of address field (in OTT) loses characters after filling out subsequent fields
Summary: EDITING: First line of address field (in OTT) loses characters after filling ...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.3.0.4 release
Hardware: Other All
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: BSA target:4.5.0 target:4.4.1 target:...
Keywords: bibisected, bisected, haveBacktrace, regression
: 86695 88856 89209 89249 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-08-22 09:23 UTC by Mike Silbermann
Modified: 2015-12-17 08:32 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
OTT File with fields and this error if you fill out fields... especial adress field (133.60 KB, application/vnd.oasis.opendocument.text-template)
2014-08-22 09:23 UTC, Mike Silbermann
Details
ZIP containing screenshot using LOv4262 (OK) and LOv4304 (not OK). (24.90 KB, application/zip)
2014-08-24 02:38 UTC, Owen Genat (retired)
Details
Linux 4.5 master backtrace (4.19 KB, text/plain)
2015-01-21 03:36 UTC, Matthew Francis
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mike Silbermann 2014-08-22 09:23:42 UTC
Created attachment 105092 [details]
OTT File with fields and this error if you fill out fields... especial adress field

Problem description: 

When contained in a template field commands, the content is ferändert after the field was filled and other fields are filled in

Current behavior: Field Address

Expected behavior:

              
Operating System: Windows 8
Version: 4.3.0.4 release
Last worked in: 4.2.5.2 release
Comment 1 Owen Genat (retired) 2014-08-23 14:03:59 UTC
(In reply to comment #0)
> OTT File with fields and this error if you fill out fields... especial
> adress field
> 
> When contained in a template field commands, the content is ferändert [changed?]
> after the field was filled and other fields are filled in

Unable to confirm. Tested under GNU/Linux using:

- v4.1.6.2 Build ID: 40ff705089295be5be0aae9b15123f687c05b0a
- v4.2.6.2 Build ID: 185f2ce4dcc34af9bd97dec29e6d42c39557298f
- v4.3.0.4 Build ID: 62ad5818884a2fc2e5780dd45466868d41009ec0
- v4.4.0.0.alpha0+ Build ID: e379401618268ed7f7f5885a36b90e1f4f6cd4af TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:master, Time: 2014-08-18_05:51:03

In all cases the address field (Empfänger Adresse) can be filled out OK and the content of this field does not change once the form is completed. It may be an issue specific to the Windows build.
Comment 2 Mike Silbermann 2014-08-23 14:22:04 UTC
If you fill in after Adress the next fields.... the adress field lood letters...
Comment 3 Owen Genat (retired) 2014-08-24 02:38:40 UTC
Created attachment 105181 [details]
ZIP containing screenshot using LOv4262 (OK) and LOv4304 (not OK).

(In reply to comment #2)
> If you fill in after Adress the next fields.... 

I must not have been paying attention previously because I see the problem now. Entering this data into the Address field (Empfänger Adresse):

123 Some Street
Suburb 1234
City
State
Country

... results in the first line of text losing characters after "12". Works OK in:

- v4.1.6.2 Build ID: 40ff705089295be5be0aae9b15123f687c05b0a
- v4.2.6.2 Build ID: 185f2ce4dcc34af9bd97dec29e6d42c39557298f

... loses characters in:

- v4.3.0.4 Build ID: 62ad5818884a2fc2e5780dd45466868d41009ec0
- v4.4.0.0.alpha0+ Build ID: e379401618268ed7f7f5885a36b90e1f4f6cd4af
TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:master, Time:
2014-08-18_05:51:03

Refer attached screenshots. Sorry for not seeing this last time.
Comment 4 Owen Genat (retired) 2014-08-24 02:48:31 UTC
Per comment 3 confirmed. Status set to NEW. Summary amended for clarity. Operating system set to All. Whiteboard changed from PossibleRegression to Regression.

(In reply to comment #3)
> ... results in the first line of text losing characters after "12"

... as fields are filled out e.g.,

- completing Empfänger Adresse   displays "12 Some Street"
- completing Auftragsnummer      displays "12Some Street"
- completing Auftragsbezeichnung displays "12ome Street"
- completing Betreff             displays "12me Street"
- completing Anrede              displays "12e Street"
- completing Unterschrift        displays "12 Street"
Comment 5 Mike Silbermann 2014-08-24 07:15:34 UTC
... as fields are filled out e.g.,

- completing Empfänger Adresse   displays "12 Some Street"
- completing Auftragsnummer      displays "12Some Street"
- completing Auftragsbezeichnung displays "12ome Street"
- completing Betreff             displays "12me Street"
- completing Anrede              displays "12e Street"
- completing Unterschrift        displays "12 Street"


YES... this is the problem!
Comment 6 Matthew Francis 2015-01-21 03:36:15 UTC
Created attachment 112580 [details]
Linux 4.5 master backtrace

I get the attached backtrace from a dbgutil build of 4.5 master after entering the first value through the "Input Field" dialog
Comment 7 Michael Weghorn 2015-01-21 21:52:53 UTC
bibisect result:

d888081586d217a52fd06ce89f146aa4080b4ca9 is the first bad commit
commit d888081586d217a52fd06ce89f146aa4080b4ca9
Author: Bjoern Michaelsen <bjoern.michaelsen@canonical.com>
Date:   Mon May 12 04:58:36 2014 +0000

    source-hash-722c82b018327c1f9578ddc533ebbb06080848eb
    
    commit 722c82b018327c1f9578ddc533ebbb06080848eb
    Author:     Caolán McNamara <caolanm@redhat.com>
    AuthorDate: Thu Mar 27 11:13:51 2014 +0000
    Commit:     Caolán McNamara <caolanm@redhat.com>
    CommitDate: Fri Mar 28 09:25:04 2014 +0000
    
        coverity#735496 Dead default in switch
    
        Change-Id: I5eddf8be2a98aa57fdcdf44d390def6522caa25d

:100644 100644 245538ff99054072c932aa194dae68ad5c41434b 9506902c6a27010b21fa60db2785cf8c6a99663b M	ccache.log
:100644 100644 a0716c81ec0b918cffff246afac6112cd8829e87 f131bc060e8059666f8d7f3d448a0a6b8e1df7e4 M	commitmsg
:100644 100644 256a6a367d24deef91794bc66fdce53fa8e1d1eb 5db1c1712e795b3ab96960366a53cf84ae3d8bca M	make.log
:040000 040000 58bc5af9546ba1b0573ff129f92c7ade81e3e678 6dbe8a26ebf7cb34dc34ce783aa54092c2e9e5ed M	opt


--

# bad: [423a84c4f7068853974887d98442bc2a2d0cc91b] source-hash-c15927f20d4727c3b8de68497b6949e72f9e6e9e
# good: [c2069a369d738078124812312d51f21ea1ce2421] source-hash-f160e4935c474a5293b3d3c11b3d538efb4767a0
git bisect start 'last43onmaster' 'last41onmaster'
# good: [33ac6698e6d90d84f99d784b9553ee87eec27d6a] source-hash-732c0f929fc0229b6da37d4ec4b6de8994fcea46
git bisect good 33ac6698e6d90d84f99d784b9553ee87eec27d6a
# good: [0b79394752f7ecbab6ab4ecedbfab8551c6e9fbd] source-hash-381613916d42a1e18e2824b5d41028dcfe19659a
git bisect good 0b79394752f7ecbab6ab4ecedbfab8551c6e9fbd
# skip: [d50b7ec6c36fecb4ff94243754027d7c4e63af9e] source-hash-7328e577e297924ba9cdfc2498f84b1d17d603d4
git bisect skip d50b7ec6c36fecb4ff94243754027d7c4e63af9e
# bad: [882db5e268e28962bdf805c820a5e031b0df9936] source-hash-383dccc094f8c8c07b4298ce0b7406d18cd61cee
git bisect bad 882db5e268e28962bdf805c820a5e031b0df9936
# bad: [6feabb3ce67846b727583754afd4380ec7d59f13] source-hash-874a9b46cb54e4c05e262e5d7490790a08ea0c55
git bisect bad 6feabb3ce67846b727583754afd4380ec7d59f13
# skip: [524032d94d92022e87e0add99aea74683da8f368] source-hash-c7363cb6d1d31f2a7d40a76e62b5934629a1a8a1
git bisect skip 524032d94d92022e87e0add99aea74683da8f368
# skip: [f832455cd2cc194ff04197ef174cb1e658336d18] source-hash-a79afdaa11a1af26c9404441dcf27ef197e972b2
git bisect skip f832455cd2cc194ff04197ef174cb1e658336d18
# good: [bfba063779a12bca219e4a9fba9bba8b67821ec1] source-hash-86a32589e90ee983159fb5b2c6a594428ab7d422
git bisect good bfba063779a12bca219e4a9fba9bba8b67821ec1
# skip: [b8faa3ecebb63b814ada4be4917f2ea81f97907d] source-hash-7a120ad4ac99ac70c35132d12d11d630b92bd846
git bisect skip b8faa3ecebb63b814ada4be4917f2ea81f97907d
# skip: [422186458e0b4db00c7e26b54d5b631f83bcad2a] source-hash-6948bf58ce181b17f60ef81f10205ef4dac50cc6
git bisect skip 422186458e0b4db00c7e26b54d5b631f83bcad2a
# good: [1b831d02ff29aa5763cf33ae75131f98d882201f] source-hash-b7c3e851465638d4416ca8837937946353561088
git bisect good 1b831d02ff29aa5763cf33ae75131f98d882201f
# skip: [7ed08df7d4b9b26f20fbd161ef7283e8c5f1e619] source-hash-82332ee1fc23b6fdccaf92149c0f2fa46fcdc4d6
git bisect skip 7ed08df7d4b9b26f20fbd161ef7283e8c5f1e619
# bad: [02c5cb286868a1a77a92e31cf388eccca7ab8d31] source-hash-b73b824b8361d5cf38363eab6730e90809f6529e
git bisect bad 02c5cb286868a1a77a92e31cf388eccca7ab8d31
# bad: [5f470f9cc992302f16a0ad8b2680725ad5beec08] source-hash-7c4783f6a2cb7598ecc48f20379dad9784541d5b
git bisect bad 5f470f9cc992302f16a0ad8b2680725ad5beec08
# bad: [d888081586d217a52fd06ce89f146aa4080b4ca9] source-hash-722c82b018327c1f9578ddc533ebbb06080848eb
git bisect bad d888081586d217a52fd06ce89f146aa4080b4ca9
# good: [a6c3773eefb6c6ea2e1a8ad980c258c07a1a8e65] source-hash-4f48dc2f978d36ef9ba08bf828894fa578430fc7
git bisect good a6c3773eefb6c6ea2e1a8ad980c258c07a1a8e65
# first bad commit: [d888081586d217a52fd06ce89f146aa4080b4ca9] source-hash-722c82b018327c1f9578ddc533ebbb06080848eb
Comment 8 Björn Michaelsen 2015-01-27 21:49:39 UTC
In the bisect range there are a few commits for fdo#73936 which look somewhat suspicous. Adding commiter to cc for a look ...
Comment 9 Matthew Francis 2015-01-28 03:38:51 UTC
The document corruption appears to have started with the below commit.

commit 4e0118aba0d41008c1a31b1cdc7ce7596b894ae2
Author: Caolán McNamara <caolanm@redhat.com>
Date:   Thu Mar 27 20:22:24 2014 +0000

    Related: fdo#73936 use ModelToViewHelper to expand SwTxtNodes
    
    ModelToViewHelper knows about formfield dropdown lists
    so their content gets expanded, which means that
    in the spelling dialog the dropdowns get shown and
    are detected as fields
    
    Change-Id: If23d44c6189a73d04205816a32e863161f7f38ef
Comment 10 Commit Notification 2015-01-28 16:23:49 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=1ecf795ffaf8c63280ea92f776b53558b3227504

Related: tdf#82942 multiple crashes on changing text in SwInputFields

It will be available in 4.5.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 11 Caolán McNamara 2015-01-28 16:53:21 UTC
That fixes Comment #6 anyway
Comment 12 Caolán McNamara 2015-01-29 09:08:46 UTC
I think these cursed annotations have their GetStart at the wrong place for some unknown reason, the value is *3* for the placeholder anchor when I paste "123 Some Street
Suburb 1234
City
State
Country" in there, which is why when the placeholder is removed it removes the char at index 3 on each iteration.
Comment 13 Matthew Francis 2015-01-30 03:05:32 UTC
*** Bug 86695 has been marked as a duplicate of this bug. ***
Comment 14 Caolán McNamara 2015-01-30 10:10:52 UTC
oh for the love of...
Comment 15 Commit Notification 2015-01-30 10:17:22 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=95f4b2f4a6dfe47842336116d94edd175a6da960

Resolves: tdf#82942 updating field contents with incorrect attribute positions

It will be available in 4.5.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 16 Commit Notification 2015-02-02 14:47:22 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-4-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=092a73d070e05f54990151fdc4e66e8adac8097d&h=libreoffice-4-4

Related: tdf#82942 multiple crashes on changing text in SwInputFields

It will be available in 4.4.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 17 Caolán McNamara 2015-02-04 12:04:09 UTC
*** Bug 88856 has been marked as a duplicate of this bug. ***
Comment 18 Commit Notification 2015-02-06 15:02:30 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-4-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=6aa163f33d48326905f47e1f37ea26f992f4235f&h=libreoffice-4-3

Resolves: tdf#82942 updating field contents with incorrect attribute positions

It will be available in 4.3.7.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 19 Commit Notification 2015-02-06 15:02:40 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-4-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=772be81db70570801a0b6b5de53319f21e1ff60e&h=libreoffice-4-4

Resolves: tdf#82942 updating field contents with incorrect attribute positions

It will be available in 4.4.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 20 Julien Nabet 2015-02-08 11:32:04 UTC
*** Bug 89209 has been marked as a duplicate of this bug. ***
Comment 21 Caolán McNamara 2015-02-12 13:52:35 UTC
*** Bug 89249 has been marked as a duplicate of this bug. ***
Comment 22 Robinson Tryon (qubit) 2015-12-17 08:32:13 UTC
Migrating Whiteboard tags to Keywords: (bibisected)
[NinjaEdit]