Download it now!
Bug 83606 - Data ranges in chart inside spreadsheet can't be modified/updated in the data range window
Summary: Data ranges in chart inside spreadsheet can't be modified/updated in the data...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
4.3.0.0.alpha0+ Master
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
: 84495 87384 87385 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-09-08 11:34 UTC by Francisco
Modified: 2016-01-20 10:50 UTC (History)
10 users (show)

See Also:
Crash report or crash signature:


Attachments
chart data window (154.90 KB, image/png)
2014-09-14 01:06 UTC, Francisco
Details
Sample spreadsheet with chart (20.53 KB, application/vnd.oasis.opendocument.spreadsheet)
2014-12-10 06:36 UTC, Matthew Francis
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Francisco 2014-09-08 11:34:58 UTC
Suppose you have a chart for whitch a previous data range was "$Hoja3.$A$1:$A$3", and you have more data on column A, up to row 5. The new range should be "$Hoja3.$A$1:$A$5", and you want to update it to cover more data, only changing the last "3" with a "5" in the corresponding textbox. As the title says, any chart in Calc can't be modified/updated simple changing the text in the data range box. 

For being able to modifying it, one must press the button to open the new data range box. Once with that little window, one may select with the mouse the new range or change the text. 

This behavior was introduced in LibO 4.3, so it's a regression.

Steps to reproduce:
1) Create a new ODS file, and put some data on it to make a chart
2) Select that range and create a chart (column, bar, whatever), and deactivate the chart.
3) Add more numbers to the data column.
4) Activate the chart, right click on it and select "Data ranges option"
5) On the "Data series" tab, try to modify the data range only changing the range of the text.

Actual result:
1) The data range is not modified

Expected
1) Data range is updated, automatically.
Comment 1 Jean-Baptiste Faure 2014-09-13 20:19:06 UTC
I do not reproduce with version 4.3.3.0.0+ (Build ID: bea4100cd9ad62637a7ed33488f2a17769aa519a) built at home under Ubuntu 14.04 x86-64.

Please, to be sure, could you attach a screenshot of the dialog that does not work as expected for you?

Set status to NEEDINFO. Please set it back to UNCONFIRMED once you have provided requested informations. Thank you for your understanding.

Best regards. JBF
Comment 2 Francisco 2014-09-14 01:06:45 UTC
Created attachment 106237 [details]
chart data window

This is a screenshot of the data window with the box for chart data ranges.

I have seen something new about, so I will try to make the description a little more detailed


1) Create a XY chart with certain range.

2) Open the data range window (like in the screenshot)

3) Modify "X" series, like in the screenshot

4) Click now on the "Y" series to modify it.

Results:
The previous modification done to X series has disappeared.

Expected
The modification perfomed previously remains. Moreover, just when modifying the range, the chart used to be almost automatically updated when the range is changed. Now, with LibO 4.3.1.2 the chart is not updated when changing the range. You can see this in the attached screenshot: the blue rectangle isn't updated. However, if you only modify one series and the press "accept" and exit the data range window, the chart is updated.
Comment 3 ign_christian 2014-09-14 08:14:26 UTC
(In reply to comment #2)
> Results:
> The previous modification done to X series has disappeared.
Same behavior occured if modify Y-values first then click on X-values series

> Expected
> The modification perfomed previously remains. Moreover, just when modifying
> the range, the chart used to be almost automatically updated when the range
> is changed. 
Confirmed. Click OK after modifying a values, without clicking another values, will update the range.

Reproduced with LO 4.3.2.1, 4.3.0.0.beta1 under Ubuntu 12.04 x86

Not reproduced with LO 4.2.6.3
Comment 4 Francisco 2014-09-14 17:15:55 UTC
Thank you, Christian!
Comment 5 Stephan van den Akker 2014-09-20 14:45:00 UTC
Tested on openSuSE 13.1 (64-bit):

Bug is NOT present in MASTER:
Version: 4.4.0.0.alpha0+
Build ID: 044ec0fc7408b01087029c7057185abda71fb8ff

Bug is reproducible in:
Version: 4.3.1.2
Build ID: 430m0(Build:2)
Installed from the OBS repository  
http://download.opensuse.org/repositories/LibreOffice:/Factory/openSUSE_13.1/
Comment 6 ign_christian 2014-09-30 03:05:05 UTC
*** Bug 84495 has been marked as a duplicate of this bug. ***
Comment 7 Laurent BP 2014-09-30 17:36:51 UTC
I reproduce on Win7 with:
- Version: 4.3.2.2
Build ID: edfb5295ba211bd31ad47d0bad0118690f76407d
- Version: 4.3.1.1
Build ID: c4b15cd4d00dec6b266fa830b4ba73e31ae6ce73
- Version: 4.3.0.4
Build ID: 62ad5818884a2fc2e5780dd45466868d41009ec0
- Version: 4.3.0.0.beta1
Build ID: 2e39c7e59c8fc8b16a54c3d981dceef27fb0c07f
- Version: 4.3.0.0.alpha0+
Build ID: 9278df2c21fed09b6b10465ca33b227ad7c49b41
TinderBox: Win-x86@47-TDF, Branch:MASTER, Time: 2014-03-19_08:44:54
- Version: 4.3.0.0.alpha0+
Build ID: bcfa89158e1ce8cecf9c078ef852225180472a55
TinderBox: Win-x86@47-TDF, Branch:MASTER, Time: 2014-01-30_14:53:08

Bug is not present with
- Version: 4.3.0.0.alpha0+
Build ID: 99159a618fd1ea90a2bc8a72621c88a4cf26e6f5
TinderBox: Win-x86@47-TDF, Branch:MASTER, Time: 2014-01-17_06:46:31
which includes resolution of bug 72814 (which I though was linked to).

So bug appeared between 2014-01-17 and 2014-01-30.
Comment 8 Laurent BP 2014-09-30 18:45:18 UTC
tp_DataSource was converted from src to ui on 2014-01-17
See http://cgit.freedesktop.org/libreoffice/core/commit/chart2/source/controller/dialogs/tp_DataSource.cxx?id=9c4032921cfb11c8786e2a371286a7d8384c74d8

I'm adding Olivier to this report as he made the conversion.
Comment 9 Laurent BP 2014-09-30 19:09:01 UTC
Bug is present in master with:
- Version: 4.4.0.0.alpha0+
Build ID: 32ac015be4d0f33120bc066e7f49e197c7405c45
TinderBox: Win-x86@39, Branch:master, Time: 2014-06-10_04:54:30

Bug is NO MORE present in master with:
- Version: 4.4.0.0.alpha0+
Build ID: abc28ffc04067eb24840fbf564c311aaee10f84d
TinderBox: Win-x86@39, Branch:master, Time: 2014-07-15_07:18:40

I suggest that commit d5a0926c2359a4f8bd48cbea5a9c034b87d6aeeb from Markus solved this bug:
http://cgit.freedesktop.org/libreoffice/core/commit/chart2/source/controller/dialogs/tp_DataSource.cxx?id=d5a0926c2359a4f8bd48cbea5a9c034b87d6aeeb

Add Markus as CC
Comment 10 bruno.binet 2014-10-02 13:17:11 UTC
If I understand, a fix is coming for the 4.4 branch. 
Is bug 83162 fixed at the same time (is it the same bug)?

Also, it it possible to backport the fix the the 4.3 branch?
Comment 11 blargh 2014-10-31 12:39:33 UTC
I reproduce the bug on Win7 with LO 4.3.3.2.
All the best,
PP

(will the 4.3 branch be patched?)
Comment 12 Matthew Francis 2014-12-10 06:36:29 UTC
Created attachment 110666 [details]
Sample spreadsheet with chart
Comment 13 Matthew Francis 2014-12-10 07:13:39 UTC
Confirmed that d5a0926c2359a4f8bd48cbea5a9c034b87d6aeeb is the commit that fixed this

Setting Whiteboard: bibisected, Keywords: bisected
Comment 14 raal 2014-12-17 17:37:42 UTC
*** Bug 87384 has been marked as a duplicate of this bug. ***
Comment 15 raal 2014-12-18 17:21:45 UTC
*** Bug 87385 has been marked as a duplicate of this bug. ***
Comment 16 Laurent BP 2015-01-27 21:00:14 UTC
Bug confirmed with LibO Version: 4.3.5.2.0+
Build ID: 430m0(Build:2)

Bug REMOVED in LibO 4.3.6.1 :)
Comment 17 Francisco 2015-02-19 01:59:54 UTC
I can confirm that this bug has been solved in Libo 4.3.6 RC2.
Comment 18 Robinson Tryon (qubit) 2015-12-15 11:03:07 UTC
Migrating Whiteboard tags to Keywords: (bibisected)
[NinjaEdit]