Bug Hunting Session
Bug 87744 - VIEWING: Captions on EMF images in DOC file not rendered correctly
Summary: VIEWING: Captions on EMF images in DOC file not rendered correctly
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
4.4.0.0.beta2
Hardware: Other Windows (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2014-12-26 14:12 UTC by Timur
Modified: 2016-11-16 17:44 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
LO 4.4.0.1 - Labels, but no graph (133.77 KB, image/png)
2015-01-03 16:09 UTC, Robinson Tryon (qubit)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Timur 2014-12-26 14:12:25 UTC
This is another bug with doc file at http://www.cgedd.fr/prix-immobilier-friggit.doc, this one a regression.
Steps to reproduce: open with LO 4.4.0 beta2 or newer.
Screenshot at https://bugs.freedesktop.org/attachment.cgi?id=111295

There are multiple problems with this file:
1. crash on PDF export, original report in bug 80508, used to be confirmed in Linux Mint but not always reproducible
2. accidental crash on scrolling down (with mouse on vertical scroll) to the end and up - tested in Windows 7 x64 with LO 4.3.2 and LO 4.3.3 but cannot be  reproduced starting from 4.3.4
3. 8 pages in document instead of 7 on open, reproducible from 4.3.1.1 both in Windows and Linux, reported as Bug 86468
4. PDF export incomplete, there are items missing in WMF or EMF (legend, caption) - not reported yet or duplicate (to check after Bug 80389 and this bug are solved)
5. WMF images in DOC file not rendered correctly in Linux - Bug 80503 
6. WMF images in DOC file not rendered correctly from LO 4.4.0 beta2 (tested in Win7 64 bit) - it's this new bug (patch available in Bug 80503 for LO 4.5.0 doesn't solve this bug)
Comment 1 Robinson Tryon (qubit) 2014-12-27 05:14:04 UTC
TESTING with LO 4.4.0.1 + Ubuntu 14.04

(In reply to Timur from comment #0)
> Steps to reproduce: open with LO 4.4.0 beta2 or newer.
> Screenshot at https://bugs.freedesktop.org/attachment.cgi?id=111295

On which page did you take the screenshot? What does the screenshot show? What do you expect to see?

Please provide clearer repro steps to help us identify the context and scope of the problem.

Status -> NEEDINFO


> There are multiple problems with this file:
>

This part was confusing. Please make it clear that this section is referring to *already known/reported issues*, so we don't think that this is a multi-bug report that needs to be rewritten.

> 1. crash on PDF export, original report in bug 80508, used to be confirmed
> in Linux Mint but not always reproducible
> 2. accidental crash on scrolling down (with mouse on vertical scroll) to the
> end and up - tested in Windows 7 x64 with LO 4.3.2 and LO 4.3.3 but cannot
> be  reproduced starting from 4.3.4
> 3. 8 pages in document instead of 7 on open, reproducible from 4.3.1.1 both
> in Windows and Linux, reported as Bug 86468
> 4. PDF export incomplete, there are items missing in WMF or EMF (legend,
> caption) - not reported yet or duplicate (to check after Bug 80389 and this
> bug are solved)
> 5. WMF images in DOC file not rendered correctly in Linux - Bug 80503 
> 6. WMF images in DOC file not rendered correctly from LO 4.4.0 beta2 (tested
> in Win7 64 bit) - it's this new bug (patch available in Bug 80503 for LO
> 4.5.0 doesn't solve this bug)
Comment 2 Timur 2014-12-29 09:12:35 UTC
Screenshot at https://bugs.freedesktop.org/attachment.cgi?id=111295 shows current page 2/8 (due to bug Bug 86468, this content is not on a page 1/7 but 2/8) with missing captions on EMF.
The same problem is on all pages. I'd say it's clear enough. I added "captions" to title.
"Multiple problems with this file" section is referring to *already known or reported issues*.
Comment 3 Timur 2014-12-29 09:15:19 UTC
Tested on Windows 7 x64.
Comment 4 Robinson Tryon (qubit) 2015-01-03 16:09:37 UTC
Created attachment 111689 [details]
LO 4.4.0.1 - Labels, but no graph
Comment 5 Robinson Tryon (qubit) 2015-01-03 16:15:34 UTC
(In reply to Timur from comment #2)
> Screenshot at attachment 111295 [details] shows
> current page 2/8 (due to bug Bug 86468, this content is not on a page 1/7
> but 2/8) with missing captions on EMF.

TESTING with 4.4.0.1 on Ubuntu 14.04, I see labels, but no graph: attachment 111689 [details]

So I disagree with the Summary of the bug.

I see roughly the same thing with 4.4.0.0.beta1, so I'm not sure about the 'regression' part, but it's a bug, so
Status -> NEW
Comment 6 Timur 2015-01-12 15:12:07 UTC
(In reply to Robinson Tryon (qubit) from comment #5)
> TESTING with 4.4.0.1 on Ubuntu 14.04, I see labels, but no graph: attachment
> 111689 [details]
I'd say it's because of different Linux-only Bug 80503. Once that's solved, please try again, to see whether this one is Windows only, or general bug. Thanks.
Comment 7 Robinson Tryon (qubit) 2015-03-31 16:22:54 UTC
(In reply to Timur from comment #6)
> (In reply to Robinson Tryon (qubit) from comment #5)
> > TESTING with 4.4.0.1 on Ubuntu 14.04, I see labels, but no graph: attachment
> > 111689 [details]
> I'd say it's because of different Linux-only Bug 80503. Once that's solved,
> please try again, to see whether this one is Windows only, or general bug.

Tentatively adding bibisectRequest to Whiteboard. Hopefully we'll get traction after dependency bugs are resolved...
Comment 8 Timur 2015-05-18 12:02:56 UTC
Captions on EMF image on page 2/8 (should be 1/7) in DOC file open correctly. 
Images on page 3/8 are the same now as they were in LO 4.4.0 beta 1, meaning they are not open correctly, but that's another bug.
Tested with 4.4.3.
Comment 9 Robinson Tryon (qubit) 2015-12-17 08:42:37 UTC Comment hidden (obsolete)