Bug 90456 - Check for updates on Windows release builds responding "... up to Date"
Summary: Check for updates on Windows release builds responding "... up to Date"
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
4.3.5.2 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 116906 126472 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-04-04 17:46 UTC by V Stuart Foote
Modified: 2019-07-19 19:21 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description V Stuart Foote 2015-04-04 17:46:55 UTC
LibreOffice 4.4.0.3,  4.4.1.2 are not offering 4.4.2.2 build on Windows when running "Check for updates"

Also, rolled back and clean installed 4.3.5.2, and 4.3.6.2 (nor a 4.4 build) was not being offered.

@Cloph, @Andras 
Is this simply a repeat of issues in bug 84441 #c19?
Comment 1 M Henri Day 2015-04-04 18:03:51 UTC
I can confirm the bug reported by Stuart above....

Henri
Comment 2 V Stuart Foote 2015-04-04 18:20:29 UTC
Also filed to Redmine Infrastructure, if that is preferred.

https://redmine.documentfoundation.org/issues/1210
Comment 3 Pedro 2015-04-04 19:56:26 UTC
The server is reporting 4.2.8 as the latest available (it's easy to check with LibreOffice 3.6.7 Portable)
So any version newer than that is reported as up-to-date.
Comment 4 Andras Timar 2015-04-04 20:04:16 UTC
(In reply to Pedro from comment #3)
> The server is reporting 4.2.8 as the latest available (it's easy to check
> with LibreOffice 3.6.7 Portable)
> So any version newer than that is reported as up-to-date.

No. 4.2.8 is the latest 'stable'. From 4.3.x you'd be updated to 4.3.5. No idea why this update.php is not updated regularly. Thanks for reporting it to Redmine, Stuart.
Comment 5 Matthew Francis 2015-04-06 09:41:19 UTC
LibreOffice itself appears to be behaving correctly based on the information provided to it, so this isn't a bug of the Product "LibreOffice".

As the cause is in server infrastructure, as discussed above, I'd suggest that the Redmine issue is the right place to represent this, and this bug can be closed.

-> RESOLVED NOTABUG (...in LibreOffice itself)
Comment 6 Christian Lohmaier 2015-04-07 09:44:29 UTC
hasn't been updated, as 4.4.0 had a regression re saving pw-protected documents with images that could lead to data-loss.

and you're only cross-updated (from x.y.z to x.y+1.u) if u>=z
Comment 7 V Stuart Foote 2015-04-07 13:08:10 UTC
(In reply to Christian Lohmaier from comment #6)
> hasn't been updated, as 4.4.0 had a regression re saving pw-protected
> documents with images that could lead to data-loss.
> 
> and you're only cross-updated (from x.y.z to x.y+1.u) if u>=z

OK, that explains it. But not sure that we should have reached the 4.4.2 (x.y.z) release and still have it not offering updates within the 4.4 branch.

Also, would suggest that a more rational logic for "offering" the cross-update, e.g. x.y.z -> x.y+1.u, should be if u >= z-2.  A u>=z seems too conservative.
Comment 8 V Stuart Foote 2015-04-07 13:30:20 UTC
Also, whats happening on the 4.3 side? Seems like a 4.3.5 < should be offering 4.3.6. 

And of course with existing logic, 4.2.8 can now never get a cross update notice.

p.s.
@Cloph, do you want this here or in Redmine?
Comment 9 A (Andy) 2015-04-09 19:24:30 UTC
Also for me reproducible with LO 4.4.1.2, Win 8.1.  I had this problem already in the past several times with previous LO releases (I thought I had also opened a bug for this in the past, but I could not find it).
Comment 10 V Stuart Foote 2015-04-20 15:32:28 UTC
Per https://redmine.documentfoundation.org/issues/1210 check.php configuration has been updated, setting this resolved fixed.

But still, may need some logic adjustment for "offering" the cross-update, e.g. x.y.z -> x.y+1.u, should be if u >= z-2.

A u>=z seems too conservative. 

Especially given that the updates remain manual decisions by the users.
Comment 11 V Stuart Foote 2018-04-09 18:27:43 UTC
*** Bug 116906 has been marked as a duplicate of this bug. ***
Comment 12 V Stuart Foote 2018-04-09 18:50:00 UTC
(In reply to V Stuart Foote from comment #11)
> *** Bug 116906 has been marked as a duplicate of this bug. ***

Added latest to Redmine as https://redmine.documentfoundation.org/issues/2594
Comment 13 V Stuart Foote 2019-07-19 19:21:30 UTC
*** Bug 126472 has been marked as a duplicate of this bug. ***