Bug 80110 - UPDATE: get 'checking for an update failed' error when checking for updates
Summary: UPDATE: get 'checking for an update failed' error when checking for updates
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.3.0.0.beta2
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL: http://cgit.freedesktop.org/libreoffi...
Whiteboard:
Keywords:
: 96956 (view as bug list)
Depends on:
Blocks: Updates
  Show dependency treegraph
 
Reported: 2014-06-16 21:46 UTC by Yousuf Philips (jay) (retired)
Modified: 2018-10-23 19:59 UTC (History)
9 users (show)

See Also:
Crash report or crash signature:


Attachments
the check for updates dialog (18.92 KB, image/png)
2014-06-16 21:46 UTC, Yousuf Philips (jay) (retired)
Details
Proposal for an alternative update dialog (50.88 KB, image/png)
2016-01-19 11:11 UTC, Heiko Tietze
Details
updte check 5.0.1.2 offering 5.0.3 (56.31 KB, image/png)
2016-01-19 14:32 UTC, V Stuart Foote
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2014-06-16 21:46:35 UTC
Created attachment 101199 [details]
the check for updates dialog

When opening the check for updates dialog in 4.2.5, and 4.3 beta 2, the error message presented needs to be changed in my opinion. Presently the dialog shows 'Checking for an update failed' and 'Could not establish Internet connection to update.libreoffice.org'.

Tested Linux and Windows.
Comment 1 retired 2014-06-16 21:47:57 UTC
Confirmed on OSX as well with 4.3b2 -> NEW.
Comment 2 QA Administrators 2015-07-18 17:43:07 UTC Comment hidden (obsolete)
Comment 3 Lloyd 2016-01-09 15:28:20 UTC
*** Bug 96956 has been marked as a duplicate of this bug. ***
Comment 4 Lloyd 2016-01-09 15:34:36 UTC
This occurred for me with versions 5.0.3.2 and 5.0.4.2 (the latest installed Jan 4 2016) and still occurs today Jan 9.
Comment 5 Dmytro Lapshyn 2016-01-16 18:28:27 UTC
Also reproducible on LibreOffice 5.0.4.2 (x64), Windows 8.1
Comment 6 Yousuf Philips (jay) (retired) 2016-01-19 09:27:20 UTC
Would be good to get dev and ux input on this.
Comment 7 Heiko Tietze 2016-01-19 11:10:49 UTC
What an ugliness ;-). 

From usability POV error messages have to be specific, actionable, and user-centered. Users should either perform an action or change their behavior as the result of the message. He or she should be informed about the reason for a problem and get help on how to solve the problem. The message has to be phrased clearly, in non-technical terms and without obscure error codes. In respect the the multistage updating process the dialog should also be more verbose on the progress (which is also informative regarding the reason for an error).
Comment 8 Heiko Tietze 2016-01-19 11:11:35 UTC
Created attachment 122077 [details]
Proposal for an alternative update dialog

The attached mockup intends to support discussion. It has a nice image/logo on the left (took just some picture from the web), a title, a progress with success info, and if there is an error the message below including details. I also suggest to add some reasons how to solve the problem. The text needs obviously much more work, it's just a quick example here.
Comment 9 V Stuart Foote 2016-01-19 14:32:08 UTC
Created attachment 122084 [details]
updte check 5.0.1.2 offering 5.0.3

The dialog is a little terse.

Attaching a clip from the 5.0.1.2 being offered 5.0.3.2

For doing something like Heiko's mockup, it looks like additional states and informative strings could be implemented in the updatehdl source:

http://opengrok.libreoffice.org/xref/core/extensions/source/update/check

More problematic than just the minimalistic dialog which should probably be enhanced, is that the update check when run manually is no longer connecting, it did -- I think jbf's bug 97175 is related.

On the same 5.0.1.2 install, if I clear profile, and check for updates it fails. So the update check was working, but now is failing--so there is an infrastructure issue.
Comment 10 Pedro 2016-01-19 14:49:06 UTC
(In reply to V Stuart Foote from comment #9)
> Created attachment 122084 [details]
> updte check 5.0.1.2 offering 5.0.3
> 
> The dialog is a little terse.
> 
> Attaching a clip from the 5.0.1.2 being offered 5.0.3.2

This has been reported since 2012...
https://bugs.documentfoundation.org/show_bug.cgi?id=46354#c8
Comment 11 V Stuart Foote 2016-01-19 17:35:12 UTC
(In reply to Pedro from comment #10)
> (In reply to V Stuart Foote from comment #9)
> > Created attachment 122084 [details]
> > updte check 5.0.1.2 offering 5.0.3
> > 
> > The dialog is a little terse.
> > 
> > Attaching a clip from the 5.0.1.2 being offered 5.0.3.2
> 
> This has been reported since 2012...
> https://bugs.documentfoundation.org/show_bug.cgi?id=46354#c8

Nope, that is not a problem here. Personally, I've no issue with showing the x.y.z label in the recent stanza of the dialog (the code is in the linked update.php URL above).

Rather, the issue here, is that we are no longer correctly connecting to the TDF update server.

An install that worked correctly before--has stopped connecting, and we get a unintelligible "checking for update failed" message. Also, that the dialog is uninformative as to why and could use some dev attention especially as with bug 95183 and bug 95184 it has broken badly for Windows XP users (a libcurl change).
Comment 12 Christian Lohmaier 2016-01-21 15:32:34 UTC
FYI: the check failed message recently was due to php not running on the server, so LO got php-sourcecode of the update-script instead of the actual reply
Comment 13 V Stuart Foote 2016-01-21 16:08:12 UTC
(In reply to Christian Lohmaier from comment #12)
> FYI: the check failed message recently was due to php not running on the
> server, so LO got php-sourcecode of the update-script instead of the actual
> reply

Yep, confirming it is back in service, and responding for the 5.0.1.2 install as in comment 11. Thank you @Cloph

From the UX perspective, the dialog could provide additional feedback--even if static strings. At least to show where in the process the dialog has reached.
Comment 14 Alex Thurgood 2017-02-03 11:09:47 UTC
*** Bug 105706 has been marked as a duplicate of this bug. ***
Comment 15 QA Administrators 2018-10-23 02:50:09 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present with the latest version of LibreOffice from https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the information from Help - About LibreOffice.
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a comment that includes the information from Help - About LibreOffice.

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not 
appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so:
1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3) from http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug
3. Leave a comment with your results.
4a. If the bug was present with 3.3 - set version to 'inherited from OOo';
4b. If the bug was not present in 3.3 - add 'regression' to keyword


Feel free to come ask questions or to say hello in our QA chat: https://kiwiirc.com/nextclient/irc.freenode.net/#libreoffice-qa

Thank you for helping us make LibreOffice even better for everyone!

Warm Regards,
QA Team

MassPing-UntouchedBug