Bug 90611 - Footnote font size imported incorrectly
Summary: Footnote font size imported incorrectly
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.0.0.alpha0+ Master
Hardware: Other All
: medium normal
Assignee: Miklos Vajna
URL:
Whiteboard: target:5.1.0 target:5.0.0.3 target:4.4.6
Keywords: bibisected, bisected, regression
: 84732 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-04-14 13:33 UTC by Matthew Francis
Modified: 2017-06-01 08:48 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Matthew Francis 2015-04-14 13:33:35 UTC
Split from bug 86726

The footnotes of attachment 110037 [details] (bug 86726) have font size 10 in MS Word, but open with font size 11 in writer
Comment 1 Matthew Francis 2015-04-14 13:38:48 UTC
This seems to have begun at the below commit.
Adding Cc: to vmiklos@collabora.co.uk; Could you possibly take a look at this one? Thanks

commit 330b860205c7ba69dd6603f65324d0f89ad9cd5f
Author: Miklos Vajna <vmiklos@collabora.co.uk>
Date:   Wed Sep 4 16:08:49 2013 +0200

    fdo#68787 DOCX import: handle when w:separator is missing for footnotes
    
    There were two problems here:
    
    1) OOXML has no way to explicitly disable the footnote separator, what
    is does is that it omits the <w:separator/> element in that case. We
    didn't parse that previously -- now we do, and if it's missing, the
    separator is disabled.
    
    2) The footnote stream isn't read by the importer, only when the main
    stream references the footnote one, the relevant part of it is parsed.
    At the moment we always parse the first (special, "separator") entry in
    the footnote stream, that may be optimized later if it becomes a
    bottleneck.
    
    Change-Id: Ie588270a212fc90fc41095029a362cfd832b24f8
Comment 2 kba 2015-04-25 22:03:25 UTC
Win7 64bit eng

LO Wersja: 4.4.2.2
Build ID: c4c7d32d0d49397cad38d62472b0bc8acff48dd6
Locale: pl_PL

Footnote font is 11
Comment 3 Commit Notification 2015-07-06 09:58:20 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=519b34300f73b1e08f6194d6ba49d4fc010cf186

tdf#90611 DOCX import: fix missing paragraph style on footnotes

It will be available in 5.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 4 Commit Notification 2015-07-08 11:47:34 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "libreoffice-5-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=16626008162545d3caec72fbffc4c19a79326a74&h=libreoffice-5-0

tdf#90611 DOCX import: fix missing paragraph style on footnotes

It will be available in 5.0.0.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 5 Commit Notification 2015-07-09 09:38:20 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "libreoffice-4-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=6178e1e784b8a7881395972b9e6f0222c012a9b1&h=libreoffice-4-4

tdf#90611 DOCX import: fix missing paragraph style on footnotes

It will be available in 4.4.6.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 6 Robinson Tryon (qubit) 2015-12-17 08:54:56 UTC Comment hidden (obsolete)
Comment 7 Justin L 2017-06-01 08:48:17 UTC
*** Bug 84732 has been marked as a duplicate of this bug. ***