Bug 93789 - text background color not displayed in slide show
Summary: text background color not displayed in slide show
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.0.0.5 release
Hardware: All All
: high major
Assignee: Not Assigned
URL:
Whiteboard: target:6.2.0 target:6.1.0.1 target:6.0.6
Keywords: implementationError
: 95584 95849 96985 101619 101620 112985 113690 114015 (view as bug list)
Depends on:
Blocks: Slide-Show
  Show dependency treegraph
 
Reported: 2015-08-30 22:11 UTC by sirt3k
Modified: 2018-06-17 12:31 UTC (History)
29 users (show)

See Also:
Crash report or crash signature:


Attachments
Text background color lost when showing (34.88 KB, image/png)
2015-11-25 11:34 UTC, roumanet
Details
two-monitor screenshot illustrating the problem (180.05 KB, image/png)
2018-05-01 15:51 UTC, Heinz
Details

Note You need to log in before you can comment on or make changes to this bug.
Description sirt3k 2015-08-30 22:11:28 UTC
Libre Office Impress:
modified text background color in a text frame is not displayed in slide show

Version: 5.0.1.2
Build ID: 81898c9f5c0d43f3473ba111d7b351050be20261
Locale: en-US (en_US.UTF-8)
Linux Mint 17.1


OS details:
RELEASE=17.1
CODENAME=rebecca
EDITION="Cinnamon 64-bit"
DESCRIPTION="Linux Mint 17.1 Rebecca"
DESKTOP=Gnome
TOOLKIT=GTK
NEW_FEATURES_URL=http://www.linuxmint.com/rel_rebecca_cinnamon_whatsnew.php
RELEASE_NOTES_URL=http://www.linuxmint.com/rel_rebecca_cinnamon.php
USER_GUIDE_URL=help:linuxmint
GRUB_TITLE=Linux Mint 17.1 Cinnamon 64-bit
Comment 1 Jean-Baptiste Faure 2015-08-31 05:01:11 UTC
Confirmed in LO 5.0.2.0+ built at home under Ubuntu 15.04 x86-64 with gcc 5.1

No text background available in LO 4.4.

Best regards. JBF
Comment 2 Katarina Behrens (CIB) 2015-09-07 11:13:00 UTC
> No text background available in LO 4.4.

It is available, just not in UI :) (but accessible via UNO ... so ye, for 99.9% of users, not available)
Comment 3 Dr. David Alan Gilbert 2015-10-30 11:26:42 UTC
i confirm this in 5.0.3 on fedora;
steps to reproduce:
  1) Create a new slide show
  2) Click in the 'clock to add text' and replace it with 'Oh hi!'
  3) click and drag to highlight the hi
  4) click on the charater properties->text background dropdown in the properties pane, select a bright red colour (It's shown correctly)
  5) Hit f5 to display - the 'hi' is still white.
Comment 4 Buovjaga 2015-11-17 13:06:45 UTC
*** Bug 95849 has been marked as a duplicate of this bug. ***
Comment 5 roumanet 2015-11-25 11:34:53 UTC
Created attachment 120785 [details]
Text background color lost when showing

Version: 5.1.0.0.alpha1 (x64)
Build ID: 0b48731919433e46e4fda7e5a5ca27c08c28b981
Locale : fr-FR (fr_FR)
windows version from november, 24th
Comment 6 Cor Nouws 2015-12-02 15:01:41 UTC
since the feature text background was introduced recently, I think this can be best marked as an enhancement.
Comment 7 Octavio Alvarez 2016-05-21 22:52:34 UTC
(In reply to Cor Nouws from comment #6)
> since the feature text background was introduced recently, I think this can
> be best marked as an enhancement.

This doesn't make sense.

While it's true that this is not a regression, it is certainly a bug, not an enhancement. Having a feature that doesn't actually work in one of the most important features of the application --slideshows-- it's just a broken feature.
Comment 8 Octavio Alvarez 2016-05-25 01:12:03 UTC
*** Bug 96985 has been marked as a duplicate of this bug. ***
Comment 9 Egor 2016-06-30 12:12:35 UTC
The same issue on:

Version: 5.1.3.2
Build ID: 1:5.1.3~rc2-0ubuntu1~trusty1
CPU Threads: 4; OS Version: Linux 3.16; UI Render: default; 
Locale: ru-RU (en_US.UTF-8)

I believe this is a bug, not an enhancement.
Comment 10 Aron Budea 2016-09-11 01:57:50 UTC
This is now called "highlight color."

Can someone enlighten me what the difference is supposed to be between highlight vs. background color, and what the user expectation would be in this case? (seems like a lot of users expect it to show in presentation mode as well)
Comment 11 Cor Nouws 2016-09-11 05:51:05 UTC
(In reply to Aron Budea from comment #10)
> This is now called "highlight color."
> 
> Can someone enlighten me what the difference is supposed to be between
> highlight vs. background color, and what the user expectation would be in
> this case? (seems like a lot of users expect it to show in presentation mode
> as well)

It's complex, have to look it op myself now and then too ;)
  https://wiki.documentfoundation.org/ReleaseNotes/5.0#Word-compatible_text_highlighting
Comment 12 mechtilde 2016-09-11 08:36:54 UTC
*** Bug 101620 has been marked as a duplicate of this bug. ***
Comment 13 roumanet 2016-09-11 18:00:18 UTC
Well, using this operating mode :
1) open Libreoffice Impress
2) use Text tool and write "Hello" or whatever you want
3) apply enlight tool (in lateral menu, icon just at the right of text color : 
Highlighter pen icon)
4) start the presentation : the Highlighted text become not highlighted.

I don't see why exporting/importing to Microsoft Office option could help in this case.

Thanks (I'm now using LO5.2.0.4, french, bug still here)
Comment 14 Mike Sapsard 2016-10-04 20:18:48 UTC
I am using Linux Mint 18 Cinnamon and LibreOffice 5.2.2.2.

Highlighted text in a text box still loses the highlight when displayed in a slide show.
Comment 15 Nick T 2016-11-10 11:15:32 UTC
This bug is also present in the version of LibreOffice in Ubuntu 16.04 LTS - version 5.1.4.2.

A text highlight colour set on text in a text box does not appear when the slide is shown.

But interestingly if you use the Presenter Console the highlight renders fine in the thumbnails on the Console.

The bug exists both in the autolayout text frames and in ad hoc text boxes added using the text box tool.
Comment 16 Tom B 2017-02-12 14:17:17 UTC
Still present in 5.3.03. This is a particularly annoying bug because there doesn't seem to be another way to set a background colour for a block of text. I've had to resort to drawing boxes, carefully positioning them and setting a background colour on them. Annoying because it means repositioning the box if the text is changed and making sure the font size is identical to the word being overlayed.
Comment 17 Marius Loots 2017-07-29 13:44:02 UTC
Is still present in Impress 5.3.1.2 on Windows 7.

Are there any movement in this regard?
Comment 18 Jean-Baptiste Faure 2017-07-29 14:23:57 UTC
Please, do not change field values without explanation.

Best regards. JBF
Comment 19 Roger 2017-10-04 16:31:45 UTC
This bug is still present with LibreOffice Impress versions 5.3.6.1 (x64) and 5.4.1.2 (32 bit) as of October 4, 2017, both running on Windows 10.

I was embarrassed to have someone to whom I had highly recommended LibreOffice Impress call me to tell me that this bug appeared during a presentation he was giving.  He was using 5.4.1.2 on Windows 10 32 bit.

Because he was using white colored font with black highlighting for emphasis of certain portions of his text (with a light-colored slide background), the "highlighted" text was essentially invisible due to the lack of highlighting.

Because of this incident he is not happy with LibreOffice, and is not happy with me for recommending it as strongly as I did (I was unaware of this issue until he pointed it out to me when he called to express his displeasure with my recommendation).

The highlighting looked fine when he was creating the slides, and it looked fine in the pdf file he created, but it did not work at the one time it needed to work (and would be expected to work), during his presentation.

After his call I tested the functionality of text highlighting here and sure enough the highlighting still does not work during actual presentations, which after all is the one time it should work.  However, everything looks OK with the highlighting both during slide creation and when pdf files are printed. I am using 5.3.6.1 x64 version on Windows 10 64 bit.

The bug was first documented at least 2 years ago.  This seems like the sort of bug that would have been jumped on and corrected quickly when it was first reported.

Except for this issue, I have had no complaints from folks to whom I have strongly recommended LibreOffice over a period of several years, and I have been very happy with LibreOffice as I had not previously done any text highlighting of this sort on my slides.
Comment 20 Martin Holmes 2017-10-12 22:21:40 UTC
Still happening in Version: 5.4.1.2 Build ID: 1:5.4.1~rc2-0ubuntu0.17.04.1~lo0.1.

It would be better to remove the functionality from the GUI rather than have people wrong-footed when they're actually giving their presentation and it doesn't work as expected.
Comment 21 Telesto 2017-10-22 19:49:57 UTC
*** Bug 112985 has been marked as a duplicate of this bug. ***
Comment 22 Glenn Horton-Smith 2017-10-26 03:22:15 UTC
This also happens in 5.0.3.2.  It affects PDF export as well as presentation mode viewing, so there is no workaround that way.   It is very frustrating that loimpress allows the user to change the "text background color" (as it is called in 5.0.3.2), and shows it as being effective in the WYSI(N)WYG editor, so that one only finds out about the bug much later.

In my case, this happened after spending considerable time color coding many slides of feature lists to indicate completion status.

It would be nice to have a fix for this, but if that is not forthcoming any time soon, why not disable the text background / "highlight" feature in loimpress? or at least provide some kind of warning?   I have not looked at the code to see how difficult that would be, but it would help avoid this bad user experience.
Comment 23 Xisco Faulí 2017-10-27 11:09:13 UTC
*** Bug 101619 has been marked as a duplicate of this bug. ***
Comment 24 Giovanni Panozzo 2017-11-05 22:00:38 UTC
Still happening in 5.4.2.2 (x64) win.
Comment 25 Maxim Monastirsky 2017-11-07 12:19:43 UTC
*** Bug 113690 has been marked as a duplicate of this bug. ***
Comment 26 Ken Shirriff 2017-11-09 06:46:48 UTC
This bug (highlight color appears while editing but not during slide show) happened to me on Version: 5.2.6.2, Build ID: a3100ed2409ebf1c212f5048fbe377c281438fdc, CPU Threads: 4; OS Version: Mac OS X 10.13.1; UI Render: default; Locale: en-US (en_US.UTF-8); Calc: group

This happened to me during a presentation. It was rather awkward since the slides didn't make much sense without the highlight colors.
Comment 27 Telesto 2017-11-09 07:46:53 UTC
> This happened to me during a presentation. It was rather awkward since the
> slides didn't make much sense without the highlight colors.

@Buovjaga
Is it possible the raise the priority?
Comment 28 Buovjaga 2017-11-09 15:56:34 UTC
(In reply to Telesto from comment #27)
> @Buovjaga
> Is it possible the raise the priority?

Yes, you have the power to do it. Examine this and decide: https://wiki.documentfoundation.org/images/0/06/Prioritizing_Bugs_Flowchart.jpg
Comment 29 Martin Holmes 2017-11-09 16:54:22 UTC
This is arguably high because it's a broken core function. What's most annoying is that it would be trivial to remove that functionality from the GUI itself, thus sparing users lots of embarrassment; even if the bug is never fixed, that should be done at the very least.
Comment 30 Buovjaga 2017-11-09 17:01:56 UTC
(In reply to Martin Holmes from comment #29)
> This is arguably high because it's a broken core function. What's most
> annoying is that it would be trivial to remove that functionality from the
> GUI itself, thus sparing users lots of embarrassment; even if the bug is
> never fixed, that should be done at the very least.

We discussed this in an email exchange with Telesto.

Note that this is *not* a core function like meant in the flowchart. "Saving doesn't work", "printing doesn't work", "LibreOffice crashes on startup" would be such cases.
Comment 31 Martin Holmes 2017-11-09 17:26:43 UTC
Unfortunately, "user is embarrassed in front of peers and superiors and resolves never to use LO again" doesn't appear on the flowchart. :-)
Comment 32 roumanet 2017-11-09 20:19:21 UTC Comment hidden (no-value)
Comment 33 mattreecebentley 2017-11-09 20:37:39 UTC Comment hidden (no-value)
Comment 34 Dr. David Alan Gilbert 2017-11-09 21:12:07 UTC Comment hidden (no-value)
Comment 35 mattreecebentley 2017-11-09 21:37:36 UTC Comment hidden (no-value)
Comment 36 Telesto 2017-11-24 14:51:52 UTC
*** Bug 114015 has been marked as a duplicate of this bug. ***
Comment 37 Telesto 2018-02-08 16:07:32 UTC
*** Bug 115549 has been marked as a duplicate of this bug. ***
Comment 38 Simon Phipps 2018-02-08 16:11:09 UTC
(In reply to Telesto from comment #37)
> *** Bug 115549 has been marked as a duplicate of this bug. ***

Note that 115549 is a report against LibreOffice Online, and that the report includes an attachment which exhibits the problem.
Comment 39 Regina Henschel 2018-04-04 12:49:19 UTC
*** Bug 95584 has been marked as a duplicate of this bug. ***
Comment 40 Heinz 2018-05-01 15:47:51 UTC
I can also confirm this bug in version 6.0.3.2 on Arch Linux. Will add a two-monitor screenshot illustrating the problem.
Comment 41 Heinz 2018-05-01 15:51:16 UTC
Created attachment 141818 [details]
two-monitor screenshot illustrating the problem
Comment 42 roumanet 2018-05-19 15:00:57 UTC Comment hidden (off-topic)
Comment 43 Buovjaga 2018-05-19 15:11:41 UTC Comment hidden (off-topic)
Comment 44 Florian 2018-06-05 12:43:20 UTC
Same here

Name         : libreoffice-impress
Version      : 6.0.4.2
Release      : Fedora 28 Workstation
Arch         : x86_64
Source       : libreoffice-6.0.4.2-2.fc28.src.rpm
Repo         : @System
Comment 45 Pierre C 2018-06-09 08:59:26 UTC Comment hidden (no-value)
Comment 46 Telesto 2018-06-09 15:35:00 UTC
Adding Michael Meeks to the loop; people get a bit annoyed around here. Having text highlighting available in edit mode but not in presentation mode is quite a (negative) surprise..
Comment 47 Michael Meeks 2018-06-11 08:56:25 UTC
Annoying no doubt; we just need to find a volunteer interested in digging into and fixing this - that's not me I'm afraid.
Comment 48 Commit Notification 2018-06-11 15:37:18 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=a3c95ec45397b146c86a3fa44445c763de99d3a3

rhbz#1589029 tdf#93789 impress not showing text highlight in presentation mode

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 49 Commit Notification 2018-06-12 08:11:49 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=b00ebb587812927a1a8f91b876d00a861cc059e6&h=libreoffice-6-1

rhbz#1589029 tdf#93789 impress not showing text highlight in presentation mode

It will be available in 6.1.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 50 Jean-Baptiste Faure 2018-06-12 14:05:31 UTC
(In reply to Commit Notification from comment #49)
> Caolán McNamara committed a patch related to this issue.
> It has been pushed to "libreoffice-6-1":

Thank you very much for this fix. Verified fixed in
Version: 6.1.0.0.beta1+
Build ID: 0b49e44f9a875ab996e346b3f23a3b6bbc9aee02
Threads CPU : 4; OS : Linux 4.4; UI Render : GL; VCL: gtk3; 
Ubuntu_16.04_x86-64
Locale : fr-FR (fr_FR.UTF-8); Calc: threaded

Best regards. JBF
Comment 51 Dr. David Alan Gilbert 2018-06-12 14:21:59 UTC
This might be worthy of a release-note; some people might get surprised by old slide shows that had background colours set suddenly working.

Thanks Caolán
Comment 52 Commit Notification 2018-06-17 12:31:55 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=761cb908d557b6712e7f2fca77b1b60e14005fe9&h=libreoffice-6-0

rhbz#1589029 tdf#93789 impress not showing text highlight in presentation mode

It will be available in 6.0.6.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.