Bug 97733 - Open GL not draw UI elemnts
Summary: Open GL not draw UI elemnts
Status: RESOLVED DUPLICATE of bug 96546
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.1.0.3 release
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 98102 98109 (view as bug list)
Depends on:
Blocks: VCL-OpenGL
  Show dependency treegraph
 
Reported: 2016-02-11 07:43 UTC by Artem
Modified: 2016-02-25 16:51 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
screenshot (44.30 KB, image/png)
2016-02-11 07:43 UTC, Artem
Details
opengl_device.log (309 bytes, text/plain)
2016-02-23 16:29 UTC, David Payne
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Artem 2016-02-11 07:43:49 UTC
Created attachment 122519 [details]
screenshot

Open GL not draw UI elemnts in 5.1 on Windows XP. Videocard: Nvidia Quadro NVS 140m.
Comment 1 Buovjaga 2016-02-12 17:06:57 UTC
Paste here the contents of
C:\Users\user\AppData\Roaming\LibreOffice\4\cache\opengl_device.log

or whatever the heck the path is in XP.. I've forgotten.

It might be that your card should be in the blacklist, but the blacklist was accidentally left out of the 5.1.0 release.

You could also try with the latest 5.1.x http://dev-builds.libreoffice.org/daily/libreoffice-5-1/Win-x86@62-merge-TDF/current/

Set to NEEDINFO.
Change back to UNCONFIRMED after you have provided more information.
Comment 2 Artem 2016-02-12 17:13:11 UTC
I tried the version 5.0 with OpenGL ON and there everything is ok. I also tried to disable OpenGL 5.1 but this has no effect. Probably not the reason OpenGL.
Comment 3 Buovjaga 2016-02-12 17:16:46 UTC
(In reply to ego.cordatus from comment #2)
> I tried the version 5.0 with OpenGL ON and there everything is ok. I also
> tried to disable OpenGL 5.1 but this has no effect. Probably not the reason
> OpenGL.

Please give us the opengl_device.log anyways.
Comment 4 Buovjaga 2016-02-23 14:26:56 UTC
*** Bug 98109 has been marked as a duplicate of this bug. ***
Comment 5 V Stuart Foote 2016-02-23 14:54:38 UTC
*** Bug 98102 has been marked as a duplicate of this bug. ***
Comment 6 David Payne 2016-02-23 16:29:38 UTC
Created attachment 122918 [details]
opengl_device.log
Comment 7 Michael Meeks 2016-02-24 13:30:00 UTC
Another black-listing issue; this card would be disabled by our black-list; please can you re-test with LibreOffice 5.1.1.2 (out soon).

Thanks =)
Comment 8 Artem 2016-02-25 13:31:06 UTC
(In reply to Michael Meeks from comment #7)
> Another black-listing issue; this card would be disabled by our black-list;
> please can you re-test with LibreOffice 5.1.1.2 (out soon).
> 
> Thanks =)

No! What are you doing? This bug only in Windows XP. Windows 7 and Linux ok on this hardware! I also say: i tried to disable OpenGL 5.1 but this has no effect. Maybe this trouble coused by old Windows XP drivers that NVIDIA discontinued.

I also pasted there my opengl_device.log but where is it? Deleted or bug №2?
Comment 9 Buovjaga 2016-02-25 14:18:54 UTC
(In reply to ego.cordatus from comment #8)
> No! What are you doing? This bug only in Windows XP. Windows 7 and Linux ok
> on this hardware! I also say: i tried to disable OpenGL 5.1 but this has no
> effect. Maybe this trouble coused by old Windows XP drivers that NVIDIA
> discontinued.
> 
> I also pasted there my opengl_device.log but where is it? Deleted or bug №2?

Michael was commenting to David.

Please try pasting your log again.
Comment 10 Artem 2016-02-25 14:32:40 UTC
(In reply to Beluga from comment #9)
> 
> Please try pasting your log again.

Maybe not need to wast your time for this WinXP? Last NVIDIA driver
for WinXP is: 307.83
Release Date: 2013.3.7

[WinXP - opengl_device.log]
DriverVersion: 9.18.13.2009
DriverDate: 4-29-2013
DeviceID: PCI\VEN_10DE&DEV_11FA&SUBSYS_097C10DE&REV_A1
AdapterVendorID: 0x10de
AdapterDeviceID: 0x11fa
AdapterSubsysID: 0x097c10de
DeviceKey: System\CurrentControlSet\Control\Video\{B48B036D-D962-4CD0-A747-9DFBDA3CAABB}\0000
DeviceString: NVIDIA Quadro K4000

[Win7 - opengl_device.log]
DriverVersion: 9.18.13.4192
DriverDate: 10-13-2015
DeviceID: PCI\VEN_10DE&DEV_0429&SUBSYS_20D817AA&REV_A1
AdapterVendorID: 0x10de
AdapterDeviceID: 0x0429
AdapterSubsysID: 0x20d817aa
DeviceKey: System\CurrentControlSet\Control\Video\{4B8F8073-7073-4D9C-9A40-430993C2D0E8}\0000
DeviceString: NVIDIA Quadro NVS 140M
Comment 11 Buovjaga 2016-02-25 14:49:05 UTC
Aha, ok, I thought there were two different persons in this report.. closing as dupe of the black-list issue.

*** This bug has been marked as a duplicate of bug 96546 ***
Comment 12 Artem 2016-02-25 16:21:32 UTC
(In reply to Beluga from comment #11)
> Aha, ok, I thought there were two different persons in this report.. closing
> as dupe of the black-list issue.
> 
> *** This bug has been marked as a duplicate of bug 96546 ***

So my hardware to be blacklisted in future releases? But it worked on any Windows7+ and Linux. Only Windows XP trouble.
Comment 13 V Stuart Foote 2016-02-25 16:51:40 UTC
(In reply to ego.cordatus from comment #12)
> (In reply to Beluga from comment #11)
> > Aha, ok, I thought there were two different persons in this report.. closing
> > as dupe of the black-list issue.
> > 
> > *** This bug has been marked as a duplicate of bug 96546 ***
> 
> So my hardware to be blacklisted in future releases? But it worked on any
> Windows7+ and Linux. Only Windows XP trouble.

As Michael Meeks indicated many changes to OpenGL between 5.0 and 5.1 and the issues with asserting black list blocking actions have been corrected only with the 5.1.1.2 release.

Actual criteria are here:
http://opengrok.libreoffice.org/xref/core/vcl/opengl/opengl_blacklist_windows.xml

As you can see, the Windows 7 and XP drivers you post should be blocked. At 5.1.1.2 release when that happens LibreOffice will close on launch and on relaunch the Tools -> Options -> View "Use OpenGL for all rendering" check box will be unchecked and greyed out.  You can force the OpenGL active--if desired, but YMMV and project won't support any OpenGL issues with otherwise blocked hardware.