Bug 97848 - User interface mostly vanished completely - no docs, no menus (Nvidia card)
Summary: User interface mostly vanished completely - no docs, no menus (Nvidia card)
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.1.0.3 release
Hardware: x86-64 (AMD64) All
: medium critical
Assignee: Not Assigned
URL: http://opengrok.libreoffice.org/xref/...
Whiteboard:
Keywords:
: 98103 (view as bug list)
Depends on:
Blocks: VCL-OpenGL
  Show dependency treegraph
 
Reported: 2016-02-14 11:24 UTC by signup
Modified: 2016-03-04 10:36 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Calc, impress and writer with vanished UI after upgrading from 5.0 to 5.1 (203.54 KB, image/jpeg)
2016-02-14 11:24 UTC, signup
Details
GPU details from sysinfo (1.96 KB, text/plain)
2016-02-23 17:13 UTC, David Payne
Details
opengl device log (309 bytes, text/plain)
2016-02-23 17:15 UTC, David Payne
Details
LibreOffice Display Issue Problem (86.90 KB, image/jpeg)
2016-02-26 04:00 UTC, Harold E Lake Jr
Details
LibreOffice Manual Resize Width to Cause Menu to Appear (104.34 KB, image/jpeg)
2016-02-26 04:01 UTC, Harold E Lake Jr
Details

Note You need to log in before you can comment on or make changes to this bug.
Description signup 2016-02-14 11:24:37 UTC
Created attachment 122635 [details]
Calc, impress and writer with vanished UI after upgrading from 5.0 to 5.1

Many elements of the user interface are completely invisible after upgrading from LibreOffice 5.0 to LibreOffice 5.1.
Yet they are there. I can hover over an invisible and klick on it - the menu shows up. The empty document is there. I type in ABC, press ctrl+a ctrl+c to copy it and it appears in my text editor when pasting it.
Screenshot attached.

I am using Win7 64 bit, an NVIDIA GeForce GTx 770.

Unfortunately with this phenomenon with invisible menus and documents in writer, impress and calc I can't continue to use it and will downgrade to 5.0 again.

As I didn't find any reports on this kind of bug I decided to file one for myself.

Hope you find the problem.
Thanks.
Comment 1 V Stuart Foote 2016-02-14 20:39:36 UTC
Any change if you navigate to Tools -> Options -> View and uncheck the "Use OpenGL for all rendering" button, then restart?

If so, the GPU is unsupported for OpenGL and should be block listed.

And also, please post the "opengl_device.log" from your use cache and copy paste the build details from the Help -> About LibreOffice dialog.
Comment 2 Timur 2016-02-23 07:54:04 UTC
*** Bug 98102 has been marked as a duplicate of this bug. ***
Comment 3 signup 2016-02-23 14:28:37 UTC
Sorry Guys, I didn't forget you - yet this setup takes some time for me to do and I will only be able to do it within the next few days. Maybe Vitalii from the duplicate bug can post the logs quicker.
Comment 4 V Stuart Foote 2016-02-23 14:57:13 UTC
yes please, when possible reinstall and post up your opengl_device.log from your user profile.

if this is a problematic OpenGL GPU/driver block list
suspect this will be duplicate of bug 97733

for now NEEDINFO
Comment 5 Buovjaga 2016-02-23 15:26:53 UTC
To quickly find the location:
C:\Users\User\AppData\Roaming\LibreOffice\4\cache\opengl_device.log
Comment 6 David Payne 2016-02-23 16:26:13 UTC
*** Bug 98103 has been marked as a duplicate of this bug. ***
Comment 7 David Payne 2016-02-23 17:13:28 UTC
Created attachment 122922 [details]
GPU details from sysinfo
Comment 8 David Payne 2016-02-23 17:15:00 UTC
Created attachment 122924 [details]
opengl device log
Comment 9 V Stuart Foote 2016-02-23 19:30:07 UTC
Please see the LibreOffice Opengl driver baseline at the URL above.

Installs where GPU and drivers are failing to meet LO's OpenGL criteria should not allow OpenGL to activate. There was an issue with the configuration which has been corrected, but will not be available before the 5.1.1 release (the 5.1.1.1 rc1 is not patched) See bug 96546

For those with higher end GPUs, update your drivers -- for nVidia that would be beyond the 353.62 (10.18.13.5362) -- and OpenGL should then function correctly on 5.0.5 or 5.1.0.3

Otherwise disable OpenGL from Tools -> Options -> View

When 5.1.1.2 is released, disabling should now be automatic based on the block list. And you would then have to force enable OpenGL.

For OP, still waiting on your opengl_device.log and GPU details.
Comment 10 Harold E Lake Jr 2016-02-26 04:00:17 UTC
Created attachment 122997 [details]
LibreOffice Display Issue Problem

LibreOffice Display Issue Problem
Comment 11 Harold E Lake Jr 2016-02-26 04:01:01 UTC
Created attachment 122998 [details]
LibreOffice Manual Resize Width to Cause Menu to Appear
Comment 12 Harold E Lake Jr 2016-02-26 04:03:31 UTC
I have an HP Envy 700-410XT, Windows 8.1 Pro x64, NVIDIA GForce GTX 745 and also have the following display problem. I have attached two files to assist with debugging this issue.
Thank You
Comment 13 V Stuart Foote 2016-02-26 04:28:49 UTC
(In reply to Harold E Lake Jr from comment #12)
> I have an HP Envy 700-410XT, Windows 8.1 Pro x64, NVIDIA GForce GTX 745 and
> also have the following display problem. I have attached two files to assist
> with debugging this issue.
> Thank You

Thanks, but actually what we would need to be of any use are your driver details and LibreOffice build and status of the OpenGL rendering.

Clip from the Help -> About dialog, and also the content of the opengl_device.log from the cache of your LibreOffice user profile.
Comment 14 Michael Meeks 2016-03-04 10:36:19 UTC
So - another block-list distribution issue I think; the driver:

DriverVersion: 9.18.13.2009
DriverDate: 4-29-2013

is somewhat ancient; we blacklist:

        <entry os="all" vendor="nvidia" compare="less" version="10.18.13.5362"> <!-- 353.62 -->

For nvidea these days. Where the key piece is really the 2009 -> 5362 I think.

ATB.