Download it now!
Bug 102310 - Export: selection should already be checked for PDF if open via Export.. with Selection
Summary: Export: selection should already be checked for PDF if open via Export.. with...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: low trivial
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:pdf
Depends on:
Blocks: PDF-Export
  Show dependency treegraph
 
Reported: 2016-09-20 13:14 UTC by Timur
Modified: 2019-12-04 15:13 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Timur 2016-09-20 13:14:56 UTC
1. Write and mark some text
2. File-Export.. 
3. check Selection
4. choose PDF, 
5. on Save you get PDF options 

Observed: on PDF options default Range is still All, as with File-Export as PDF.., so another click is necessary
Expected: on PDF options default Range is already Selection, if open via Export.. with Selection

Inherited from OO. Similar with Writer and Calc.
Comment 1 Timur 2016-09-20 13:16:31 UTC
This can be tested with LO 5.1 or master, 5.2.1.2 produces unreadable PDF, hopefully already fixed because master works fine.
Comment 2 Aron Budea 2016-09-22 07:14:44 UTC
Confirmed. Maybe low prio.
5.2.1.2 produced fine PDF with some short random gibberish text I tried, the issue you're seeing might be something specific.
Comment 3 QA Administrators 2017-10-30 08:32:08 UTC Comment hidden (obsolete)
Comment 4 QA Administrators 2019-12-03 13:52:52 UTC Comment hidden (obsolete)
Comment 5 Timur 2019-12-04 15:13:31 UTC
This seems to work in Writer in Calc.
Impress can be done in bug 33982.
Test master 6.5+.
Anyone is welcome to also test this.