Bug 104169 - Change the mouse cursor icon when hovering the spreadsheet
Summary: Change the mouse cursor icon when hovering the spreadsheet
Status: CLOSED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium enhancement
Assignee: Sarabjot Singh
URL:
Whiteboard: target:7.2.0
Keywords: difficultyInteresting, easyHack, skillCpp, topicUI
Depends on:
Blocks: Mouse-Cursor
  Show dependency treegraph
 
Reported: 2016-11-25 17:50 UTC by mr.Pablo
Modified: 2021-05-26 13:27 UTC (History)
13 users (show)

See Also:
Crash report or crash signature:


Attachments
Patchset 1 (1013 bytes, image/png)
2021-04-27 10:14 UTC, Heiko Tietze
Details
FatCross cursor PS1 (3.39 KB, image/png)
2021-04-27 15:32 UTC, Sarabjot Singh
Details
How a transparent cross could look like (155.29 KB, image/gif)
2021-05-25 09:40 UTC, Mike Kaganski
Details
Apple Numbers mouse pointer (101.39 KB, image/jpeg)
2021-05-26 09:18 UTC, steve
Details
LO cross mouse pointer on macOS (171.55 KB, image/jpeg)
2021-05-26 09:19 UTC, steve
Details
how it looks on windows (8.42 MB, image/jpeg)
2021-05-26 09:28 UTC, BogdanB
Details

Note You need to log in before you can comment on or make changes to this bug.
Description mr.Pablo 2016-11-25 17:50:34 UTC
This is a feature request. 

The mouse cursor icon could be changed to a 'plus sign' or a 'cross' when we move the mouse over the actual Calc spreadsheet (the squares with numbers), just like in other major Office suites such as MS Excel and Gnumeric.   

In my opinion, this would make Calc feel much more natural and comfortable to use.
Anyone agrees?

Thank you.
Comment 1 tommy27 2016-11-26 05:13:15 UTC
enhancement request. status NEW.
let's see what the UX team thinks about it
Comment 2 Heiko Tietze 2016-12-11 09:31:18 UTC
Gnumeric: plus symbol 
WPS Spreadsheets: plus symbol 
Calligra Sheets: default cursor

The crosshair cursor would be very thin on my Qt-based system.
Comment 3 Eike Rathke 2017-02-07 11:16:55 UTC
I fail to see the actual benefit. Plus, you'll have to change the cursor then whenever
* it leaves the cell area grid
* hovers over a drawing layer object (note caption, drawing, chart, ...)

Personally I think it even looks awkward.. but that just aside.
Comment 4 mr.Pablo 2017-02-07 13:16:34 UTC
"I fail to see the actual benefit." - The spreadsheet would feel more intuitive and natural. There is a reason why they do it in MS Excel and Gnumeric.

"Plus, you'll have to change the cursor then whenever
* it leaves the cell area grid
* hovers over a drawing layer object (note caption, drawing, chart, ...)" - Yes and that can be done with 1 line of code: change line 53 of file fudraw.cxx. Where is says "   aNewPointer ( PointerStyle::Arrow )," change into "    aNewPointer ( PointerStyle::Cross ),"

The problem is that the resulting cross looks too thin and is the same cursor used to drag formulae. So the 'enum PointerStyle' must be exapanded to include a 'FatCross' member that would map onto gtk.gdk.CROSS. Once the 'enum PoyterStyle' is expanded and the cursor GTK, Qt mappings are done, the line 53 on fudraw.cxx would look like this:
"    aNewPointer ( PointerStyle::FatCross ),"
Comment 5 mr.Pablo 2017-02-07 13:38:57 UTC
"The spreadsheet would feel more intuitive and natural. There is a reason why they do it in MS Excel and Gnumeric" I'm sorry my answer can sound a bit rude. I don't want anyone angry over this. This stuff is, after all, subjective.
Comment 6 Heiko Tietze 2017-02-07 13:54:10 UTC
(In reply to nuno360 from comment #4)
> Yes and that can be done with 1 line of code: change line 53 of file
> fudraw.cxx. Where is says "   aNewPointer ( PointerStyle::Arrow )," change
> into "    aNewPointer ( PointerStyle::Cross ),"

Perfect code pointer, feel free to share your patch with the community. If you need support don't hesitate to ask.
Comment 7 Heiko Tietze 2019-03-12 09:32:31 UTC
Removing needsUX. 

Mr.Pablo, do you want to implement it? If so, please make it optional (and off by default) and otherwise I would resolve the ticket as WFM since the interest in this change is very low.
Comment 8 Xisco Faulí 2019-03-20 18:27:45 UTC
@Heiko, do you think we can turn this enhancement into an easyhack? or we don't want to spend resources on this ?
Comment 9 Heiko Tietze 2019-03-21 11:46:41 UTC
Let's keep it alive. Code pointer is in c4, the feature should be optional as of c3 (my opinion too).
Comment 10 mesutcfc 2020-02-25 08:26:44 UTC
Hi Heiko. I am interested this bug. I read all of comment. When i search fudraw.cxx, I saw two of the same file(one in the sd module, the other in the sc module). Then I made changes to the two files in order, as said by mr.pablo.When I made changes to the fudraw.cxx file in the sd module, nothing happened but the cursor changed when I made changes to the fudraw.cxx file in the sc module.

Then i went to ptrstyle.hxx file and i have seen such definitions like this in enum class PointerStyle:

     Cross = css :: awt :: SystemPointer :: CROSS, 

Finally I went to SystemPointer.hdl file from there and i have seen such definitions like this in enum class PointerStyle:

    static const :: sal_Int32 CROSS = (sal_Int32) 5;

Now I think I should make such definitions:

    anewpoint is (pointerstyl A :: fatcross)
    FatCross = css :: awt :: SystemPointer :: FATCROSS,
    static const :: sal_Int32 FATCROSS = (sal_Int32) 72;

Also, I found this icon (https://opengrok.libreoffice.org/xref/core/icon-themes/elementary/cmd/32/basicshapes.cross.png?r=ae882ec4) and thought we could use it.

But despite all my research, I have a few questions I haven't found the answer to:

I want to see how the word cross matches the icon. Where should i look? 

Forgive me for these naive questions but if I can see how an icon is introduced, maybe i can make progress.
Comment 11 Heiko Tietze 2020-02-25 08:36:47 UTC
(In reply to mesutcfc from comment #10)
> When i search fudraw.cxx...

You ask code related questions ideally in the IRC channel. Check our wiki how to connect https://wiki.documentfoundation.org/Development.

> Also, I found this icon
> (https://opengrok.libreoffice.org/xref/core/icon-themes/elementary/cmd/32/
> basicshapes.cross.png?r=ae882ec4) and thought we could use it.

Cursors are not icons. And even when there are functions implemented we should comply with the system look and feel and use what is configured on the OS.

> I want to see how the word cross matches the icon. Where should i look? 

You mean the new cursor? Just start Calc ;-)
Comment 12 Buovjaga 2020-02-25 09:12:26 UTC
(In reply to mesutcfc from comment #10)
> Hi Heiko. I am interested this bug. I read all of comment. When i search
> fudraw.cxx, I saw two of the same file(one in the sd module, the other in
> the sc module). Then I made changes to the two files in order, as said by
> mr.pablo.When I made changes to the fudraw.cxx file in the sd module,
> nothing happened but the cursor changed when I made changes to the
> fudraw.cxx file in the sc module.

If you are unsure about what the modules do, you can always consult the README files in them. The sc modules is for Calc, so relevant to this exact report. One way to examine the READMEs is this page: https://docs.libreoffice.org/
Comment 13 mesutcfc 2020-02-25 20:47:35 UTC
@Heiko and @Buovjaga Thanks for answers. 

    anewpoint is (pointerstyl A :: fatcross)
    FatCross = css :: awt :: SystemPointer :: FATCROSS,
    static const :: sal_Int32 FATCROSS = (sal_Int32) 72;

Except for the above code lines, I have no idea how to implement a new cursor. I need reading code and research somethings. I hope i will fix this :)
Comment 14 mesutcfc 2020-02-28 20:13:14 UTC
I made some changes. They may be irrelevant.
I get an error during the make process, I would be glad if you can guide me.

https://gerrit.libreoffice.org/c/core/+/89744
Comment 15 Heiko Tietze 2020-03-02 15:24:07 UTC
(In reply to mesutcfc from comment #14)
> I made some changes. They may be irrelevant.
> I get an error during the make process, I would be glad if you can guide me.
> 
> https://gerrit.libreoffice.org/c/core/+/89744

Commented on Gerrit
Comment 16 Sarabjot Singh 2021-04-23 19:53:20 UTC
Hi. I want to work on this bug (enhancement) but I am not completely sure about what the task is, as it currently stands. My guess is I have to follow up from Eike’s comment in gerrit about preventing the pointer from changing back to arrow on click (more precisely, after click) (Link - https://gerrit.libreoffice.org/c/core/+/89744/18#message-69a364293a918a9e7f67383d446ba80502bf776f).
The new position of SetPointer calls are now in lines 1911, 1920 and 1951 for MouseButtonUp in sc/source/ui/view/gridwin.cxx. All of these can be changed to
    SetPointer( PointerStyle::FatCross );

I agree with Eike on MouseButtonDown case – it should be remain arrow.
Please correct me if I am wrong somewhere.

Also, to resume work from the point mesutcfc left, I see their patch can be downloaded from gerrit, but then there are multiple (five) options for that and I am not sure which one to take (sorry, I am a novice) and if there is any follow up to be done (after downloading) to get it ready to work. (I read something about cherry picking for older patches on https://wiki.documentfoundation.org/Development/gerrit/SubmitPatch#Cherry_picking_yourself_out_of_trouble).
Comment 17 Buovjaga 2021-04-24 05:11:44 UTC
(In reply to Sarabjot Singh from comment #16)
> Also, to resume work from the point mesutcfc left, I see their patch can be
> downloaded from gerrit, but then there are multiple (five) options for that
> and I am not sure which one to take (sorry, I am a novice) and if there is
> any follow up to be done (after downloading) to get it ready to work. (I
> read something about cherry picking for older patches on
> https://wiki.documentfoundation.org/Development/gerrit/
> SubmitPatch#Cherry_picking_yourself_out_of_trouble).

Use the cherry picking method as described in the wiki section you found. You could then use

git commit --amend --author="Sarabjot Singh <saini.sarabjotsingh@gmail.com>"

and add a line in the commit message:

Co-authored-by: Mesut Çifci <mesutcifci97@gmail.com>

to properly credit Mesut's earlier work.
Comment 18 Sarabjot Singh 2021-04-26 06:24:44 UTC
Hi. Thanks a lot for that.
After changing in "gridwin.cxx", the cursor now stays FatCross after mouse click. But now we have 2 problems:

1. The FatCross cursor hotspot is at top-left of (and thus outside visible) cursor area (it should be at the centre of cross). Mesut adjusted the hotspot in file "vcl/inc/cursor_hotspots.hxx", but that file seems to be only for macOS (though I might be wrong). I have only tested this on Linux but I can't test on another OS.
To correct this, I searched for files with the word "hotspot" in their names and there was no such file. Then I went through a lot of files relating to cursors yesterday but couldn't figure it out. What do I do?

2. The files in which Mesut initially added the FatCross pointer declarations and #includes, they were added at the end of the sequence of their respective sequences.
Do those need to be moved to the position within the sequence where they seem correct, or just let them be?
Comment 19 Sarabjot Singh 2021-04-26 06:57:54 UTC
(Corrections/additions in comment #18)

> I searched for files with the word "hotspot" in their names
> and there was no such file.

...no such file other than the one mentioned.


> 2. The files in which Mesut initially added the FatCross pointer
> declarations and #includes, they were added at the end of the sequence of
> their respective sequences.

For example in "include/vcl/ptrstyle.hxx", "vcl/inc/bitmaps.hlst", "vcl/inc/cursor_hotspots.hxx" and a few others
Comment 20 Heiko Tietze 2021-04-26 07:36:56 UTC
(In reply to Sarabjot Singh from comment #18)
> But now we have 2 problems:

Good place to ask this kind of questions is the mailing list or IRC, see https://wiki.documentfoundation.org/Development
Comment 21 Buovjaga 2021-04-26 18:45:33 UTC
(In reply to Buovjaga from comment #17)
> (In reply to Sarabjot Singh from comment #16)
> > Also, to resume work from the point mesutcfc left, I see their patch can be
> > downloaded from gerrit, but then there are multiple (five) options for that
> > and I am not sure which one to take (sorry, I am a novice) and if there is
> > any follow up to be done (after downloading) to get it ready to work. (I
> > read something about cherry picking for older patches on
> > https://wiki.documentfoundation.org/Development/gerrit/
> > SubmitPatch#Cherry_picking_yourself_out_of_trouble).
> 
> Use the cherry picking method as described in the wiki section you found.
> You could then use
> 
> git commit --amend --author="Sarabjot Singh <saini.sarabjotsingh@gmail.com>"
> 
> and add a line in the commit message:
> 
> Co-authored-by: Mesut Çifci <mesutcifci97@gmail.com>
> 
> to properly credit Mesut's earlier work.

My advice was not complete. New try:

git commit --amend --author="Sarabjot Singh <saini.sarabjotsingh@gmail.com>"

Add the co-author line.
Manually delete the Change-Id line, save and close

Now you can make your own changes and when you do git commit --amend the next time, it will generate a new Change-Id
Comment 22 Sarabjot Singh 2021-04-26 19:03:24 UTC
(In reply to Buovjaga from comment #21)

Thanks a lot for the help. Just submitted the patch:
https://gerrit.libreoffice.org/c/core/+/114679
Comment 23 Heiko Tietze 2021-04-27 10:14:33 UTC
Created attachment 171447 [details]
Patchset 1

This is quite a fat cross :-).
Comment 24 Roman Kuznetsov 2021-04-27 10:28:11 UTC Comment hidden (no-value)
Comment 25 Sarabjot Singh 2021-04-27 15:32:21 UTC
Created attachment 171459 [details]
FatCross cursor PS1

(In reply to Heiko Tietze from comment #23)

Whoa
are you getting exactly this thing?

This what I got.
Comment 26 Heiko Tietze 2021-04-27 15:48:57 UTC
Building on Linux with --enable-kde5, if this makes a difference. Maybe icon theme was Karasa Jaga.
Comment 27 Sarabjot Singh 2021-04-28 10:49:35 UTC
(In reply to Heiko Tietze from comment #26)
> Building on Linux with --enable-kde5, if this makes a difference. Maybe icon
> theme was Karasa Jaga.

Replied on gerrit
Comment 28 Heiko Tietze 2021-05-04 09:08:54 UTC
(In reply to Sarabjot Singh from comment #27)
> Replied on gerrit

No review possible with status WIP. And your patch is also not on my list.

But I can cherry-pick and test, of course, and the cursor has a size of about two cells height. But it is completely white with kf5 and gen, cannot see anything. But it looks good with gtk3. Another issue, probably not worth to fix, is that charts change the cursor to NESW for moving but only after selection. Just hovering over keeps the fat cross.
Comment 29 Sarabjot Singh 2021-05-05 07:38:56 UTC
Thanks for all the help. I think the work is almost complete now, apart from a bit of cleaning (of commented functions).

Its completely ready for review though. I have removed WIP status
Comment 30 Commit Notification 2021-05-18 06:34:38 UTC
Sarabjot Singh committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/40e85aadbff8eaeba20ee6a39ca669d282d91005

tdf#104169 - Change mouse cursor to FatCross in calc spreadsheet

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 31 Timur 2021-05-20 13:31:03 UTC Comment hidden (no-value)
Comment 32 Michael Warner 2021-05-20 18:52:08 UTC
So, I'm aware that normally "me too" type comments are discouraged here. But I feel that I have to counterbalance some of the other opinions that have been expressed by saying that I personally like the fat cross cursor in a spreadsheet, and I am appreciative of the work that Sarabjot and Mesut have been doing to make it an option in LO.
Comment 33 Timur 2021-05-21 06:27:50 UTC
It is useful to know who likes a change and who doesn't. 
But more important is to clarify why change from "some like, some not" to "Some don't, some do", why is this not an option?
Sarabjot, please explain if an option is possible.
Comment 34 Heiko Tietze 2021-05-21 06:54:45 UTC
(In reply to Timur from comment #33)
> Sarabjot, please explain if an option is possible.

Everything is possible, please file a new ticket and CC Sarabjot. Maybe s/he want's to extend his/her work.
Comment 35 Sarabjot Singh 2021-05-21 08:08:00 UTC
(In reply to Michael Warner from comment #32)
> I personally like the fat cross cursor ... and I am appreciative of the work...
Thanks a lot for that Michael :)


(In reply to Timur from comment #33)
> It is useful to know who likes a change and who doesn't...
I understand that every opinion is valuable.
Like Heiko said, everything is possible. One way is adding an option in Tools > Options > LibreofficeDev > View..
Comment 36 Sarabjot Singh 2021-05-21 08:09:11 UTC
Moved from Assignee to CC: Sarabjot Singh
Comment 37 Heiko Tietze 2021-05-21 08:29:58 UTC
(In reply to Sarabjot Singh from comment #36)
> Moved from Assignee to CC: Sarabjot Singh

Keep the credits. This issue is resolved/fixed waiting for the verified tag. And you made it happen! :-)
Comment 38 b. 2021-05-21 16:10:43 UTC
i see that here people have worked with enthusiasm for an improvement of calc, i thank for this effort, but consider the result insufficient.  
1. the cursor now covers what you want to target, you have to guess where you will click,  
2. beauty is a matter of taste, and this 'fatty' gets from me personally a flat 6 (worst school grade in Germany),  
3. if it should be 'copied' from Excel ... did you get the size wrong or forget to think about 4k screens?  
4. it is a - totally unnecessary - break to a well working cursor that users are used to for a long time,  
5. a spreadsheet - for me - is there for working, not for fashionable bells and whistles,  
so I'm glad that it doesn't work and please reverse it as soon as possible,  
  
But if you have practiced now and know where this can be done in the program ... an option with a semi-transparent 'neon-spray-paint-point' following the  mouse like it is used in some youtube videos to ease the tracking of the cursor would be really nice and a real improvement ... 'option'!, not hardwired. !
Comment 39 Sarabjot Singh 2021-05-21 18:39:00 UTC
(In reply to b. from comment #38)
I understand that your cursor suddenly disappeared and you are angry about it. I don't want to argue, but I have to defend my work. And I want to clarify a few things.

> 1. cursor now covers what you want to target, ... guess where you will click,  
The target (hotspot) of cursor is in its exact middle. IMO, what you can select with fat+ is practically almost always bigger than the cursor. 
It changes to a respective precision cursor (Ex. cross, resize) when you hover it over relevant points in spreadsheet - this remains unchanged. On selecting a chart/shape/image/other object, it changes to hand, which is even bigger than the fat +.

> 2. beauty is a matter of taste...
I agree. An implementation of an option to choose would suffice.

> 3. if it should be 'copied' from Excel...
It isn't. To compare with Excel, fat+ is smaller than excel but 1 px "fatter".

> ... did you get the size wrong or forget to think about 4k screens?
No I didn't. The cursor doesn't grow in size on bigger resolutions. It is inside a 17x17px area at all times. The cell to cursor size ratio remains intact and its when you zoom out that cells start becoming smaller. The cursor is actually smaller than all other common cursors.

> 4. it is a - totally unnecessary ... a long time,
In my defence, there are also people who migrate to LO and find the arrow cursor in calc slightly weird (They are used to cross in other spreadsheets). They might be a smaller proportion than those already using LO but they do exist.

> 5. a spreadsheet ... and whistles,
As you said, its a matter of taste!

> so I'm glad that it doesn't work and please reverse it as soon as possible,  
Sorry to disappoint, but it does work :), just not on windows :(. Probably the cursor image is at fault.

> But if you have practiced now and know where this can be done in the program
I learned how and where to implement a cursor, but not how to change the stuff in the options box. It might even be different for each OS, but that aside... I can suggest how to do the rest of the work.

> option with a semi-transparent 'neon-spray-paint-point'...'option'!, not hardwired.
I think what you are talking about is the laser cursor from presentations in google slides. And IMHO, that would look super weird. But doesn't harm me for being just an option. Please create a ticket for it if you want it added.

Again, I don't want to argue and no offence was intended. Just wanted to speak for my work.
As I said, this can be made optional.
Comment 40 b. 2021-05-21 19:56:08 UTC Comment hidden (no-value)
Comment 41 Heiko Tietze 2021-05-22 06:25:24 UTC
(In reply to b. from comment #40)
> 'fat' covers almost two cells in height, and five digits in width in my
> normal view mode on kali linux 4k screen, that's far too much, 

* Please file a new ticket for the HiRes issue. If you can't do a screenshot take a camera picture of the screen. 
* Double-check whether cursor disappear in general after some time. I think it's a OS/DE feature not a bug.
* Discuss making the cursor optional at the respective ticket. Don't flock dead horses here.

* Keep in mind that appreciation is the reward for volunteers. Sarabjot did a great job! And "please reverse it as soon as possible" is rather offensive for someone who spend a good amount of his spare time in this task. (Granted that we all are not native speaker and cultural ambassadors.)
Comment 42 BogdanB 2021-05-22 06:28:19 UTC
It's ok.
Verified in Version: 7.2.0.0.alpha1+ / LibreOffice Community
Build ID: b238522ca121ca8f863fe4d3394ade088a65ad01
CPU threads: 4; OS: Linux 5.8; UI render: default; VCL: gtk3
Locale: en-US (ro_RO.UTF-8); UI: en-US
Calc: threaded
Comment 43 b. 2021-05-23 06:41:54 UTC Comment hidden (no-value)
Comment 44 Buovjaga 2021-05-23 07:15:30 UTC Comment hidden (off-topic)
Comment 45 BogdanB 2021-05-25 04:43:50 UTC
Verified also in Windows.
The cursor is not the same as nice as on Linux, but this bug was about changing the cursor, and it is changed.

Version: 7.2.0.0.alpha1+ (x64) / LibreOffice Community
Build ID: 08e99279226206db8ce83cdebc4cf2994739e90b
CPU threads: 4; OS: Windows 10.0 Build 19042; UI render: Skia/Raster; VCL: win
Locale: ro-RO (ro_RO); UI: en-US
Calc: threaded
Comment 46 Heiko Tietze 2021-05-25 06:22:34 UTC
(In reply to b. from comment #43)
> still no cursor in Windows (7/x64) with ver. from 2021-05-23,  

Double check the version. And if all fails please open a new ticket. Stating the facts is enough, if something is wrong on your system we will find the reason.
Comment 47 Timur 2021-05-25 07:56:16 UTC Comment hidden (no-value)
Comment 48 Sarabjot Singh 2021-05-25 08:35:53 UTC
(In reply to BogdanB from comment #45)
> Verified also in Windows.
> The cursor is not the same as nice as on Linux...
Maybe the cursor image was at fault and it has been changed in this patch
https://gerrit.libreoffice.org/c/core/+/115962. Thats why the different cursor
Checkout this bug: https://bugs.documentfoundation.org/show_bug.cgi?id=142390
Comment 49 Buovjaga 2021-05-25 08:55:17 UTC Comment hidden (off-topic)
Comment 50 Sarabjot Singh 2021-05-25 09:04:47 UTC
(In reply to Timur from comment #47)
> ...Calc imprecise (just try to fix tipyng errors)...
Sir, like I said earlier, it changes to a respective precision cursor for relevant purposes, and likewise to an I-beam cursor when typing.
Could you please check for the same on your system and please report if you notice a case otherwise. (Perhaps create a ticket). Things such as these have not been changed and any such issue is perhaps pre-existing.
I'm really sorry for the mess with the Windows cursor.
Also to note, it doesn't change to the I-beam automatically when you start typing, it changes on moving/clicking the mouse, but that also is pre-existing.
Comment 51 Mike Kaganski 2021-05-25 09:34:20 UTC
I realize that this is off-topic here (I still don't see a dedicated report where it could be correctly discussed), but I just wanted to throw in an idea.  Possibly we could avoid adding yet another option to LO, just making the fat cross be more light-wieight and precise: e.g., make its internals transparent, and ass a hair cross in the middle to allow users to see where precisely the click would happen.
Comment 52 Mike Kaganski 2021-05-25 09:35:14 UTC
Sorry for a typo, of course I intended to type "add".
Comment 53 Mike Kaganski 2021-05-25 09:40:38 UTC
Created attachment 172318 [details]
How a transparent cross could look like
Comment 54 Roman Kuznetsov 2021-05-25 11:48:04 UTC Comment hidden (no-value)
Comment 55 Sarabjot Singh 2021-05-25 21:02:48 UTC Comment hidden (off-topic)
Comment 56 Timur 2021-05-26 06:34:24 UTC
Mike gave a good explanation of cursor size in Windows:
https://bugs.documentfoundation.org/show_bug.cgi?id=142390#c21
Which would now require yet another bug to create icons (and differentiate normal and HiRes).
Comment 57 steve 2021-05-26 09:17:35 UTC Comment hidden (no-value)
Comment 58 steve 2021-05-26 09:18:01 UTC
Created attachment 172347 [details]
Apple Numbers mouse pointer
Comment 59 steve 2021-05-26 09:19:27 UTC
Created attachment 172348 [details]
LO cross mouse pointer on macOS
Comment 60 BogdanB 2021-05-26 09:28:50 UTC
Created attachment 172350 [details]
how it looks on windows

Version: 7.2.0.0.alpha1+ (x64) / LibreOffice Community
Build ID: 08e99279226206db8ce83cdebc4cf2994739e90b
CPU threads: 4; OS: Windows 10.0 Build 19042; UI render: Skia/Raster; VCL: win
Locale: ro-RO (ro_RO); UI: en-US
Calc: threaded
Comment 61 Heiko Tietze 2021-05-26 09:37:55 UTC
May I remind everyone on comment 41. This bug is fixed. Anything else should go into follow-up tickets.
Comment 62 Timur 2021-05-26 09:55:04 UTC Comment hidden (no-value)