Bug 142390 - calc 7.2.0.0.a0+ >2021-05-19, no mouse cursor in cell area
Summary: calc 7.2.0.0.a0+ >2021-05-19, no mouse cursor in cell area
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
7.2.0.0.alpha0+
Hardware: All Windows (All)
: highest critical
Assignee: Mike Kaganski
URL:
Whiteboard: target:7.2.0
Keywords: bibisected, bisected, regression
: 142365 142392 (view as bug list)
Depends on:
Blocks:
 
Reported: 2021-05-20 09:39 UTC by b.
Modified: 2021-05-29 04:30 UTC (History)
10 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description b. 2021-05-20 09:39:09 UTC
Description:
with below ver. the mouse cursor isn't shown in cell area, despite visible in e.g. menu area and frame, and clicking selects cell. 

parallel installation of older versions doesn't have this fail, thus regression. 


Steps to Reproduce:
1. install below ver. 
2. hover around with mouse / touchpad, 
3. see pointer disappearing when entering cell area, 

Actual Results:
no cursor visible, 

Expected Results:
cursor visible, 


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.2.0.0.alpha1+ (x64) / LibreOffice Community
Build ID: 3d36ff1a1d94bcdb6facf12eec00a532b6640880
CPU threads: 8; OS: Windows 6.1 Service Pack 1 Build 7601; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: en-US
Calc:
Comment 1 Timur 2021-05-20 12:47:07 UTC
*** Bug 142392 has been marked as a duplicate of this bug. ***
Comment 2 Timur 2021-05-20 12:48:35 UTC Comment hidden (obsolete)
Comment 3 Timur 2021-05-20 12:50:04 UTC
Please make a short screencast, showing cell area and outside with cursor.
Comment 4 Timur 2021-05-20 13:04:36 UTC
I see that already 3 users had it, but I don't. Did you try with profile reset?

Version: 7.2.0.0.alpha1+ (x64) / LibreOffice Community
Build ID: b1c0734ffe0f395757b6e0cea7830d820231afeb
CPU threads: 8; OS: Windows 6.1 Service Pack 1 Build 7601; UI render: Skia/Raster; VCL: win

I do see a change in Linux, cursor is now fat +. Bibisect:

commit 34a67b502c8a19ea36d86ab4c86aa9d0533941c4
Date:   Tue May 18 08:49:49 2021 +0200
    source sha:40e85aadbff8eaeba20ee6a39ca669d282d91005
    previous sha:2b3879c748adb8d48606339cecaf81a12c19f697

author	Sarabjot Singh <saini.sarabjotsingh@gmail.com>	2020-02-28 22:47:40 +0300
committer	Heiko Tietze <heiko.tietze@documentfoundation.org>	2021-05-18 08:33:31 +0200
commit	40e85aadbff8eaeba20ee6a39ca669d282d91005 (patch)
tree	581f051765db01ac25b6d3426762d1c7b97155ca
parent	2b3879c748adb8d48606339cecaf81a12c19f697 (diff)
tdf#104169 - Change mouse cursor to FatCross in calc spreadsheet
Added new cursor FatCross to calc. Change mouse cursor to
FatCross while hovering over the spreadsheet in calc instead
of earlier Arrow.

Please check yourself.
Comment 5 Timur 2021-05-20 13:27:18 UTC
I see with new LO.
CC: Sarabjot Singh
Comment 6 Xisco Faulí 2021-05-20 14:02:51 UTC Comment hidden (obsolete)
Comment 7 Sarabjot Singh 2021-05-20 16:27:45 UTC
Could anyone confirm 2 things on windows? I cannot test this on windows.

1. Select the clone formatting tool in calc and report if you can see the paint bucket cursor.
Press escape while still in copy formatting mode and cursor over spreadsheet(cell area) and report if and what cursor you see.

2. Go to "vcl/win/src".
Remove "fatcross.cur".
In the same directory, copy and paste (duplicate) any cursor (that is visible in its normal use case, eg, "fill.cur" used in above point).Rename it to "fatcross.cur".
Build.
Report what you see.
(Not to forget, do this in a new branch)
Comment 8 Sarabjot Singh 2021-05-20 16:40:55 UTC
(In reply to Xisco Faulí from comment #6)
> I can't reproduce it in ... OS: Linux 5.7;
Its because the bug is only on windows. All other OS are okay.
I couldn't check this on windows.
Comment 9 Sarabjot Singh 2021-05-20 16:53:31 UTC
For the time being, here's a temporary workaround to make the cursor visible

Open "sc/source/ui/drawfunc/fudraw.cxx "
In line 62
Replace (PointerStyle::FatCross) with (PointerStyle::Arrow)
This will show the arrow cursor majority of times, except for a few situations of mouse clicks.
Comment 10 m.a.riosv 2021-05-20 23:55:08 UTC
Repro with
Version: 7.2.0.0.alpha1+ (x64) / LibreOffice Community
Build ID: 05366b8e6683363688de8708a3d88cf144c7a2bf
CPU threads: 4; OS: Windows 10.0 Build 21382; UI render: Skia/Vulkan; VCL: win
Locale: es-ES (es_ES); UI: en-US Calc: CL
Comment 11 Timur 2021-05-21 06:25:22 UTC
This is critical because it makes Calc unusable without workaround for user. 

(In reply to Sarabjot Singh from comment #7)
> Could anyone confirm 2 things on windows? I cannot test this on windows.
> 
> 1. Select the clone formatting tool in calc and report if you can see the
> paint bucket cursor.
Yes.
> Press escape while still in copy formatting mode and cursor over
> spreadsheet(cell area) and report if and what cursor you see.
No.

I don't build in Windows.
Comment 12 Telesto 2021-05-21 10:04:34 UTC
(In reply to Timur from comment #11)
> This is critical because it makes Calc unusable without workaround for user. 

Only master being affected. So highest critical might outdo it a little for my taste. However no expert on priority's.. so leaving it as is.
Comment 13 steve 2021-05-21 10:28:03 UTC
Confirming fat + instead of mouse pointer arrow with mouse over cell grid on macOS 11.3.1 and main build:

Version: 7.2.0.0.alpha1+ / LibreOffice Community
Build ID: eda109d5d91e82adb675ebf6db952bf6d82b3391
CPU threads: 8; OS: Mac OS X 10.16; UI render: default; VCL: osx
Locale: de-DE (de_DE.UTF-8); UI: en-US
Calc: threaded
Comment 14 b. 2021-05-21 13:16:27 UTC
have seen the fatcross cursor in linux ... not a good idea (IMHO), ugly, and covers the details one wants to see to click onto the right point, 

highlighting the cursor in general is a good idea, esp. for modern LCD or TFT displays or videos where people should follow a cursor with their eyes which they don't have in own control (if you lead the mouse yourself you can get the focus back because you know what your hand is doing, watching videos this feature fails), 

but other appliances use better options for that, e.g. a transparent neon spraypaint-point moving together with the original 'sharp pointing' cursor,
Comment 15 Timur 2021-05-21 13:26:03 UTC
Discussion on cursor is in bug 104169 , here is it missing in Windows.
Comment 16 V Stuart Foote 2021-05-23 16:42:15 UTC
Confirming on Windows 10 (20H2) with HC GrayEve, Windows Dark or default Windows light theme. No difference between LibreOffice Application Color themes (default or dark). No difference both Skia modes, or with CPU rendering.

With https://gerrit.libreoffice.org/c/core/+/114679 applied no cursor is visible 
Windows builds once mouse is pointed onto the sheet table.

Version: 7.2.0.0.alpha1+ (x64) / LibreOffice Community
Build ID: 4a9eef7849a75ba91806886ea9c96d114c8d56f9
CPU threads: 8; OS: Windows 10.0 Build 19042; UI render: default; VCL: win
Locale: en-US (en_US); UI: en-US
Calc: threaded
Comment 17 Timur 2021-05-24 08:51:38 UTC
*** Bug 142365 has been marked as a duplicate of this bug. ***
Comment 18 Mike Kaganski 2021-05-24 09:37:41 UTC
https://gerrit.libreoffice.org/c/core/+/115962
Comment 19 Commit Notification 2021-05-24 10:42:26 UTC
Mike Kaganski committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/abfa48b54307d659dc2f6f890c9855d06f1cbf7d

tdf#142390: fix fatcross cursor on Windows

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 20 Timur 2021-05-25 08:11:47 UTC
Hi Mike. 
While I don't support this change as I wrote in bug 104169, I thank you for making Calc usable again. 
Can you please explain the cursor size? 
Seems to me like it's 2 letters in MSO and in GTK3 but larger, like 3 letters, in Windows.
Comment 21 Mike Kaganski 2021-05-25 08:39:58 UTC
(In reply to Timur from comment #20)
> Can you please explain the cursor size? 
> Seems to me like it's 2 letters in MSO and in GTK3 but larger, like 3
> letters, in Windows.

The visible cursor size depends only on the resource image. The "base" image size is 32x32, and it covers the area larger than size of most typical cursors. So the cursor author uses only part of the area. E.g., Excel uses only 15x15 pixels for its fat cross. Our cursor uses 19x19 pixels, which is about 26% larger in each dimension, and 60% larger in area. IMO, it's just a matter of asking our arts experts to improve the image (if I was asked to create a cursor, I would indeed do a poor job because I'm less than zero in arts, but it's possible and useful to prepare something for those who can then improve existing draft - just make fatcross.cur look great).
Comment 22 Mike Kaganski 2021-05-25 08:43:03 UTC
(In reply to Mike Kaganski from comment #21)
> The "base" image size is 32x32

Note that cursor resource may also contain images of greater resolution, which are used in Hi-DPI environments; as large as 128x128 are present in Excel. In each such image, of course, the relative size of the cursor should stay consistent.
Comment 23 b. 2021-05-25 20:49:09 UTC
i'm fine with any such changes ... if they are an option!
Comment 24 m.a.riosv 2021-05-26 07:29:57 UTC
That cross cursor like in excel, it's a change from other LibreOffice versions where it is the usual arrow. Sorry but I don't like too much this cross cursor.
Comment 25 Mike Kaganski 2021-05-26 07:43:49 UTC
(In reply to b. from comment #23)
(In reply to m.a.riosv from comment #24)

Of course you all realize that your comments are off-topic here, trying to discuss the cross cursor in the issue dedicated to "cursor is not shown" regression. See comment 15 (and even bug 104169 would not be the proper place to discuss now, new bugs are needed, dedicated to specific issues like providing an option, fixing HiDPI, etc.).
Comment 26 V Stuart Foote 2021-05-26 13:28:42 UTC
(In reply to Mike Kaganski from comment #25)
>... new bugs are needed, dedicated to specific issues like
> providing an option, fixing HiDPI, etc.).

Done bug 142499 and bug 142500 respective.