Bug 111392 - Export as image: Calc exports chart as empty PDF (OK with File-Export to PDF)
Summary: Export as image: Calc exports chart as empty PDF (OK with File-Export to PDF)
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
(earliest affected) release
Hardware: All All
: high minor
Assignee: Not Assigned
Keywords: implementationError
: 115509 125158 125558 129644 142406 (view as bug list)
Depends on:
Blocks: PDF-Export
  Show dependency treegraph
Reported: 2017-08-05 09:59 UTC by rl
Modified: 2023-05-24 17:03 UTC (History)
10 users (show)

See Also:
Crash report or crash signature:


Note You need to log in before you can comment on or make changes to this bug.
Description rl 2017-08-05 09:59:21 UTC
1. Open new spreadsheet.
2. To have some data to work with, enter arbitrary numbers into two columns.
3. Select the entered values.
4. Insert → Chart… → Line → Points and Lines → Finish.
5. Make sure that the inserted chart is selected.
6. Chart context menu → Export as image.
7. Enter file name.
8. Select PDF as file type.
9. Save.
10. Check size of the PDF file.

Unexpected result is that the generated PDF file is empty.

Exporting into other formats works fine. However, I have only checked PNG (the default), JPEG and TIFF.

The issue can be reproduced in 
- LibreOffice on macOS 10.12.6
- LibreOffice on Windows 10 v1703
Comment 1 raal 2017-08-05 12:32:13 UTC
I can confirm with Version:
Build ID: e0bafa78e3ad0df397d78cd65ad19bd5b07dc5f2
CPU threads: 4; OS: Linux 4.4; UI render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2017-07-20_22:42:49

Feature added in bug 60137. Tomaz could you take a look? Thank you
Comment 2 Jorge Juan 2017-11-15 10:55:18 UTC
I can confirm with:
Build ID: 1:5.4.3~rc2-0ubuntu0.16.04.1~lo1
CPU threads: 4; OS: Linux 4.10; UI render: default; VCL: gtk2; 
Locale: en-GB (en_GB.UTF-8); Calc: group
Comment 3 Xavier Van Wijmeersch 2017-11-15 19:32:14 UTC
I reproduce with

Build ID: 831dca83f073bca9ad6242f1b96183eb4a49af69
CPU threads: 8; OS: Linux 4.9; UI render: default; VCL: kde4; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2017-11-15_00:06:28
Locale: nl-BE (en_US.UTF-8); Calc: group
Comment 4 Thomas 2018-12-04 12:55:21 UTC

The Problem still occurs in Version: on Windows 7.
Comment 5 Roman Kuznetsov 2019-02-26 07:22:21 UTC
still repro in

Build ID: c57dc7d41bd62f933cffab6131edb7252606382d
CPU threads: 4; OS: Windows 6.1; UI render: default; VCL: win; 
Locale: ru-RU (ru_RU); UI-Language: en-US
Calc: threaded
Comment 6 Roman Kuznetsov 2019-02-26 07:44:35 UTC
*** Bug 115509 has been marked as a duplicate of this bug. ***
Comment 7 raal 2019-05-07 16:52:41 UTC
*** Bug 125158 has been marked as a duplicate of this bug. ***
Comment 8 raal 2019-05-28 16:51:24 UTC
*** Bug 125558 has been marked as a duplicate of this bug. ***
Comment 9 raal 2019-05-28 17:37:41 UTC
PDF export was added in this commit, but it never worked in calc's charts.

author	Miklos Vajna <vmiklos@collabora.co.uk>	2016-06-24 13:00:46 +0200
committer	Miklos Vajna <vmiklos@collabora.co.uk>	2016-06-24 11:51:01 +0000
commit 7d76bb251e0c88ff17282a33b801a5d17a434af5 (patch)
tree 927e5ff1968764b40b070dca8e6aae8b3e9d25ce
parent 47443d720d5f2bee0993222fd6383a59056d8591 (diff)
vcl: add graphic export-as-pdf filter
In case the metafile was imported from a PDF originally, then this
allows storing the PDF stream next to the graphic. This means that e.g.
in Writer choosing 'Save' from the context menu of the graphic can write
the original PDF stream, not the replacement metafile.
Comment 10 Timur 2020-06-12 08:26:38 UTC
*** Bug 129644 has been marked as a duplicate of this bug. ***
Comment 11 Timur 2021-05-21 10:48:23 UTC
*** Bug 142406 has been marked as a duplicate of this bug. ***
Comment 12 lrdarknesss 2021-11-11 11:00:39 UTC
I can confirm that this bug still exists. 
Just tried to export a chart as PDF, it still results in a 0 byte file.
Comment 13 narek.andreasyan 2021-11-23 22:56:19 UTC
On the charts export as image -> save as PDF is not working, created zero file for the version (x64) under Windows 10 Education 21H1.

Alternative also not working correctly. Select the chart, then File -> Export as PDF... -> With Options Selection/Selected sheets and Lossless Compression, the chart is divided in many pages. Is there a possibility to export the charts in one page?
Comment 14 narek.andreasyan 2021-11-23 23:12:40 UTC Comment hidden (obsolete)
Comment 15 Paris Oplopoios 2022-12-14 22:18:48 UTC
Could not reproduce with:

Version: (X86_64) / LibreOffice Community
Build ID: 3c2effa9057ab51c2cfff72673e1e4512d025b23
CPU threads: 12; OS: Linux 6.0; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded
Comment 16 Justin L 2023-05-24 17:03:39 UTC
fixed in LO 7.4 with commit 77d2bbaa18e0be5347d7bd7167b245264789e0a4
Author: Miklos Vajna on Tue Jan 4 16:28:03 2022 +0100
    sc export chart as graphic: handle PDF