Bug 112221 - LOCALHELP Update Customize dialog documentation to the new design
Summary: LOCALHELP Update Customize dialog documentation to the new design
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Documentation (show other bugs)
Version:
(earliest affected)
6.0.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.1.0
Keywords:
: 107758 (view as bug list)
Depends on: 114701
Blocks: HelpGaps-NewFeatures
  Show dependency treegraph
 
Reported: 2017-09-05 07:01 UTC by Gabor Kelemen (allotropia)
Modified: 2021-05-06 19:45 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gabor Kelemen (allotropia) 2017-09-05 07:01:44 UTC
The results of the 2017 GSoC project about revamping the Customize dialog have been merged:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=d69f9436b59e249af8dcac88ccadf09b920b1bab
and see the other patches from the same author.

We have some existing documentation for this window, which probably needs an overhaul now. Quoting bug#107758 these pages are:

Customize article
http://opengrok.libreoffice.org/xref/help/source/text/shared/01/06140000.xhp

Menu article
http://opengrok.libreoffice.org/xref/help/source/text/shared/01/06140100.xhp

Keyboard article
http://opengrok.libreoffice.org/xref/help/source/text/shared/01/06140200.xhp

Toolbars article
http://opengrok.libreoffice.org/xref/help/source/text/shared/01/06140400.xhp

Events article
http://opengrok.libreoffice.org/xref/help/source/text/shared/01/06140500.xhp
Comment 1 Buovjaga 2017-09-09 18:38:24 UTC
Setting to NEW.

It's on the agenda for the Getting Started guide for next week: https://listarchives.libreoffice.org/global/documentation/msg11744.html
Comment 2 Muhammet Kara 2017-12-04 12:20:25 UTC
From the 6.0 release notes:
---
It is now easier than ever to customize LibreOffice UI based on your needs, thanks to improved user experience and accessibility of the newly reworked Customize dialog (Tools ▸ Customize...). tdf#88896 (Muhammet Kara (Pardus), GSoC 2017; Katarína Behrens (CIB); Heiko Tietze; Yousuf Philips)

    The Menus, Toolbars, and Context Menus tabs have been revamped to provide a modern and intuitive design which is highly accessible and user friendly.
    With the well-established two-pane design of the revamped dialog, it is possible to customize toolbars, menus, and context menus following a nice work-flow, without leaving the dialog.
    A search box has also been introduced to filter the functions which can be assigned to UI elements, so you can easily and quickly find exactly what you are looking for without navigating through a list of too many categories and functions. The Keyboard tab has also got the new search box. tdf#63966
    Last but not least improvement is the cleaned-up and re-factored code under the hood, which eliminates some bugs of the past and prepares for the features of the future.
---

A few notes on the new workflow for the revamped tabs (Menus, Toolbars, Context Menus):
- The functions which can be added to the selected toolbar/menu are listed in the box on the left
- The functions which are already included are listed in the box on the left
- To Add: Select a function on the left, and click the add button (right-arrow in the middle)
- To Remove: Select a function on the right and click the remove button (left-arrow)
- If user types something in the search/filter box on the top, the functions in the left-box are filtered as user types
- Both the "category" listbox and the functions box respond to key presses, and jumps through entries by key presses
- Styles and Macros are presented in a tree-like view in the functions box.
- Search/filter feature also works for styles and macros; non-maching functions and empty sub-categories/sub-trees are filtered out as user types
- Sub-trees of macros come collapsed at the beginning, and expands automatically if user types something in the search box
- Description of the selected function is displayed under the functions box
Comment 3 Olivier Hallot 2017-12-26 17:10:29 UTC
*** Bug 107758 has been marked as a duplicate of this bug. ***
Comment 4 Olivier Hallot 2017-12-26 17:23:13 UTC
The revamped dialogs miss (IMHO) a label for the drop-down boxes on the right part of the dialog.

"Location"  for [%PRODUMCTNAME <module> ; <file>] drop-down

"Menu" for the drop-down containing all menus / context menus / Toolbars

I also demand to replace the "+" and "-" icons with textual "Add" and "Delete" buttons.

See Bug#114701.
Comment 5 Commit Notification 2017-12-27 15:23:27 UTC
Olivier Hallot committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=f84e3a174753b28c141d117082c574a8defd4eed

tdf#112221 Help page for context menu cust'zation
Comment 6 Xisco Faulí 2018-09-12 12:17:37 UTC
A polite ping to Olivier Hallot:
Is this bug fixed? if so, could you please close it as RESOLVED FIXED ? Otherwise, Could you please explain what's missing?
Thanks
Comment 7 Robert Großkopf 2019-03-17 14:23:41 UTC
Seems there has nothing been fixed yet. I get an empty "Description"-field in Customize > Toolbars and the tip-help says: "Local help is not installed." - but it's installed.

Or do I misunderstood this bug and found another bug?
Comment 8 Robert Großkopf 2019-03-17 16:24:06 UTC
(In reply to Robert Großkopf from comment #7)
> Seems there has nothing been fixed yet. I get an empty "Description"-field
> in Customize > Toolbars and the tip-help says: "Local help is not
> installed." - but it's installed.
> 
> Or do I misunderstood this bug and found another bug?

Isn't the right bug - I have created a new one for the new help: bug 124130