Bug 119141 - This version is unable to retrieve data from a webpage (link external data)
Summary: This version is unable to retrieve data from a webpage (link external data)
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.0.6.2 release
Hardware: All All
: high critical
Assignee: Justin L
URL:
Whiteboard: target:6.2.0 target:6.1.1 target:6.0.7
Keywords: bibisected, bisected, regression
: 119208 119306 119336 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-08-07 12:15 UTC by Fabio
Modified: 2018-10-10 10:22 UTC (History)
11 users (show)

See Also:
Crash report or crash signature:


Attachments
bug sample - saved by rel. 6.0.5.2 (ok) (19.04 KB, application/vnd.oasis.opendocument.spreadsheet)
2018-08-08 11:03 UTC, Fabio
Details
bug sample - saved by rel. 6.0.6.2 (ko) (9.49 KB, application/vnd.oasis.opendocument.spreadsheet)
2018-08-08 11:06 UTC, Fabio
Details
alternate patch - use local range names with web page query (2.11 KB, patch)
2018-08-13 11:21 UTC, Justin L
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Fabio 2018-08-07 12:15:34 UTC
this version is unable to retrieve data from a webpage .
using the function : sheet/link external data, no areas or table are loaded.
I had to rollback to version 6.0.5.2  to restore this function.
Also the version 6.1.0 have the same issue, i have tested it, before  rollback to 6.0.5.2.
Ty

p.s.
the web page i try to load is:
http://www.borse.it/fondi/quotazione/HSBC-GIF-Emerging-Wealth-A-EUR/HSBC-GIF-Emerging-Wealth-A-EUR__LU0309123817.EUR/?refresh_cens
Comment 1 Xisco Faulí 2018-08-07 18:48:17 UTC
Thank you for reporting the bug. Please attach a sample document, as this makes it easier for us to verify the bug. 
(Please note that the attachment will be public, remove any sensitive information before attaching it. 
See https://wiki.documentfoundation.org/QA/FAQ#How_can_I_eliminate_confidential_data_from_a_sample_document.3F for help on how to do so.)

I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' once the requested document is provided.
Comment 2 Fabio 2018-08-08 11:03:57 UTC
Created attachment 144025 [details]
bug sample - saved by rel. 6.0.5.2 (ok)

ok file
Comment 3 Fabio 2018-08-08 11:06:07 UTC
Created attachment 144026 [details]
bug sample - saved by rel. 6.0.6.2 (ko)

ko file
Comment 4 Fabio 2018-08-08 11:13:12 UTC
hi, I prepared two files, one saved using rel. 6.0.5.2 (ok) and the other saved using rel 6.0.6.2.(ko)
If you open the "ok" file with 6.0.6.2, you  update the links, it become like the "ko" file.
if you open the "ko" file with 6.0.5.2, you update the links, it become like the "ok" file.
Thanks
Comment 5 m.a.riosv 2018-08-08 23:13:35 UTC
Reproducible the issue:
Version: 6.0.6.2 (x64)
Build ID: 0c292870b25a325b5ed35f6b45599d2ea4458e77
CPU threads: 4; OS: Windows 10.0; UI render: GL; 
Locale: es-ES (es_ES); Calc: CL
Comment 6 m.a.riosv 2018-08-09 00:09:56 UTC
Not possible to add a new external link either for web pages or html files.
Seems a critical bug that brakes the use of files with this kind of external links.
Comment 7 Aron Budea 2018-08-09 06:11:31 UTC
Mark bug as regression, since this used to work.
Comment 8 Aron Budea 2018-08-09 07:10:46 UTC
Bibisected to the 6.1 backported commit originating from the following one, using repo bibisect-win32-6.1. Adding Cc: to Justin Luth, please take a look sometimes.

https://cgit.freedesktop.org/libreoffice/core/commit/?id=5720c85ccea9f1481bd604b806c5be728e59a13f
author		Justin Luth <justin.luth@collabora.com>	2018-06-05 19:30:58 +0300
committer	Eike Rathke <erack@redhat.com>	2018-06-11 23:20:50 +0200

tdf#114487 sc htmlimp: non-global sheet range names
Comment 9 Justin L 2018-08-09 13:52:28 UTC
Just reverting seems like the best recourse for stable.

Another possible fix in arealink.cxx is:
    if (!bFound)
    {
        pNames = pSrcDoc->GetRangeName(rRange.aStart.Tab());
        const ScRangeData* p = pNames ? pNames->findByUpperName(aUpperName) : nullptr;
        if (p && p->IsValidReference(rRange))
            bFound = true;
    }

However, we still have a UI problem where Edit - Links to External Files... doesn't list the local tabs. So trying to fix all that seems a bit too extreme to push to stable - thus my suggestion to simply revert. https://gerrit.libreoffice.org/58761
Comment 10 m.a.riosv 2018-08-10 20:42:09 UTC
*** Bug 119208 has been marked as a duplicate of this bug. ***
Comment 11 m.a.riosv 2018-08-12 11:36:35 UTC
The patch to reverted, is not on master.
Version: 6.2.0.0.alpha0+ (x64)
Build ID: 82b12d836582c2dccc5f438363c9d128e85ac656
CPU threads: 4; OS: Windows 10.0; UI render: default; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-08-12_03:30:11
Locale: es-ES (es_ES); Calc: CL

Needs to be back ported ASAP to 6.0 and 6.1. Both have just public released with this issue.

https://ask.libreoffice.org/en/question/162643/link-to-external-data-doesnt-work/
Comment 12 Justin L 2018-08-13 11:21:07 UTC
Created attachment 144140 [details]
alternate patch - use local range names with web page query

(In reply to Justin L from comment #9)
> However, we still have a UI problem
This alternate fix allows Edit->Links to External Files to see the local range names that were created. But the use of ScAreaLink seems to be pretty widespread, so I don't know what the implications would be on other areas. Also, external data in other contexts seems to also refer to global names only. A simple revert still seems to be the best course of action.

I tested if manually creating a global named range (HTML_all) could be a workaround, but the current spreadsheet content is not considered. A separate document is being created in the background it seems.
Comment 13 Commit Notification 2018-08-15 10:02:42 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=1597dbb5ba5d68b5807236c1d045f5215f221c91

tdf#119141 Revert "sc htmlimp: non-global sheet range names"

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 Commit Notification 2018-08-15 12:59:36 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f4b83b45a43d635082f8b9d765f9522fad4e467f&h=libreoffice-6-1

tdf#119141 Revert "sc htmlimp: non-global sheet range names"

It will be available in 6.1.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 15 Commit Notification 2018-08-15 12:59:57 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "libreoffice-6-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=8b2b2010f98e4e5997b3d4ecb83a1c5b0c9e49ab&h=libreoffice-6-0

tdf#119141 Revert "sc htmlimp: non-global sheet range names"

It will be available in 6.0.7.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 16 Xisco Faulí 2018-08-16 20:27:44 UTC
*** Bug 119306 has been marked as a duplicate of this bug. ***
Comment 17 Jean-Baptiste Faure 2018-08-18 07:41:06 UTC
*** Bug 119336 has been marked as a duplicate of this bug. ***
Comment 18 Xisco Faulí 2018-08-20 16:38:40 UTC
Verified in

Version: 6.2.0.0.alpha0+
Build ID: 401cba4c20fbc930f034168872642428d7459218
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: threaded

@Justin Luth, Thanks for fixing this!!
Comment 19 BogdanB 2018-08-20 19:39:54 UTC
The same, verified on Linux. It's ok.

Version: 6.2.0.0.alpha0+
Build ID: f05b0a6aaf8af5d78f9cad8bb953228cb0ce09f1
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2018-08-20_01:57:14
Locale: ro-RO (ro_RO.UTF-8); Calc: threaded
Comment 20 Dorian B. 2018-09-10 17:43:10 UTC
Hello!
I used Libreoffice Calc 6.1.0.3 Portable (in Romanian language) for Windows.
I confirm bug with menu Edit -> Links to External Files ...-> window Edit links -> Address External Data -> the list tables/range is EMPTY.
Don't update the cells with the external data with URLs and don't work "Enable Content" for "Automatic update of external links has been disabled".
 
In Libreoffice Calc 6.0.3.2 for Linux (in Romanian language), it's work External date with URLs.

Please fix this bug.

Thank you for understand.

Best regards,
Dorian Baciu
Comment 21 Aron Budea 2018-09-12 03:53:28 UTC
(In reply to Dorian B. from comment #20)
> I used Libreoffice Calc 6.1.0.3 Portable (in Romanian language) for Windows.
The fix has been pushed, and will be part of versions 6.1.1 and 6.0.7 (note the references in the Whiteboard field).
Comment 22 Justin L 2018-10-10 10:22:11 UTC
*** Bug 120352 has been marked as a duplicate of this bug. ***