Bug 123305 - Libreoffice rendering on HDPI displays blurred
Summary: Libreoffice rendering on HDPI displays blurred
Status: UNCONFIRMED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.1.4.2 release
Hardware: x86-64 (AMD64) other
: medium trivial
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: HiDPI
  Show dependency treegraph
 
Reported: 2019-02-10 12:58 UTC by war
Modified: 2019-03-15 13:37 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
LO 6.1.4 repo (560.36 KB, image/png)
2019-02-12 17:40 UTC, war
Details
LO 6.1.5 AppImage (944.38 KB, image/png)
2019-02-12 17:41 UTC, war
Details
LO 6.2.0 AppImage (551.64 KB, image/png)
2019-02-12 17:43 UTC, war
Details

Note You need to log in before you can comment on or make changes to this bug.
Description war 2019-02-10 12:58:32 UTC
Description:
Configuration:
Ubuntu 18.10, MacBook Pro Retina 13" (HDPI 2560x1600)
LibreOffice 6.1.4 (repo) and LibreOffice 6.2 (AppImage).

Several components of LO are rendered blurred:
- Toolbar icons
- Embedded OLE components
- Embedded images
- Table frames

Under Ubuntu 18.04 (LTS) LO 6.0.3 (from repo) did not show this.

The 6.1.4 AppImage did not show it either.
6.2 AppImage does not honour the installed theme (which LO 6.1.4 (repo) and 6.1.4 AppImage do).

Seems like a recursion bug related to screen rendering in LO

Steps to Reproduce:
1.Create a table in Calc
2.Embed in Writer as OLE
3.View results on screen

Actual Results:
Embedded objects are blurred
Toolbar and icons are blurred
Text in embedded objects is barely legible

Expected Results:
A sharp and crisp display (as was in LO 6.1.4 AppImage or 6.0.3 in Ubuntu 18.04)


Reproducible: Always


User Profile Reset: Yes



Additional Info:
I reported this serveral times on Canonicals Launchpad bugtracker.
The issue was closed every time with no improvement.

As this does not happen on Windows or MacOS the problem seems bound to Linux and HDPI displays (which will be ubiquitous in the future)
Comment 1 war 2019-02-12 17:40:55 UTC
Created attachment 149231 [details]
LO 6.1.4 repo

This image demonstrates correct theme but blurred icons and embedded documents (OK its thumbnails here but the result is the same)
Comment 2 war 2019-02-12 17:41:49 UTC
Created attachment 149232 [details]
LO 6.1.5 AppImage

This image demonstrates correct theme and correct icons and embedded documents (again thumbnails here but the result is the same)
Comment 3 war 2019-02-12 17:43:25 UTC
Created attachment 149233 [details]
LO 6.2.0 AppImage

Here the theme is incorrect (default) and the icons and thumbnails are blurred.

There is something regressing with alternate versions in the way you display content.
Comment 4 war 2019-02-12 17:44:20 UTC
The images demonstrate what I mean by "blurred" and "wrong theme"

I use a themed Gnome as one can see
Comment 5 war 2019-02-12 17:45:50 UTC
Just to prevent the question (Have you tried turing off custom themes):

Yes the same situation applies with both Yaru (new Ubuntu theme) and Ambient (old Ubuntu theme)
Comment 6 miltonh26 2019-02-15 04:26:07 UTC
Same for me except for 6.1.5.2 on Kubuntu 18.10 using DEB files. Fonts and toolbars were not rendered properly, thus LO was unusable. Before that tried 6.2.0.3 (also with DEB files) but had the same issue. Also attempted deleting configuration files and the issue was not corrected. Ended up reverting to the repos and reinstalled 1:6.1.4-0ubuntu0.18.10.1 which works well.