Bug Hunting Session
Bug 125009 - Rename tabbed layout to notebookbar
Summary: Rename tabbed layout to notebookbar
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: easyHack, needsDevEval, skillDesign, topicUI
: 125090 (view as bug list)
Depends on:
Blocks: UI
  Show dependency treegraph
 
Reported: 2019-04-28 12:01 UTC by andreas_k
Modified: 2019-05-17 04:52 UTC (History)
9 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description andreas_k 2019-04-28 12:01:22 UTC
In the media there is always notebook, but in the ui nb mean different layouts.

Can we say to tabbed notebookbar and tabbed compact notebookbar compact
Comment 1 Roman Kuznetsov 2019-04-28 18:57:28 UTC
changings for changings. We need stability in GUI
Comment 2 Thomas Lendo 2019-04-28 19:59:04 UTC
For me, Notebookbar is a marketing name, but it's not self-explanatory to be part of menus and tooltips.
Comment 3 andreas_k 2019-04-28 20:21:49 UTC
(In reply to Thomas Lendo from comment #2)
> For me, Notebookbar is a marketing name, but it's not self-explanatory to be
> part of menus and tooltips.

that's the problem Marketing promote Notebookbar but nobody can choose notebookbar anywhere. But you are true, it's not self-explanatory.
Comment 4 andreas_k 2019-04-28 20:22:51 UTC
(In reply to Roman Kuznetsov from comment #1)
> changings for changings. We need stability in GUI

Would be cool, but therefore you can find to much issues in the GUI.
Comment 5 Heiko Tietze 2019-04-29 10:18:46 UTC
Italo, what do you think? I don't like the term Notebookbar in the UI (neither around marketing) but agree on "Tabbed" being boring and not really vivid. 

Synonyms for "tabulate" are arrange, assort, catalog (or catalogue), categorize, classify, codify, diagram, enumerate, index, order, schematize, sort
analyze, anatomize, assay, break down, cut, deconstruct, dissect
assess, diagnose, evaluate, examine, inspect, investigate, scrutinize
divide, reduce, segment, separate, subdivide
(https://www.merriam-webster.com/thesaurus/tabulator)

How about "Verbose Catalogues" and "Compact Catalogues"? Native speakers are welcome here...
Comment 6 andreas_k 2019-04-29 10:44:06 UTC
In the past there was also muffin in marketing. But it is also not self explanation.
Comment 7 Roman Kuznetsov 2019-04-29 10:48:54 UTC
(In reply to Heiko Tietze from comment #5)
 
> How about "Verbose Catalogues" and "Compact Catalogues"? Native speakers are
> welcome here...

How about "Ribbon"?
Comment 8 Cor Nouws 2019-04-29 11:48:27 UTC
(In reply to Roman Kuznetsov from comment #7)

> How about "Ribbon"?
Recognizable ánd confusing - because it's not just that.

What about changing
  View > User Interface > ...
to
  View > Default/Side/Notebook bars > ...
(how ugly ..:\  )
Comment 9 V Stuart Foote 2019-04-29 13:43:31 UTC
(In reply to Cor Nouws from comment #8)
> (In reply to Roman Kuznetsov from comment #7)
> 
> > How about "Ribbon"?
> Recognizable ánd confusing - because it's not just that.
> 

The "Windows Ribbon Framework" is a Microsoft marketing name [1][2] for a Ribbon interface [3], originally marketed by Microsoft as their "Fluent UI".

While our MUFFIN Notebook Bar implements both a Ribbon (with Tab divisions), and the equally appealing Grouped bars--we do not otherwise implement the MS Windows Ribbon Framework--nor do we want to imply we do.  We be chasing our tail to implement missing "essentials" coming from Microsoft's flavor.

> What about changing
>   View > User Interface > ...
> to
>   View > Default/Side/Notebook bars > ...
> (how ugly ..:\  )

No, we need to keep the View -> User Interface list selection (see reasoning in bug 115131, or bug 108099).  

If we had to do something (and not clear we do), let's hit users in the face with MUFFIN!

View -> User Interface

   Standard Toolbars
   ---MUFFIN---
   Single Toolbar
   Sidebar
   Tabbed
   Groupedbar Compact

or with Experimental Features enabled

   Standard Toolbars
   ---MUFFIN---
   Single Toolbar
   Sidebar
   Contextual groups
   Contextual Single
   -------------------
   Tabbed
   Tabbed Compact
   Groupedbar
   Groupedbar Compact

or some such.

=-ref-=
[1] https://docs.microsoft.com/en-us/windows/desktop/windowsribbon/windowsribbon-introduction
[2] https://docs.microsoft.com/en-us/windows/desktop/uxguide/cmd-ribbons
[3] https://en.wikipedia.org/wiki/Ribbon_(computing)
Comment 10 Heiko Tietze 2019-04-29 14:01:07 UTC
(In reply to V Stuart Foote from comment #9)
>    Standard Toolbars
>    ---MUFFIN---
>    Single Toolbar

A non-clickable menu entry with text? That will be a challenge both for dev as well as users.
Comment 11 V Stuart Foote 2019-04-29 14:04:35 UTC
(In reply to V Stuart Foote from comment #9)
> ... 108099).  

s/ 108099/ bug 106470 /
Comment 12 V Stuart Foote 2019-04-29 14:06:20 UTC
(In reply to Heiko Tietze from comment #10)
> (In reply to V Stuart Foote from comment #9)
> >    Standard Toolbars
> >    ---MUFFIN---
> >    Single Toolbar
> 
> A non-clickable menu entry with text? That will be a challenge both for dev
> as well as users.

Also known as a menu separator... which could be text based or a graphic.
Comment 13 andreas_k 2019-05-10 07:34:04 UTC
*** Bug 125090 has been marked as a duplicate of this bug. ***
Comment 14 Heiko Tietze 2019-05-13 14:13:12 UTC
Asked on the marketing list and the recommendation is to go with "Tabbed Notebookbar".
Comment 15 andreas_k 2019-05-15 07:28:41 UTC
(In reply to Heiko Tietze from comment #14)
> Asked on the marketing list and the recommendation is to go with "Tabbed
> Notebookbar".

For readability I would recommend
- Notebookbar Tabbed
- Notebookbar Tabbed compact

And for Toolbars
- Toolbar Standard
- Toolbar Single
- Sidebar
Comment 16 Italo Vignoli 2019-05-15 08:07:29 UTC
I am fine with the names suggested by Andreas Kainz
Comment 17 Heiko Tietze 2019-05-15 17:40:58 UTC
So let's go with Andreas' proposal in comment 15 (personally I don't like it).
Comment 18 Roman Kuznetsov 2019-05-15 17:43:15 UTC
(In reply to andreas_k from comment #15)
> (In reply to Heiko Tietze from comment #14)
> > Asked on the marketing list and the recommendation is to go with "Tabbed
> > Notebookbar".
> 
> For readability I would recommend
> - Notebookbar Tabbed
> - Notebookbar Tabbed compact
> 
> And for Toolbars
> - Toolbar Standard
> - Toolbar Single
> - Sidebar

Let's delete Sidebar from this submenu. There is the same item just in View
Comment 19 Samuel Mehrbrodt (CIB) 2019-05-16 08:10:05 UTC
Please beware that "Tabbed Notebookbar" is redundant.
Notebook is an alias for tab. So Tabbed Tabbar is what this really means.
Comment 20 andreas_k 2019-05-16 14:30:32 UTC
Can i close this bug as WFM. Cause we work on configure nb and l prefer that toolbars and nb are different for an developer but for users it should be only an other layout. So after this discussion l think its better to dont add notebookbar.
Comment 21 Heiko Tietze 2019-05-16 14:32:39 UTC
(In reply to andreas_k from comment #20)
> Can i close this bug as WFM. Cause we work on configure nb and l prefer that
> toolbars and nb are different for an developer but for users it should be
> only an other layout. So after this discussion l think its better to dont
> add notebookbar.

It was your request, feel free to resolve as wfm or fix it.