Bug 130654 - Allow defining font size for Math formula input box -- 'smeditwindowzoom' expert config stanza
Summary: Allow defining font size for Math formula input box -- 'smeditwindowzoom' exp...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Formula Editor (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium enhancement
Assignee: dante19031999
URL:
Whiteboard: target:7.2.0
Keywords: accessibility
: 134077 (view as bug list)
Depends on:
Blocks: HelpGaps-NewFeatures Options-Dialog-View
  Show dependency treegraph
 
Reported: 2020-02-14 11:08 UTC by veniero facchetti
Modified: 2021-08-04 14:16 UTC (History)
9 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description veniero facchetti 2020-02-14 11:08:52 UTC
visually impaired children have very difficult to write inside the formula area because its not possible increase the character dimension or zoom inside the pert of screen of the formula writer area.
Comment 1 Buovjaga 2020-05-10 10:04:47 UTC
Let's ask UX how the font size could be controlled. Tools - Options - LibreOffice - Fonts has "Font settings for HTML, Basic and SQL sources". Maybe the formula input field font should be tied to this as well? It seems the use case is identical.
Comment 2 V Stuart Foote 2020-05-10 14:14:21 UTC
No progress on bug 101646 has been made.

Alternatively, one of its dupes, bug 67372, to allow setting font and size of UI elements is another approach. 

Unfortunately the os/DE provided scaling [1] of only fonts is hit or miss for being passed through to the LibreOffice UI panels.

Menu fonts will increase in size, and scaling will be applied to some UI text elements like the 'Formula Bar' in Calc, but not to others like the 'Command window' in the sm Formula editor here.

Short of the major re-implementation of GUI scaling for bug 101466 seems there are 
two approaches to enhance the sm Formula editor: (1) user control of the 'Command window' font size; (2) expose the sm Formula editor's 'Command window' to the os/DE font management (as occurs for Calc's 'Formula Bar'.

=-ref-=
[1] https://ask.libreoffice.org/en/question/146190/increase-font-size-of-calc-formula-toolbar-in-libreoffice-version-6/
Comment 3 Heiko Tietze 2020-05-11 15:59:00 UTC
I would expect the dialog to use the system font which is larger for users with impairments. If we really introduce a font size option it's better placed on the respective module. Like Basic Fonts on Writer it would be Fonts under Charts with just one field for the formula editor.
Comment 4 V Stuart Foote 2020-05-11 16:18:17 UTC
(In reply to Heiko Tietze from comment #3)
> I would expect the dialog to use the system font which is larger for users
> with impairments. If we really introduce a font size option it's better
> placed on the respective module. Like Basic Fonts on Writer it would be
> Fonts under Charts with just one field for the formula editor.

Sure, but remember this is not a dialog. It is a GUI component of the sm Formula module, internally controlled in src.

Somehow the sc Calc Formula Bar is picking up the system font, but seemingly not at the os/DE specified size.

Allowing GUI scaling control by module (text and graphical elements) would be great--and of benefit to accessibility. Or ideally assuring the GUI responds to os/DE a11y theme accomodation--but we know that is a major challenge. Here just getting the sm Fomula modules 'Command window' to pick up font size change (ours or os/DE) is a good start.
Comment 5 Heiko Tietze 2020-05-28 12:36:24 UTC
Was thinking about something like "Basic Fonts" in Writer for all modules. 

But anyway, let's introduce just this "Font size: <10>" option under Tools > Options > Math > Misc (not much to configure here).
Comment 6 Regina Henschel 2020-05-28 13:55:27 UTC
"Font size" is not specific enough. It can be confused with the default font size of formulas.

I suggest a section similar to the existing "Font Settings for HTML, Basic and SQL Sources" of LibreOffice>Fonts. It could be placed in LibreOffice>Fonts or in Math. If the tab in Math has not enough place, make two tabs, one for "Print" and one for "Miscellaneous".
Comment 7 V Stuart Foote 2020-05-28 15:41:10 UTC
(In reply to Heiko Tietze from comment #5)
> Was thinking about something like "Basic Fonts" in Writer for all modules. 
> 
> But anyway, let's introduce just this "Font size: <10>" option under Tools >
> Options > Math > Misc (not much to configure here).

Actually sm already has its own Font panels similar to function of Writer's (Western, Asian, CTL) Basic fonts--but as there, they control the font rendering to canvas of sm formula nodes.

Addition to Tools -> Options -> LibreOffice Math -> Settings in a 'Miscellaneous Options' block would be best specific location for this control.

This needed UX enhancement is for controlling font (size and family) used in the sm Math module's 'Command Window' input GUI.  We actually have bug 95406 open for similar in the sc Formula Bar. 

But makes one wonder if we could do a better job on the Tools -> Options -> LibreOffice -> Accessibility panel and control this across the UI as an assistive technology? I.e. override os/DE specified font size and otherwise bump up any hard coded size in src/xml. 

But we probably want to avoid the churn we had in the sc Formula Bar at 6.3 for bug 127066 -- and as asked there, is this appropriate to do piecemeal (maybe for this one) or by maybe solving bug 101646?
Comment 8 veniero facchetti 2020-05-28 16:24:48 UTC
if i click on plus button on bottom of the screen (zoom setting) i have an increase of the font of the center of the page. it's not possible increase also the font of this panel without add more setting?
Comment 9 V Stuart Foote 2020-05-28 16:54:20 UTC
(In reply to veniero facchetti from comment #8)
> if i click on plus button on bottom of the screen (zoom setting) i have an
> increase of the font of the center of the page. it's not possible increase
> also the font of this panel without add more setting?

Yes unfortunately that is the state of things.

 No means to adjust the StarMath Formula editor's GUI to use a larger font for input in its 'Command Window'. 

The LibreOffice UI already allows you to resize the resulting formula (both its screen size, and its actual in document size) but it provides no means to adjust the size of the font in the 'Command Window' input panel beyond operating system scaling of the users Desktop environment. Scaling which makes the UI buttons, the objects on the Elements Bar, and menu items all move to new relative positions.

In this instance assigning a font control for use on the 'Command Window' is the cleaner UI adjustment.
Comment 10 V Stuart Foote 2020-06-17 20:44:38 UTC
*** Bug 134077 has been marked as a duplicate of this bug. ***
Comment 11 Mike Kaganski 2021-04-30 09:43:31 UTC
Sorry, isn't this a task for our zoon control, available in View and in bottom right of status bar? That would be consistent across the modules, no? Just using that control also for the font in the formula source looks reasonable for me. I feel that introducing another control for this task (as seems to be what https://gerrit.libreoffice.org/c/core/+/114616 prepares) is overkill.
Comment 12 V Stuart Foote 2021-04-30 13:36:31 UTC
(In reply to Mike Kaganski from comment #11)
> Sorry, isn't this a task for our zoon control, available in View and in
> bottom right of status bar? That would be consistent across the modules, no?
> Just using that control also for the font in the formula source looks
> reasonable for me. I feel that introducing another control for this task (as
> seems to be what https://gerrit.libreoffice.org/c/core/+/114616 prepares) is
> overkill.

Don't know. Seems we'd need two zoom bars done that way? Current zoom bar controls the resulting formula canvas, would still need that independent of a zoom applied to the input formula bar. 

But if mechanism to scale/control the input formula bar can be reused independently for the input bar, and is simpler to maintain--dev's choice. 

We wouldn't need a zoom bar widget though, just an increase and decrease button on the input bar, and some way to set it from the LO Math options dialog.
Comment 13 dante19031999 2021-04-30 14:03:24 UTC
Adding an stroller to the settings pane isn't complicated.
Doesn't need to be very accessible. It's an once in a lifetime setting.
Comment 14 dante19031999 2021-04-30 17:16:20 UTC
This patch contains a solution:
https://gerrit.libreoffice.org/c/core/+/114943/4

It only has access by advanced configuration.
http://org.openoffice.office.math.smeditwindowzoom/

If the patch is accepted an entry will be added in math settings.
Comment 15 Commit Notification 2021-05-15 06:16:38 UTC
dante committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/7beb507edbf94627c639483175be730f38f90dcd

tdf#130654 editable smeditwindow zoom

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 16 V Stuart Foote 2021-05-16 21:11:59 UTC
The Tools -> Options -> Advanced "Open Expert Configuration" stanza search for "smeditwindowzoom" works great--the 10 <--> 1000 scale value from default of 100 should satisfy any user.

Thanks Dante!

Guess this will need some mention in the Math help, and the UG.

=-testing-=

Version: 7.2.0.0.alpha1+ (x64) / LibreOffice Community
Build ID: 58b0c95ad50139a62bddb348d10f94053c09cd5b
CPU threads: 8; OS: Windows 10.0 Build 19042; UI render: Skia/Vulkan; VCL: win
Locale: en-US (en_US); UI: en-US
Calc: threaded
Comment 17 dante19031999 2021-05-16 21:20:06 UTC
I'm changing it back to new because it isn't over.
There's this in the to merge: https://gerrit.libreoffice.org/c/core/+/115605/6
It's an entry to the setting from math config pane.

The expert config is fine, but the mid user won't be able to change it.
Comment 18 V Stuart Foote 2021-05-16 21:37:03 UTC
(In reply to dante19031999 from comment #17)
> I'm changing it back to new because it isn't over.
> There's this in the to merge:
> https://gerrit.libreoffice.org/c/core/+/115605/6
> It's an entry to the setting from math config pane.
> 
> The expert config is fine, but the mid user won't be able to change it.

Sure, a GUI widget in the Tools -> Options -> LO Math settings panel will be helpful.
Comment 19 Heiko Tietze 2021-05-17 07:10:50 UTC
Another tools > option is nice but I wonder how to make this easy accessible having the usual zoom in mind.
Another slider in the statusbar would be awkward but perhaps the number and a slider widget on click. Plus wheel interaction at the edit area. It would be easier if the configuration is done via font size (12, 18, 24pt...).
Comment 20 V Stuart Foote 2021-05-17 14:01:41 UTC
(In reply to Heiko Tietze from comment #19)
> ...
> be easier if the configuration is done via font size (12, 18, 24pt...).

not really, the whole frame is being scaled. Default font (Liberation Mono at 12pt) is the 100 of the zoom scale.  And as Dante suggests, this is really a set and forget value, it requires an LO restart to apply. A GUI control on the input window would not function well here.

When added to the Options -> Math panel, a series font point sizes would have to be interpreted back to a zoom percentage. Most folks are familiar now with the os/DE provided "scale" ranges. So, don't really have the dependencies on a font point size that we used to.
Comment 21 Commit Notification 2021-05-28 08:57:46 UTC
dante committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/1a0fd1c1342969e5b4d08d13764483cd8bada589

tdf#130654 editable smeditwindow zoom UI

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 22 Roman Kuznetsov 2021-08-04 14:16:10 UTC
verified in

Version: 7.3.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: ac80ec817eb07c77a51bc0729985a473c734182e
CPU threads: 8; OS: Windows 10.0 Build 19043; UI render: Skia/Vulkan; VCL: win
Locale: ru-RU (ru_RU); UI: en-US
Calc: threaded