Bug 131188 - FILEOPEN: PPTX: Incorrect colour in chart's label
Summary: FILEOPEN: PPTX: Incorrect colour in chart's label
Status: RESOLVED DUPLICATE of bug 134977
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
6.1 all versions
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, filter:pptx, regression
Depends on:
Blocks: OOXML-Chart
  Show dependency treegraph
 
Reported: 2020-03-06 14:35 UTC by Xisco Faulí
Modified: 2020-08-10 07:43 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Screenshot of the document in PP and todays nightly version (175.80 KB, image/png)
2020-08-10 07:41 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2020-03-06 14:35:09 UTC
Steps to reproduce:
1. Open attachment 158424 [details] from bug 131168

-> 'one vendor' label is black instead of white. How it looks in MS Powerpoint -> attachment 158425 [details]

Reproduced in

Version: 7.0.0.0.alpha0+
Build ID: bdfd0feefe3785e1ea68bf1f1f987147c8fe9335
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded
Comment 1 Xisco Faulí 2020-03-06 14:36:45 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=790f9abeb1a1167ad5ab84c5fb855b36669c125b

author	Szymon Kłos <szymon.klos@collabora.com>	2018-01-04 22:15:32 +0100
committer	Szymon Kłos <szymon.klos@collabora.com>	2018-01-29 23:49:42 +0100
commit 790f9abeb1a1167ad5ab84c5fb855b36669c125b (patch)
tree dea7c957b67be7518d2092614b82f18148817265
parent a1f933ee2b9e23a505d937035821e9571cf4119c (diff)
tdf#114821 import complex data labels in bar chart

Bisected with: bibisect-linux64-6.1

Adding Cc: to Szymon Kłos
Comment 2 Timur 2020-03-06 14:44:31 UTC
Looks Black but if you edit it shows White.
Comment 3 Timur 2020-03-13 10:35:26 UTC Comment hidden (obsolete)
Comment 4 Timur 2020-07-17 16:43:12 UTC
More color issues here:

1. open attachment 158424 [details] in LO
2a. "0-1 vendor 38%" is black in LO while white in MSO
2b. change normal Pie to Donut (or Exploded Donut) - see that "3 vendors 12%" is black text on dark blue background (hardly readable), so incorrect color issue remains. 
2c. change chart type to stacked bar - "3 vendors 12%" is black text on dark blue background
2d. change chart type to normal bar - can't see "2 vendors 25%" because the label is rendered white on white

Note: 
I first tried to make PPTX in MSO by adding slides with Clustered bar and Stacked bar, but it looks wrong already in MSO. So steps are to just change in LO.
Comment 5 Tünde Tóth 2020-08-07 10:00:10 UTC

*** This bug has been marked as a duplicate of bug 134977 ***
Comment 6 NISZ LibreOffice Team 2020-08-10 07:41:11 UTC
Created attachment 164087 [details]
Screenshot of the document in PP and todays nightly version

Version: 7.1.0.0.alpha0+ (x86)
Build ID: <buildversion>
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: hu-HU (hu_HU); UI: en-US
Calc: CL

Build is from: 2020-08-08 03:16:08
Comment 7 NISZ LibreOffice Team 2020-08-10 07:43:12 UTC
(In reply to Timur from comment #4)
> More color issues here:
> 
> 1. open attachment 158424 [details] in LO
> 2a. "0-1 vendor 38%" is black in LO while white in MSO

This is now solved.

> 2b. change normal Pie to Donut (or Exploded Donut) - see that "3 vendors
> 12%" is black text on dark blue background (hardly readable), so incorrect
> color issue remains. 
> 2c. change chart type to stacked bar - "3 vendors 12%" is black text on dark
> blue background
> 2d. change chart type to normal bar - can't see "2 vendors 25%" because the
> label is rendered white on white
> 

These also happen in PowerPoint (just tried) so I'd not consider them a bug.