Bug 133775 - UI: Copy about text translated too
Summary: UI: Copy about text translated too
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
7.1.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 134608 (view as bug list)
Depends on:
Blocks: About-Dialog
  Show dependency treegraph
 
Reported: 2020-06-07 20:03 UTC by Telesto
Modified: 2020-07-07 21:07 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2020-06-07 20:03:12 UTC
Description:
UI: Copy about text translated too

Steps to Reproduce:
1. Open LibreOffice
2. Help -> About -> Copy version information

Actual Results:
Translated (see below)

Expected Results:
No translated


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.1.0.0.alpha0+ (x64)
Build ID: 191288d6a7fb52b31038a21c4e71ee57ffa3bacd
CPU-threads: 4; Besturingssysteem: Windows 6.3 Build 9600; UI-render: standaard; VCL: win
Locale: nl-NL (nl_NL); GI: nl-NL
Calc: CL
Comment 1 Telesto 2020-06-07 20:04:28 UTC
@Heiko
They button has the purpose to copy/paste untranslated info..
Comment 2 Heiko Tietze 2020-06-08 08:17:08 UTC
To drop localization of system information was requested in bug 132066. Meaning to Copy Version Info is intentionally English only. Plus, without use case, scenario, goals this request like any other makes not much sense.

The button itself supports a11y, see bug 132179.
Comment 3 Telesto 2020-06-08 08:42:40 UTC
(In reply to Heiko Tietze from comment #2)
> To drop localization of system information was requested in bug 132066.
> Meaning to Copy Version Info is intentionally English only. Plus, without
> use case, scenario, goals this request like any other makes not much sense.
> 
> The button itself supports a11y, see bug 132179.

Meaning to Copy Version Info is intentionally English only.
-> It should be, but it isn't
Comment 4 Heiko Tietze 2020-06-08 08:47:17 UTC
The content is mostly untranslated. The few remaining terms (see bug 132066 comment 18 are not worth the effort). So my take => NAB.
Comment 5 Telesto 2020-06-10 09:11:12 UTC
Version: 7.1.0.0.alpha0+ (x64)
Build ID: 59939d2490726336546c7ad05082d23031074e12
CPU-threads: 4; Besturingssysteem: Windows 6.3 Build 9600; UI-render: Skia/Rooster; VCL: win
Locale: nl-NL (nl_NL); GI: nl-NL
Calc: CL

Version: 7.0.0.0.beta1+ (x64)
Build ID: 22cb73dcc682edb15a2425339377ff54dde5dba6
Потоков ЦП: 4; ОС: Windows 6.3 Build 9600; Отрисовка ИП: Skia/Vulkan; VCL: win
Locale: nl-NL (nl_NL); ИП: ru-RU
Calc: CL

Version: 7.0.0.0.beta1+ (x64)
Build ID: 22cb73dcc682edb15a2425339377ff54dde5dba6
CPU-säikeet: 4; Käyttöjärjestelmä: Windows 6.3 Build 9600; Käyttöliittymän piirtäminen: Skia/Vulkan; VCL: win
Locale: nl-NL (nl_NL); UI: fi-FI
Calc: CL

Some requests
1. Don't translate UI-render/ CPU-threads/ Operating system. Makes the layout/placing of the items unpredictable -> makes it 'harder'/ more time consuming to read 
2. The UI-render options shouldn't be translated.. "Rooster" should be Raster. Without Skia you get 'standaard' which should be "default" -> really needed
Comment 6 Heiko Tietze 2020-06-10 10:01:02 UTC
In cui/source/dialog/about.cxx function IMPL_LINK_NOARG(AboutDialog, HandleClick, weld::Button &, void) the two strings m_pEnvLabel and m_pUILabel are taken from the actual label. These labels are assigned via vcl/source/app/svapp.cxx Application::GetHWOSConfInfo() using VclResId() for l10n. No idea how to retranslate. And the function is also used in updatefeed.cxx so we cannot just cut l10n.

=> not worth the effort
Comment 7 Xisco Faulí 2020-06-15 14:46:56 UTC
(In reply to Heiko Tietze from comment #6)
> In cui/source/dialog/about.cxx function IMPL_LINK_NOARG(AboutDialog,
> HandleClick, weld::Button &, void) the two strings m_pEnvLabel and
> m_pUILabel are taken from the actual label. These labels are assigned via
> vcl/source/app/svapp.cxx Application::GetHWOSConfInfo() using VclResId() for
> l10n. No idea how to retranslate. And the function is also used in
> updatefeed.cxx so we cannot just cut l10n.
> 
> => not worth the effort

Closing as RESOLVED WONTFIX based on the comment
Comment 8 Heiko Tietze 2020-07-07 12:29:36 UTC
*** Bug 134608 has been marked as a duplicate of this bug. ***
Comment 9 Mike Kaganski 2020-07-07 21:07:27 UTC
(In reply to Heiko Tietze from comment #6)
> In cui/source/dialog/about.cxx function IMPL_LINK_NOARG(AboutDialog,
> HandleClick, weld::Button &, void) the two strings m_pEnvLabel and
> m_pUILabel are taken from the actual label. These labels are assigned via
> vcl/source/app/svapp.cxx Application::GetHWOSConfInfo() using VclResId() for
> l10n. No idea how to retranslate. And the function is also used in
> updatefeed.cxx so we cannot just cut l10n.
> 
> => not worth the effort

Please make it clean and pretty.

To translate that in Application::GetHWOSConfInfo, just add the second variant of VclResId to vcl/source/app/svdata.cxx (and resp. header):


> OUString VclResId(const char* pId, const OUString& rsBcp47LanguageTag)
> {
>     return Translate::get(pId, Translate::Create("vcl", LanguageTag(rsBcp47LanguageTag)));
> }

... and add respective argument to Application::GetHWOSConfInfo. Depending if you put there an empty string or "en-US", it would you either the default VclResId, or the new one.

The "not worth the effort" and WONTFIX are wrong, that's not pretty with a doable fix.