Bug 134752 - Empty pages after enabled/disabling show tracking changes
Summary: Empty pages after enabled/disabling show tracking changes
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.2.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: notBibisectable, regression
Depends on:
Blocks: Track-Changes redlinehide-regressions
  Show dependency treegraph
 
Reported: 2020-07-12 15:48 UTC by Telesto
Modified: 2021-06-22 12:17 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2020-07-12 15:48:12 UTC
Description:
Empty pages after enabled/disabling show tracking changes

Steps to Reproduce:
1. Open attachment 162927 [details] bug 134746
2. Edit -> Track and Changes -> Show
3. Edit -> Track and Changes -> Show

Actual Results:
Empty pages (different multi page view/single page view/ version

Expected Results:
No empty pages


Reproducible: Always


User Profile Reset: No



Additional Info:
Found in
Version: 7.1.0.0.alpha0+ (x64)
Build ID: c48e4d795e37f23b71d647247590807ab9e52223
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL

Version: 6.4.0.0.beta1+ (x64)
Build ID: 20be5cd0bdc57d812bf34a2debfe48caa51de881
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: GL; VCL: win; 
Locale: nl-NL (nl_NL); UI-Language: en-US
Calc: CL
Comment 1 Telesto 2020-07-12 15:51:54 UTC
Also in
Version: 6.2.9.0.0+ (x86)
Build ID: 5f01fe15eb2661f1f9ce12d1d99dc2a705b462ee
CPU threads: 4; OS: Windows 6.3; UI render: default; VCL: win; 
Locale: nl-NL (nl_NL); UI-Language: en-US
Calc: CL

but not in
6.2 oldest
Comment 2 Aron Budea 2020-07-18 20:56:49 UTC
Confirmed with LO 7.1.0.0.alpha0+ (fa844c15233f108a0e9b0b2e8c9757c1aa088a4b) / Ubuntu.

Bibisected to the 6.2 backport of the following commit using repo bibisect-linux-64-6.2. Other, currently open regressions pointing to the same commit are bug 133967 and bug 134770. Adding CC: to Michael Stahl.

https://cgit.freedesktop.org/libreoffice/core/commit/?id=32902f66e7749b2d06d13f50416be5323a0c0ea9
author		Michael Stahl <Michael.Stahl@cib.de>	2018-11-30 17:54:41 +0100
committer	Michael Stahl <Michael.Stahl@cib.de>	2018-12-18 17:55:30 +0100

sw_redlinehide: make layout based Show/Hide mode the default
Comment 3 Aron Budea 2021-03-20 06:52:56 UTC
Further bibisecting with experimental mode yielded no useful results, as opening the file crashes in a large range in between.

Stops crashing here, but already bad:
https://cgit.freedesktop.org/libreoffice/core/commit/?id=f609eba8b979620dc8f1c4a47d710360f8aae9e6
author		Michael Stahl <Michael.Stahl@cib.de>	2018-10-09 14:49:23 +0200
committer	Michael Stahl <Michael.Stahl@cib.de>	2018-11-15 15:09:58 +0100

"sw_redlinehide_3: convert even more SwAccessibleParagraph functions"

Starts crashing here:
https://cgit.freedesktop.org/libreoffice/core/commit/?id=ae3150b1e1863e854224c2e41c7e50991f945dad
author		Michael Stahl <Michael.Stahl@cib.de>	2018-09-17 12:01:46 +0200
committer	Michael Stahl <Michael.Stahl@cib.de>	2018-09-19 10:18:33 +0200

"sw_redlinehide_2: replace SW_REDLINEHIDE with ExperimentalMode config"
Comment 4 NISZ LibreOffice Team 2021-06-22 12:17:18 UTC
I can't reproduce this in 7.2 since:

https://git.libreoffice.org/core/+/eb85de8e6b61fb3fcb6c03ae0145f7fe5478bccf

author	Michael Stahl <michael.stahl@allotropia.de>	Tue Apr 13 20:13:51 2021 +0200
committer	Michael Stahl <michael.stahl@allotropia.de>	Mon Apr 19 17:22:06 2021 +0200

sw: layout: if fly's anchor moves forward, move fly off SwPageFrame

In 7.0 the initial 13 pages grew to 15 after showing/hiding tracked changes, in 7.1 it grew only to 14, after this commit the number of pages stays 13.

Thanks Michael for fixing this one :)